[jitsi-dev] Bug report: jitsi 2.0 crushed with libjunbound.so: undefined symbol: SSL_CTX_free


#1

jitsi-2.0-4506.10553.x86_64.rpm
jitsi-2.1-4509.10562.x86_64.rpm

ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib64/alsa-lib/libasound_module_pcm_a52.so
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib64/alsa-lib/libasound_module_pcm_a52.so
ALSA lib alsaplugin.c:177:(_snd_pcm_dca_open) dca is only for playback
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Fontconfig warning: "/etc/fonts/conf.d/65-4-sazanami-gothic.conf", line 8: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-4-sazanami-mincho.conf", line 8: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-google-droid-sans.conf", line 61: Having multiple values in <test> isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/conf.d/65-google-droid-sans.conf", line 96: Having multiple values in <test> isn't supported and may not work as expected
/usr/bin/java: symbol lookup error: /usr/share/jitsi/lib/native/libjunbound.so: undefined symbol: SSL_CTX_free

java -version
java version "1.7.0_06-icedtea"
OpenJDK Runtime Environment (mageia-2.3.8.1.mga3-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

openssl-1.0.1e

jitsi-1.0-build.3967.x86_64.rpm - work well on same PC.


#2

Thanks for the report.

/usr/share/jitsi/lib/native/libjunbound.so: undefined symbol: SSL_CTX_free

java -version
java version "1.7.0_06-icedtea"
OpenJDK Runtime Environment (mageia-2.3.8.1.mga3-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

openssl-1.0.1e

jitsi-1.0-build.3967.x86_64.rpm - work well on same PC.

What OS and version are you using?

You're having DNSSEC enabled I guess? Disabling it should at least make Jitsi work until we fixed this. You can do this manually by setting net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false in the config file (or removing the line entirely).

Regards,
Ingo


#3

07.03.2013 13:06, Ingo Bauersachs пишет:

Thanks for the report.

/usr/share/jitsi/lib/native/libjunbound.so: undefined symbol: SSL_CTX_free

java -version
java version "1.7.0_06-icedtea"
OpenJDK Runtime Environment (mageia-2.3.8.1.mga3-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

openssl-1.0.1e

jitsi-1.0-build.3967.x86_64.rpm - work well on same PC.

What OS and version are you using?

You're having DNSSEC enabled I guess?

Yes, you are right.

net.java.sip.communicator.util.dns.DNSSEC_ENABLED=true

Your suggestion has helped to solve the problem.
I will wait bug fixes to DNSSEC subsystem.
Mageia 3 Linux.

···

Disabling it should at least make Jitsi work until we fixed this. You can do this manually by setting net.java.sip.communicator.util.dns.DNSSEC_ENABLED=false in the config file (or removing the line entirely).

Regards,
Ingo