[jitsi-dev] Bug of video streaming


#1

Dear Team,

Today I've just found a really huge bug about the video streaming.

I have 4 server:
+) In server 1, I installed Jitsi-meet and nginx.
+) In server 2, I installed Prosody and Jicofo and nginx
+) In server 3 and 4: I installed Jvb 1 and Jvb2.

When 4 people join a class. But only 1 people turn on the camera, all other
3 people have same problems to see that only 1 camera. The log is: The
user1 has problem connecting issue. But, one by one other 3 people turn on
the camera, the connection of each person that turned the camera on is good
again (that person can see the first camera). Then one by one 3 other
people turn the camera off, the connection still good.

Right now, Im using the old version of Jitsimeet (release about 7/2017).
The jitsi video bridge version is 930 and the version of Jicofo is the same
as the time jvb 930 release.

Is this problem cause I'm using the old version of Jitsi. Thank you so
much.


#2

Hi,

It is possible that this is fixed in the newer versions. You can try
reproducing that scenario on meet.jit.si and see whether you experience it
there.
There were a lot of changes in jitsi-meet and in jitsi-videobridge since
the versions you use.

Regards
damencho

···

On Fri, Apr 13, 2018 at 6:40 AM, Trần Hoài Nam <namth4@topica.edu.vn> wrote:

Dear Team,

Today I've just found a really huge bug about the video streaming.

I have 4 server:
+) In server 1, I installed Jitsi-meet and nginx.
+) In server 2, I installed Prosody and Jicofo and nginx
+) In server 3 and 4: I installed Jvb 1 and Jvb2.

When 4 people join a class. But only 1 people turn on the camera, all
other 3 people have same problems to see that only 1 camera. The log is:
The user1 has problem connecting issue. But, one by one other 3 people turn
on the camera, the connection of each person that turned the camera on is
good again (that person can see the first camera). Then one by one 3 other
people turn the camera off, the connection still good.

Right now, Im using the old version of Jitsimeet (release about 7/2017).
The jitsi video bridge version is 930 and the version of Jicofo is the same
as the time jvb 930 release.

Is this problem cause I'm using the old version of Jitsi. Thank you so
much.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev


#3

Thank you so much. i’ve upgrade the newer version and problems solved

···

On Tue, Apr 17, 2018 at 3:53 AM Damian Minkov <damencho@jitsi.org> wrote:

Hi,

It is possible that this is fixed in the newer versions. You can try
reproducing that scenario on meet.jit.si and see whether you experience
it there.
There were a lot of changes in jitsi-meet and in jitsi-videobridge since
the versions you use.

Regards
damencho

On Fri, Apr 13, 2018 at 6:40 AM, Trần Hoài Nam <namth4@topica.edu.vn> > wrote:

Dear Team,

Today I've just found a really huge bug about the video streaming.

I have 4 server:
+) In server 1, I installed Jitsi-meet and nginx.
+) In server 2, I installed Prosody and Jicofo and nginx
+) In server 3 and 4: I installed Jvb 1 and Jvb2.

When 4 people join a class. But only 1 people turn on the camera, all
other 3 people have same problems to see that only 1 camera. The log is:
The user1 has problem connecting issue. But, one by one other 3 people turn
on the camera, the connection of each person that turned the camera on is
good again (that person can see the first camera). Then one by one 3 other
people turn the camera off, the connection still good.

Right now, Im using the old version of Jitsimeet (release about 7/2017).
The jitsi video bridge version is 930 and the version of Jicofo is the same
as the time jvb 930 release.

Is this problem cause I'm using the old version of Jitsi. Thank you so
much.

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev