[jitsi-dev] bcprov-jdk15on 1.51-jitsi-1


#1

Hi,

I'm looking for the source (modified pom included) that were used to
generate bcprov-jdk15on 1.51-jitsi-1.

Also we use multiple versions of this artifact:
jicofo, jitsi-videobridge and jitsi-certificate are using 1.51-jitsi-1,
libjitsi, zrtp4j and jicofo uses jitsi-universe version (1.51)
bccontrib uses 1.48

Can we use 1.51-jitsi-1 everywhere?

I found that while I was doing cleanup of the pom files to remove version
already in jitsi-universe

Regards
Etienne


#2

jicofo, jitsi-videobridge and jitsi-certificate are using 1.51-jitsi-1,

1.51-jitsi-1 contains a patch required by jitsi-videobridge which fixes a DTLS issue with Firefox. The projects bellow shouldn’t need it.

libjitsi, zrtp4j and jicofo uses jitsi-universe version (1.51)
bccontrib uses 1.48

With the reason mentioned above, I don’t see why we’d want zrt4j or bccontrib to depend on 1.51-jitsi-1.

···

On Jan 6, 2016, at 1:01 PM, Etienne Champetier <champetier.etienne@gmail.com> wrote:


#3

Oh, I totally missed that line, I’m sorry. https://github.com/jitsi/jitsi-maven-repository/tree/master/releases/org/bouncycastle/bcprov-jdk15on says: Deploys bcprov from the branch r1rv51-patched of gpolitis/bc-java (at GitHub). I think I used BouncyCastle’s own Ant support and then deployed the resulting binary file.

···

On Jan 6, 2016, at 1:01 PM, Etienne Champetier <champetier.etienne@gmail.com> wrote:
I'm looking for the source (modified pom included) that were used to generate bcprov-jdk15on 1.51-jitsi-1.


#4

> jicofo, jitsi-videobridge and jitsi-certificate are using 1.51-jitsi-1,

1.51-jitsi-1 contains a patch required by jitsi-videobridge which fixes a

DTLS issue with Firefox. The projects bellow shouldn’t need it.

> libjitsi, zrtp4j and jicofo uses jitsi-universe version (1.51)
> bccontrib uses 1.48

With the reason mentioned above, I don’t see why we’d want zrt4j or

bccontrib to depend on 1.51-jitsi-1.

Thanks for the explanation.
I'm still looking for the exact source code though

···

Le 6 janv. 2016 21:42, "Lubomir Marinov" <lyubomir.marinov@jitsi.org> a écrit :

> On Jan 6, 2016, at 1:01 PM, Etienne Champetier < champetier.etienne@gmail.com> wrote:


#5

Hi

> I'm looking for the source (modified pom included) that were used to

generate bcprov-jdk15on 1.51-jitsi-1.

Oh, I totally missed that line, I’m sorry.

https://github.com/jitsi/jitsi-maven-repository/tree/master/releases/org/bouncycastle/bcprov-jdk15on
says: Deploys bcprov from the branch r1rv51-patched of gpolitis/bc-java (at
GitHub). I think I used BouncyCastle’s own Ant support and then deployed
the resulting binary file.

No problem and Thanks!
Next time please fork/commit/branch and tag so we are sure of what sources
produce the artifact

The bug seems to be fixed in version 1.54
https://github.com/bcgit/bc-java/commit/b6be49786b13314b4c29501fb17df098e728a7fe

···

Le 6 janv. 2016 22:33, "Lubomir Marinov" <lyubomir.marinov@jitsi.org> a écrit :

> On Jan 6, 2016, at 1:01 PM, Etienne Champetier < champetier.etienne@gmail.com> wrote: