[jitsi-dev] Authentication on Mobile Apps Does not Work


#1

Hi All,

I have a jitsi deployment with authentication enabled. But when I tried
with the lates IOS app from with the full URL, it does not work. Also I
tried building app from master branch, it did not work either.
What could be the possible reason ?

···

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#2

Are you passing a jwt token as a URL parameter?

Cheers,

···

On Jan 12, 2018, at 06:09, Buddhika Jayawardhana <buddhika.anushka@gmail.com> wrote:

Hi All,

I have a jitsi deployment with authentication enabled. But when I tried with the lates IOS app from with the full URL, it does not work. Also I tried building app from master branch, it did not work either.
What could be the possible reason ?

--
Saúl


#3

Hi Saul,

No. I just have configured the system descripbed as :
https://github.com/jitsi/jicofo#secure-domain

···

On Fri, Jan 12, 2018 at 2:27 PM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

> On Jan 12, 2018, at 06:09, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I have a jitsi deployment with authentication enabled. But when I tried
with the lates IOS app from with the full URL, it does not work. Also I
tried building app from master branch, it did not work either.
> What could be the possible reason ?
>

Are you passing a jwt token as a URL parameter?

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#4

Can you paste a sample URL?

···

On Jan 12, 2018, at 10:42, Buddhika Jayawardhana <buddhika.anushka@gmail.com> wrote:

Hi Saul,

No. I just have configured the system descripbed as : https://github.com/jitsi/jicofo#secure-domain

On Fri, Jan 12, 2018 at 2:27 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:

> On Jan 12, 2018, at 06:09, Buddhika Jayawardhana <buddhika.anushka@gmail.com> wrote:
>
> Hi All,
>
> I have a jitsi deployment with authentication enabled. But when I tried with the lates IOS app from with the full URL, it does not work. Also I tried building app from master branch, it did not work either.
> What could be the possible reason ?
>

Are you passing a jwt token as a URL parameter?

Cheers,

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Buddhika Jayawardhana
buddhika.anushka@gmail.com | LinkedIn
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl


#5

Hi Saul,
This is it.

https://meet.meetrix.xyz/1234

···

On Fri, Jan 12, 2018 at 6:22 PM, Saúl Ibarra Corretgé < scorretge@atlassian.com> wrote:

Can you paste a sample URL?

> On Jan 12, 2018, at 10:42, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:
>
> Hi Saul,
>
> No. I just have configured the system descripbed as :
https://github.com/jitsi/jicofo#secure-domain
>
> On Fri, Jan 12, 2018 at 2:27 PM, Saúl Ibarra Corretgé < > scorretge@atlassian.com> wrote:
>
>
> > On Jan 12, 2018, at 06:09, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:
> >
> > Hi All,
> >
> > I have a jitsi deployment with authentication enabled. But when I
tried with the lates IOS app from with the full URL, it does not work. Also
I tried building app from master branch, it did not work either.
> > What could be the possible reason ?
> >
>
> Are you passing a jwt token as a URL parameter?
>
>
> Cheers,
>
> --
> Saúl
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> --
> Buddhika Jayawardhana
> buddhika.anushka@gmail.com | LinkedIn
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
*Buddhika Jayawardhana*
*buddhika.anushka@gmail.com <buddhika.12@cse.mrt.ac.lk>* | LinkedIn
<http://lk.linkedin.com/in/buddhikajay/>


#6

I just tried it and I get the password prompt just fine. What iOS version and device do you have?

Cheers,

···

On Jan 12, 2018, at 18:31, Buddhika Jayawardhana <buddhika.anushka@gmail.com> wrote:

Hi Saul,
This is it.

https://meet.meetrix.xyz/1234

On Fri, Jan 12, 2018 at 6:22 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:
Can you paste a sample URL?

> On Jan 12, 2018, at 10:42, Buddhika Jayawardhana <buddhika.anushka@gmail.com> wrote:
>
> Hi Saul,
>
> No. I just have configured the system descripbed as : https://github.com/jitsi/jicofo#secure-domain
>
> On Fri, Jan 12, 2018 at 2:27 PM, Saúl Ibarra Corretgé <scorretge@atlassian.com> wrote:
>
>
> > On Jan 12, 2018, at 06:09, Buddhika Jayawardhana <buddhika.anushka@gmail.com> wrote:
> >
> > Hi All,
> >
> > I have a jitsi deployment with authentication enabled. But when I tried with the lates IOS app from with the full URL, it does not work. Also I tried building app from master branch, it did not work either.
> > What could be the possible reason ?
> >
>
> Are you passing a jwt token as a URL parameter?
>
>
> Cheers,
>
> --
> Saúl
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> --
> Buddhika Jayawardhana
> buddhika.anushka@gmail.com | LinkedIn
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Buddhika Jayawardhana
buddhika.anushka@gmail.com | LinkedIn
_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl


#7

Hi Saul, it's an iPhone 7 +, iOS 11.2.2

···

On Jan 12, 2018 11:39 PM, "Saúl Ibarra Corretgé" <scorretge@atlassian.com> wrote:

I just tried it and I get the password prompt just fine. What iOS version
and device do you have?

Cheers,

> On Jan 12, 2018, at 18:31, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:
>
> Hi Saul,
> This is it.
>
> https://meet.meetrix.xyz/1234
>
> On Fri, Jan 12, 2018 at 6:22 PM, Saúl Ibarra Corretgé < > scorretge@atlassian.com> wrote:
> Can you paste a sample URL?
>
> > On Jan 12, 2018, at 10:42, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:
> >
> > Hi Saul,
> >
> > No. I just have configured the system descripbed as :
https://github.com/jitsi/jicofo#secure-domain
> >
> > On Fri, Jan 12, 2018 at 2:27 PM, Saúl Ibarra Corretgé < > scorretge@atlassian.com> wrote:
> >
> >
> > > On Jan 12, 2018, at 06:09, Buddhika Jayawardhana < > buddhika.anushka@gmail.com> wrote:
> > >
> > > Hi All,
> > >
> > > I have a jitsi deployment with authentication enabled. But when I
tried with the lates IOS app from with the full URL, it does not work. Also
I tried building app from master branch, it did not work either.
> > > What could be the possible reason ?
> > >
> >
> > Are you passing a jwt token as a URL parameter?
> >
> >
> > Cheers,
> >
> > --
> > Saúl
> >
> >
> > _______________________________________________
> > dev mailing list
> > dev@jitsi.org
> > Unsubscribe instructions and other list options:
> > http://lists.jitsi.org/mailman/listinfo/dev
> >
> >
> >
> > --
> > Buddhika Jayawardhana
> > buddhika.anushka@gmail.com | LinkedIn
> > _______________________________________________
> > dev mailing list
> > dev@jitsi.org
> > Unsubscribe instructions and other list options:
> > http://lists.jitsi.org/mailman/listinfo/dev
>
> --
> Saúl
>
>
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev
>
>
>
> --
> Buddhika Jayawardhana
> buddhika.anushka@gmail.com | LinkedIn
> _______________________________________________
> dev mailing list
> dev@jitsi.org
> Unsubscribe instructions and other list options:
> http://lists.jitsi.org/mailman/listinfo/dev

--
Saúl

_______________________________________________
dev mailing list
dev@jitsi.org
Unsubscribe instructions and other list options:
http://lists.jitsi.org/mailman/listinfo/dev