Jitsi config.js and interface_config overwritten

Greetings,

I’m using selfhost docker jitsi, is anyone have any ideas why my config.js and interface_config always get overwritten to the default after the docker was restarted, is there a way to maintain the settings? Thanks

That’s intentional.

Use the environment variables or the -custom.js files for setting the config, the container will regerate it on every boot.

Note that your config will be at the bottom.

Thanks for reply Saghul, do you have any reference page to refer regarding how to add the cusom.js in environment and etc? Because i’m new to this, which totally lost when this is happened. It would be greatly appreciated if you could send some link or sample for me… million thanks

One of the key settings that i would like to change is the DISABLE_VIDEO_BACKGROUND: true, in the interface_config

Check this answer for more info:

In short, create a file interface_config-custom.js in .jitsi-meet-cfg/web directory and add this in it:

interfaceConfig.DISABLE_VIDEO_BACKGROUND = true;

I think i got it, thanks a lot @izakgl @kyanel