Jitsi conference only works from locale network

Hi Community,

I installed a fresh Jitsi installation on my private external Debian Server. Everybody can join our meetings, but nobody can share audio or video. BUT when I join the meeting by my Smartphone and PC from same network all works fine. When I turn of the WLAN on my smart device and rejoin it will not work. I tested this scenario on Chrome, Firefox and a custom Jitsi Desktop Client on PC and on my smartphone I always use the official Jitsi App from PlayStore. In Firefox the Meeting has always no video or audio (also on the same network).
My Jitsi logs display many SSL error. But I can’t understand why because I use the lets encrypt installer liked the Manuel from Jitsi explained. And on the same network it works well …

My technical equipment

  • PC: Windows 10
  • Smartphone: Android 10 (Lineage)
  • Server (hostet external): Debian 10 Buster

So I am confused and sad cause my friend and me switch from WhatsApp and Discord to Open Source Solutions and at least the screen mirroring currently not working by open Software :frowning:

Sorry for my bad English skills and thx for reading :slight_smile:
Leon

Hi,
welcome to the forum…

Do you have a valid certificate?
Not an internally generated certificate from the server

Is your server under NAT?

Regards…

Hi,

Do you have a valid certificate?
I think so because Firefox says the certificate is valid

Is your server under NAT?
Don’t know but when I print my IP an external Address (no 192.X.X.X or so) was shown

Regards :slight_smile:

Ok…
does the server also have a private ip?

If your answer is YES, then you read this guide: Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook in the “Advanced configuration” section

Regards…

My IP Address is available across the internet. The ifconfig result of my server is shown below

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 185.X.X.X  netmask 255.255.254.0  broadcast 185.X.X.X
		[IP v6 stuff ...]
        ether 96:X:X:X:X:X  txqueuelen 1000  (Ethernet)
        RX packets 1526011  bytes 100204932 (95.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3938  bytes 745778 (728.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I think the doors you have opened are 80, 443 and 10000.

Local network or same network… what do you want to tell us?

Hey,

My goal is to have a meeting with a friend who live in another city. So I want an external accessible Jitsi-Server. But currently I only can have meetings in locale network.

I tried to scribble my problem. Connection 2 will work but Connection 1 failed. In 1 its possible to join a meeting by a device. But the device can’t see or hear something

1 Like

I understand … No more than 2 devices connect.

What ports are open on the server?

Have you tried connecting your notebook and your friend’s notebook?

Hi @Nordmole,

I prepared a Jitsi installer for Debian 10 Buster. It does not only install the packages but also checks many conditions which will cause a potential problem.

jitsi-buster-installer

Hi,

What ports are open on the server?
The following ports are open

  • 80/tcp
  • 443/tcp
  • 10000/udp
  • 22/tcp
  • 3478/udp
  • 5349/tcp

Have you tried connecting your notebook and your friend’s notebook?
Sure. I tried different device types and the problem occurred every time. But it’s not limited to 2 devices. The problem is linked to the network structureand server but not the devices I think

Naa. I want to understand the problem and not automated repair it :smiley: It is at least a private project and so I can take the time I was able to spend for

But thanks for your answer. May I can use your tool in future :wink:

Show us the jvb logs please…

Hi!

Here it comes: My Jvb.log File

Okay @Kali,

This Solution will work an all service run smoothly now. Great! I’m very happy about that. But why this error occurs? So this thread is not finished! We have to clear this last question :slight_smile:

Regards,
Leon

Hi,
My last question was solved btw. The user @gpatel-fr explains in this topic why this error occurred

Thanks!

I am also facing the issue ,can anyone help me how to fix this issue,screen share is working on same net connection but with different intertnet connection ,screen goes blank

Checkout advanced section in the quick install guide https://jitsi.org/qi