Jitsi cannot find jibri after installed JWT

After I install JWT on my Jitsi server, my Jitsi not able to locate jibri. Error on jicofo.log

Unable to find an available Jibri, can’t start
Failed to start a Jibri session, no Jibris available

Any idea how to solve ? Thank

I added to here

/etc/jitsi/jicofo/sip-communicator.properties

org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.yourdomain.com
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

I tried added to /etc/jitsi/jicofo/jicofo.conf

and restart everything, still the same error.

Did you configure the JIbri XMPP user / password?

this is the setting right ?

sudo prosodyctl register jibri auth.domain.name password
sudo prosodyctl register recorder recorder.domain.name password

yes I added both.

I just saw this error on jitsi prosody

[type=jibri brewery=jibriname] BaseBrewery.start#175: Failed to create room.

and connection to jitsi from jibri is authenticated if not mistaken

MucClient$2.connected#304: Connected.

2022-02-28 10:19:38.650 INFO: [28] [hostname=turn2.tfsystems.biz id=turn2.tfsystems.biz] MucClient.lambda$getConnectAndLoginCallable$8#628: Logging in.

2022-02-28 10:19:38.728 INFO: [28] [hostname=turn2.tfsystems.biz id=turn2.tfsystems.biz] MucClient$2.authenticated#310: Authenticated, b=false

** Joined MUC: jibriname@internal.domainname**

I checked prosody log

Feb 28 10:34:02 c2s556bc0597fd0 info Authenticated as jibri@auth.domainname

but error on jicofo.log

Jicofo 2022-02-28 10:35:34.984 SEVERE: [135] JibriSession.startInternal#308: Unable to find an available Jibri, can’t start

Jicofo 2022-02-28 10:35:34.984 INFO: [135] [room=3@conference.turn2.tfsystems.biz meeting_id=f206801e-c84f-4180-9f4f-78cca9aa6f88] JibriRecorder.handleStartRequest#124: Failed to start a Jibri session, no Jibris available

Before I install JWT, I able to connect to my jibri and record.

Am I need to do any configuration to allow JWT from jibri ?

Thanks

Can you paste your jicofo.conf

Jicofo HOCON configuration. See reference.conf in /usr/share/jicofo/jicofo.jar for

#available options, syntax, and default values.
jicofo {
xmpp: {
client: {
client-proxy: focus.turn2.tfsystems.biz
}
trusted-domains: [ “recorder.turn2.tfsystems.biz” ]
}
bridge: {
brewery-jid: “JvbBrewery@internal.auth.turn2.tfsystems.biz”
}
jibri: {
brewery-jid: “JibriVmm@internal.auth.turn2.tfsystems.biz”
pending-timeout: 90 seconds
}
}

JibriVmm?

I renamed my jibri from jibriBrewery to jibriVmm

in my /etc/jitsi/jibri/jibri.conf

control-muc {
domain = “internal.auth.turn2.tfsystems.biz”
room-name = “JibriVmm
nickname = “jibri-nickname”
}

Did you check jibri logs?

/var/log/jitsi/jibri/

Yes, no error on log.0.txt

2022-02-28 11:54:13.007 WARNING: [28] MucClient.createXMPPTCPConnectionConfiguration#114: Disabling certificate verification!

2022-02-28 11:54:13.049 INFO: [28] [hostname=turn2.tfsystems.biz id=turn2.tfsystems.biz] MucClient.initializeConnectAndJoin#331: Dispatching a thread to connect and login.

2022-02-28 11:54:13.266 INFO: [28] [hostname=turn2.tfsystems.biz id=turn2.tfsystems.biz] MucClient$2.connected#304: Connected.

2022-02-28 11:54:13.267 INFO: [28] [hostname=turn2.tfsystems.biz id=turn2.tfsystems.biz] MucClient.lambda$getConnectAndLoginCallable$8#628: Logging in.

2022-02-28 11:54:13.342 INFO: [28] [hostname=turn2.tfsystems.biz id=turn2.tfsystems.biz] MucClient$2.authenticated#310: Authenticated, b=false

2022-02-28 11:54:13.399 INFO: [28] [hostname=turn2.tfsystems.biz id=turn2.tfsystems.biz] MucClient$MucWrapper.join#748: Joined MUC: jibribrewery@internal.auth.turn2.tfsystems.biz

succesful joined. *I changed back to jibribrewery

Does this mean it’s solved?

No, I mean my jibri showed connected, but jitsi when click recording still not able to find jibri.

Jicofo 2022-02-28 10:35:34.984 SEVERE: [135] JibriSession.startInternal#308: Unable to find an available Jibri, can’t start

Jicofo 2022-02-28 10:35:34.984 INFO: [135] [room=3@conference.turn2.tfsystems.biz meeting_id=f206801e-c84f-4180-9f4f-78cca9aa6f88] JibriRecorder.handleStartRequest#124: Failed to start a Jibri session, no Jibris available

*I installed my jibri on external server.

What are Java verion and resources on jibri?

openjdk version “1.8.0_312”

OpenJDK Runtime Environment (build 1.8.0_312-8u312-b07-0ubuntu1~20.04-b07)

OpenJDK 64-Bit Server VM (build 25.312-b07, mixed mode)

jibri is already the newest version (8.0-116-gca0c772-1).

Assuming you have already checked this topic, I have no other idea

Yup, everything is exactly same. If still cannot I will try reinstall my jibri.

Thanks @emrah.

You need a more complete config file with your XMPP user credentials. As an example look at the stuff we set in Docker: docker-jitsi-meet/jibri.conf at master · jitsi/docker-jitsi-meet · GitHub

Hi, problem solved.

After reinstalled jibri I found out my configuration for jitsi is wrong.
I able to reconnect after follow from github

Thanks

1 Like