Jitsi breaks after update

Good morning,

my instance on Ubuntu 18.04 LTS breaks, if I update to the latest version. The domain isn’t reachable afterwards.

Can you tell me, where I should start please?

Thank you
w3nz

This isn’t a terribly useful amount of information in a question. What breaks? HTTPS connectivity? You can’t SSH to the system?

And have you tried rebooting the server? I’ve had some of my dev instances get really weird after shuffling packages around, a reboot usually fixes it.

Hi Syonyk, thank you for your reply. The HTTPS connectivity breaks. I did a reboot of the server and afterwards the Server isn’t accessible via HTTP/S any longer:

root@servername:~# sudo apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web
  jitsi-meet-web-config jitsi-videobridge2
7 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 69,9 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 186 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] 

Holen:1 https://download.jitsi.org stable/ jitsi-meet 2.0.4384-1 [2.864 B]
Holen:2 https://download.jitsi.org stable/ jicofo 1.0-541-1 [32,6 MB]
Holen:3 https://download.jitsi.org stable/ jitsi-meet-web 1.0.3969-1 [5.847 kB]
Holen:4 https://download.jitsi.org stable/ jitsi-meet-web-config 1.0.3969-1 [13,5 kB]
Holen:5 https://download.jitsi.org stable/ jitsi-meet-prosody 1.0.3969-1 [34,7 kB]
Holen:6 https://download.jitsi.org stable/ jitsi-videobridge2 2.1-164-gfdce823f-1 [31,4 MB]
Holen:7 https://download.jitsi.org stable/ jitsi-meet-turnserver 1.0.3969-1 [5.232 B]
Es wurden 69,9 MB in 7 s geholt (10,3 MB/s).                                   
Vorkonfiguration der Pakete ...
(Lese Datenbank ... 109510 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../0-jitsi-meet_2.0.4384-1_all.deb ...
Entpacken von jitsi-meet (2.0.4384-1) über (1.0.4335-1) ...
Vorbereitung zum Entpacken von .../1-jicofo_1.0-541-1_all.deb ...
Entpacken von jicofo (1.0-541-1) über (1.0-539-1) ...
Vorbereitung zum Entpacken von .../2-jitsi-meet-web_1.0.3969-1_all.deb ...
Entpacken von jitsi-meet-web (1.0.3969-1) über (1.0.3928-1) ...
Vorbereitung zum Entpacken von .../3-jitsi-meet-web-config_1.0.3969-1_all.deb ...
Entpacken von jitsi-meet-web-config (1.0.3969-1) über (1.0.3928-1) ...
Vorbereitung zum Entpacken von .../4-jitsi-meet-prosody_1.0.3969-1_all.deb ...
Entpacken von jitsi-meet-prosody (1.0.3969-1) über (1.0.3928-1) ...
Vorbereitung zum Entpacken von .../5-jitsi-videobridge2_2.1-164-gfdce823f-1_all.deb ...
Entpacken von jitsi-videobridge2 (2.1-164-gfdce823f-1) über (2.1-157-g389b69ff-1) ...
Vorbereitung zum Entpacken von .../6-jitsi-meet-turnserver_1.0.3969-1_all.deb ...
Entpacken von jitsi-meet-turnserver (1.0.3969-1) über (1.0.3928-1) ...
jitsi-videobridge2 (2.1-164-gfdce823f-1) wird eingerichtet ...
* Applying /etc/sysctl.d/10-console-messages.conf ...
kernel.printk = 4 4 1 7
* Applying /etc/sysctl.d/10-ipv6-privacy.conf ...
net.ipv6.conf.all.use_tempaddr = 2
net.ipv6.conf.default.use_tempaddr = 2
* Applying /etc/sysctl.d/10-kernel-hardening.conf ...
kernel.kptr_restrict = 1
* Applying /etc/sysctl.d/10-link-restrictions.conf ...
fs.protected_hardlinks = 1
fs.protected_symlinks = 1
* Applying /etc/sysctl.d/10-lxd-inotify.conf ...
fs.inotify.max_user_instances = 1024
* Applying /etc/sysctl.d/10-magic-sysrq.conf ...
kernel.sysrq = 176
* Applying /etc/sysctl.d/10-network-security.conf ...
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.ipv4.tcp_syncookies = 1
* Applying /etc/sysctl.d/10-ptrace.conf ...
kernel.yama.ptrace_scope = 1
* Applying /etc/sysctl.d/10-zeropage.conf ...
vm.mmap_min_addr = 65536
* Applying /etc/sysctl.d/20-jvb-udp-buffers.conf ...
net.core.rmem_max = 10485760
net.core.netdev_max_backlog = 100000
* Applying /etc/sysctl.d/50-IPv6.conf ...
net.ipv6.conf.default.accept_ra = 0
net.ipv6.conf.default.autoconf = 0
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.all.autoconf = 0
net.ipv6.conf.eth0.accept_ra = 0
net.ipv6.conf.eth0.autoconf = 0
* Applying /usr/lib/sysctl.d/50-default.conf ...
net.ipv4.conf.all.promote_secondaries = 1
net.core.default_qdisc = fq_codel
* Applying /etc/sysctl.d/99-nc-kernel.conf ...
vm.dirty_background_ratio = 5
vm.dirty_ratio = 10
* Applying /etc/sysctl.d/99-sysctl.conf ...
* Applying /etc/sysctl.conf ...
jitsi-meet-web-config (1.0.3969-1) wird eingerichtet ...
----------------

You can now switch to a Let’s Encrypt certificate. To do so, execute:
/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

----------------
jitsi-meet-web (1.0.3969-1) wird eingerichtet ...
jitsi-meet-prosody (1.0.3969-1) wird eingerichtet ...
jicofo (1.0-541-1) wird eingerichtet ...
jitsi-meet (2.0.4384-1) wird eingerichtet ...
jitsi-meet-turnserver (1.0.3969-1) wird eingerichtet ...
------------------------------------------------

turnserver is already configured on this machine, skipping.

------------------------------------------------
Trigger für ureadahead (0.100.0-21) werden verarbeitet ...
Trigger für systemd (237-3ubuntu10.39) werden verarbeitet ...
root@servername:~# sudo init 6
Connection to 123.456.789.0 closed by remote host.
Connection to 123.456.789.0 closed.

Hi w3nz, look at your nginx config file. They changed the Port under Server from 443 to 4443.

2 Likes

Hi,
is the webserver availabe, when you adress the IP directly?

I believe, that I run into the same issue days ago. My first solution was a downgrade the whole setup (see Only one user at time (NAT + Reverse Proxy)) . Several clean installs (I purged everything jitsi related and delete remnant files in /etc/jitsi ) failed, but a clean install with an preinstalled apache worked.

Kind Regards
Dorian

THANK YOUUU d.schoty! You saved my day! :slight_smile:

sudo nano /etc/nginx/sites-available/servername.de.conf 

and changing

[...]

server {
    listen 4444 ssl http2;
    listen [::]:4444 ssl http2;
[...]

to

[...]

server {
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
[...]

solved my problem.

2 Likes

Thank you for your response. :slight_smile:

no, port 443 is listened in
/etc/nginx/modules-enabled/60-jitsi-meet.conf
and there forwarded to 4444 or 4445 (for turn)