Jitsi automatically redirects to a meeting after installing Jibri

Hi guys,

I have a problem when installing Jibri on AWS EC2 instances. For testing purposes we don’t have a domain but we use the public IP of the machine (using an Elastic IP). As a procedure, I followed the steps provided on this page:

Installation went pretty fine however, when opening Jitsi after finishing the configuration for Jibri, it automatically redirects to a new meeting but get’s stuck for some reason.
Tried it with multiple browsers, but it’s still not working, tried different config files for jibri (but still not working). Not sure where to check further as I couldn’t find something relevant in the logs.
Any ideas where I should look further or did someone else faced similar problems?

jibri {
id = “”
single-use-mode = false

recording {
    recordings-directory = "/srv/recordings"
    finalize-script = "/usr/local/bin/finalize_recording.sh"
}

chrome {
    flags = [
        // "--ignore-certificate-errors",
        "--use-fake-ui-for-media-stream",
        "--start-maximized",
        "--kiosk",
        "--enabled",
        "--disable-infobars",
        "--autoplay-policy=no-user-gesture-required"
    ]
}

ffmpeg {
    resolution = "1920x1080"
    audio-source = "alsa"
    audio-device = "plug:bsnoop"
}

api {
    http {
        internal-api-port = 8001
        external-api-port = 8002
    }

    xmpp {
        environments = [{
            name = "eb-environment"
            xmpp-server-hosts = ["PUBLIC-IP"]
            xmpp-domain = "PUBLIC-IP"

            control-muc {
                domain = "internal.auth.PUBLIC-IP"
                room-name = "JibriBrewery"
                nickname = "jibri-nickname"
            }

            control-login {
                domain = "auth.PUBLIC-IP"
                username = "jibri"
                password = "Password1234@"
            }

            call-login {
                domain = "recorder.PUBLIC-IP"
                username = "recorder"
                password = "Password1234@"
            }

            strip-from-room-domain = "conference."
            usage-timeout = 0
            trust-all-xmpp-certs = true
        }]
    }
}

stats {
    enable-stats-d = true
}

call-status-checks {
    no-media-timeout = 30 seconds
    all-muted-timeout = 10 minutes
    default-call-empty-timeout = 30 seconds
}

}

Also tried to increase the size of the EC2 for Jibri to a c4 machine, but same thing.
Any help will be highly appreciated.

Another thing which seems to be strange are the errors from prosody. Not sure if they are relevant to this problem though.

root@jitsi:/var/snap/amazon-ssm-agent/4046# systemctl status prosody
● prosody.service - LSB: Prosody XMPP Server
Loaded: loaded (/etc/init.d/prosody; generated)
Active: active (running) since Tue 2021-08-03 11:05:43 UTC; 1min 30s ago
Docs: man:systemd-sysv-generator(8)
Tasks: 1 (limit: 1140)
CGroup: /system.slice/prosody.service
└─971 lua5.1 /usr/bin/prosody

Aug 03 11:05:42 jitsi systemd[1]: Starting LSB: Prosody XMPP Server…
Aug 03 11:05:42 jitsi prosody[846]: * Starting Prosody XMPP Server prosody
Aug 03 11:05:43 jitsi prosody[846]: …done.
Aug 03 11:05:43 jitsi systemd[1]: Started LSB: Prosody XMPP Server.
Aug 03 11:05:43 jitsi prosody[971]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281
Aug 03 11:05:43 jitsi prosody[971]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281
Aug 03 11:05:43 jitsi prosody[971]: modulemanager: Unable to load module ‘storage_memory’: /usr/lib/prosody/modules/mod_storage_memory.lua: No such file or directory
Aug 03 11:05:43 jitsi prosody[971]: storagemanager: Failed to load storage driver plugin memory on internal.auth.3.125.174.22: /usr/lib/prosody/modules/mod_storage_memory.lua: No such file or directory
Aug 03 11:05:43 jitsi prosody[971]: modulemanager: Unable to load module ‘storage_memory’: /usr/lib/prosody/modules/mod_storage_memory.lua: No such file or directory
Aug 03 11:05:43 jitsi prosody[971]: storagemanager: Failed to load storage driver plugin memory on internal.auth.3.125.174.22: /usr/lib/prosody/modules/mod_storage_memory.lua: No such file or directory

It seems that prosody and lua are old. It will be better to install on Ubuntu 20.04 or Debian 10 Buster in my opinion

Hmm, ok. The problem is, I have tried to install Jibri first on Ubuntu 20.04 but for some reason, when trying to switch to the generic kernel on AWS, the machine no longer started back.
Do you think it might be because of the version, or at least it will remove this issue?

I have no so much Ubuntu experience on AWS but when I last installed Jibri on an AWS Ubuntu 20.04 instance, I didn’t have such an issue.

But I’m sure Debian 10 Buster will work flawlessly

As a small update for anyone who might encounter a similar error from the screenshot (using the tutorial above), pay attention to the config.js file.
In my case it was a missing comma (,) when adding those 3 parameters mentioned here - /etc/jitsi/meet/domain-config.js.