Jitsi - "Ask to unmute" function doesn't work

Hi,

I have problem with “Ask to unmute” function. It doesn’t work, after I click on the button then I don’t have notification to accept.

Regards,
noje

Do you have the av moderation part enabled in your prosody config?
Maybe share your prosody config.

I attached my prosody configuration.

prosody.txt (3.2 KB)

Seems fine. Any errors in client, jicofo or prosody logs?

  1. I don’t have any errors in prosody logs.
  2. I have some warning in jicofo logs :

Jicofo 2022-02-22 16:44:17.104 WARNING: [19] Main$1.warn#154: Key ‘jicofo.bridge.average-participant-packet-rate-pps’ from source ‘typesafe config (reloaded 1 times)’ is deprecated: use jicofo.bridge.average-participant-stress

Jicofo 2022-02-22 16:44:17.366 WARNING: [1] org.glassfish.jersey.server.wadl.WadlFeature.configure: JAXBContext implementation could not be found. WADL feature is disabled.

Jicofo 2022-02-22 16:44:17.471 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime: A provider org.jitsi.rest.Version registered in SERVER runtime does not implement any provider interfaces

Jicofo 2022-02-22 16:44:18.234 WARNING: [36] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connection XMPPTCPConnection[focus@auth.DOMAIN/focus] (0) closed with error
org.jivesoftware.smack.XMPPException$StreamErrorException: system-shutdown You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorReceived SIGTERM</stream:error>
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:981)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(XMPPTCPConnection.java:913)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:936)
at java.base/java.lang.Thread.run(Thread.java:832)

Jicofo 2022-02-22 16:44:18.239 SEVERE: [36] [xmpp_connection=client] XmppProviderImpl$XmppConnectionListener.connectionClosedOnError#397: XMPP connection closed on error: system-shutdown You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions
stream:errorReceived SIGTERM</stream:error>

Hum, no this is prosody being restarted … you can ignore it.

I didn’t have av moderation configuration in prosody.cfg but I had buttons from av moderation which didn’t work. I did configuration like I sent you but buttons are still inactive. Is there any option to delete / add buttons from av moderation ?

I added to prosody.cfg “breakout rooms” and I have the same problem. I have button to create these rooms but it’s inactive.

Are you restarting prosody after editing the config?

Yes, many times :frowning:

Fitst (but this is unrelated) get rid of your modules in the anonymous (guest) host. They are useless.

Then try to remove websocket from the main host (this could be related)

After I deleted websocket from the main host I couldn’t open conferences. I got message “You have been disconnected”.

that means that your bosh configuration is not working then.
Either try to fix bosh, or try to use websockets but upgrade prosody to latest.

@damencho @gpatel-fr

I had prosody in version : 0.11.4-1. I have upgraded prosody to newest version : 0.11.13-1 and it has started work…

Good to know, thanks … interesting what was preventing it from working correctly … when I have more time I can try debugging it more.

Yeah, you had the same problem and updating fixed it … I think I read all your observations, but I’m still lost and not sure what was the problem actually with 0.11.4.

if jitsi_web_query_room is empty this is strange … as it is extracted from the URL params here

I don’t see why it wouldn’t work … or somehow that version of prosody is not loading the module here jitsi-meet/mod_auth_token.lua at 65589937ea8c1bae53d64c1b6bcceaab07dc3134 · jitsi/jitsi-meet · GitHub

Oh wait, let me check when this was added:
module:hook_global(“websocket-session”, init_session);

Yep,

that went in 0.11.6 I think, so without it, jwt and websocket will not work in anything before 0.14. And apparently and av_moderation.
Good work for debugging it @gpatel-fr!

1 Like

Thanks.

So to properly work av_moderation with websocket, we need minimum prosody version 0.11.6 ?