Jitsi apt repo expired cert

Hi, the jitsi apt repo has an expired cert. See the github issue here:

Yikes. Thanks for the heads up. Calling in the cavalry: @damencho

All issues had been fixed and download.jitsi.org is back.

Hi! I’m getting the same answer, as reported above, when I do ‘sudo apt-get -y update’
Err:10 https://download.jitsi.org stable/ Release
Certificate verification failed: The certificate is NOT trusted. The certificate issuer is unknown. Could not handshake: Error in the certificate verification.

I’ve tried setting trusted=yes on sorces.list, bust doesn’t works.
deb [trusted=yes] https://download.jitsi.org stable/

I’m using Ubuntu 18.04.2 LTS

Thanks

@r76ricardo Just started a new VM on DO and there is not problem.

root@ubuntu-s-1vcpu-1gb-lon1-01:~# echo 'deb https://download.jitsi.org stable/' >> /etc/apt/sources.list.d/jitsi-stable.list
root@ubuntu-s-1vcpu-1gb-lon1-01:~#
root@ubuntu-s-1vcpu-1gb-lon1-01:~# wget -qO -  https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
OK
root@ubuntu-s-1vcpu-1gb-lon1-01:~# apt-get update
Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Hit:2 http://mirrors.digitalocean.com/ubuntu bionic InRelease
Get:3 http://mirrors.digitalocean.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:4 http://mirrors.digitalocean.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:5 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [447 kB]
Get:6 https://download.jitsi.org stable/ InRelease [2415 B]
Get:7 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [156 kB]
Get:8 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [570 kB]
Get:9 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [185 kB]
Get:10 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 Packages [4008 B]
Get:11 http://security.ubuntu.com/ubuntu bionic-security/multiverse Translation-en [2060 B]
Get:12 http://mirrors.digitalocean.com/ubuntu bionic/universe amd64 Packages [8570 kB]
Get:13 http://mirrors.digitalocean.com/ubuntu bionic/universe Translation-en [4941 kB]
Get:14 http://mirrors.digitalocean.com/ubuntu bionic/multiverse amd64 Packages [151 kB]
Get:15 http://mirrors.digitalocean.com/ubuntu bionic/multiverse Translation-en [108 kB]
Get:16 http://mirrors.digitalocean.com/ubuntu bionic-updates/main amd64 Packages [676 kB]
Get:17 http://mirrors.digitalocean.com/ubuntu bionic-updates/main Translation-en [249 kB]
Get:18 http://mirrors.digitalocean.com/ubuntu bionic-updates/universe amd64 Packages [965 kB]
Get:19 http://mirrors.digitalocean.com/ubuntu bionic-updates/universe Translation-en [287 kB]
Get:20 http://mirrors.digitalocean.com/ubuntu bionic-updates/multiverse amd64 Packages [6644 B]
Get:21 http://mirrors.digitalocean.com/ubuntu bionic-updates/multiverse Translation-en [3556 B]
Get:22 http://mirrors.digitalocean.com/ubuntu bionic-backports/main amd64 Packages [2512 B]
Get:23 http://mirrors.digitalocean.com/ubuntu bionic-backports/main Translation-en [1644 B]
Get:24 http://mirrors.digitalocean.com/ubuntu bionic-backports/universe amd64 Packages [3736 B]
Get:25 http://mirrors.digitalocean.com/ubuntu bionic-backports/universe Translation-en [1696 B]
Get:26 https://download.jitsi.org stable/ Packages [32.4 kB]
Fetched 17.6 MB in 6s (2838 kB/s)
Reading package lists... Done
root@ubuntu-s-1vcpu-1gb-lon1-01:~# lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.2 LTS
Release:	18.04
Codename:	bionic

Trying to do apt update today , but getting the following error

Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate. Could not handshake: Error in the certificate verification.

Tried trusted=yes in /etc/apt/sources.list.d/jitsi-stable.list. But issue still persists .

@damencho One of the root or intermediate certificates has expired (1 days ago) for https://download.jitsi.org

Check the following link
https://www.sslshopper.com/ssl-checker.html#hostname=https://download.jitsi.org

@damencho Can you please let us know when this certificate will be renewed? So that we can install the JITSI. OR is there any other way install the JITSI?

Hey guys. I’m getting same errors

it’s working now!!

Same issue