Jitsi ApiKey and Secret

Hi,

I have self host jitsi server and how do i provide API key and secret for jitsi wordpress plugin?

Thanks

You need to install jitsi-meet-tokens. You will set app_id and app_secret while installing it.

jitsi-meet-tokens Installation done with app_id and app_secret. But once open up video link from WP below error popups up. did i miss any configuration ?

Can you check the following post. There is a temporary issue.

Thanks a lot @emrah.

1 Like

@emrah is it possible to keep two form of authentication in /etc/prosody/conf.d/YOUR-DOMAIN.cfg
e.g Jitsi meet servers for token and internal_hashed base authentication

AFAIK this is not possible. Each virtualhost uses only one authentication method. What is your use case?

I guess you can do that, but you need different config.js settings for each type of client. Using different domains:

I have WP plugin calling Jitsi with API key as well as user can directly open up conference using login id.
could you suggest good solution for this use case ?

I tried @damencho’s suggestion but I cannot complete the task.

  • First I changed nginx config to publish different config.js according to the querystring keys (I checked jwt key) but this doesn’t work because clients send a second request without a jwt key after the first request and this breaks my scenario.

  • IIUC each virtualhost (one for JWT, the other for internal_hash) should use the same muc (conference…) but jwt needs token_authentication in its muc but internal_hash doesn’t…

I tried a second way and it seems OK to me.

  • Install Jitsi with token authentication
  • Use app_id and app_secret for WP
  • Use eparto.net as login panel for the second group.

So without token authentication module, it will work.

I typed wrong. I meant token_verification

Yeah, that what I mean, if you disable that, it should work

But then how do we use token and internal_hashed at the same time?