Jitsi anonymous domain is not up

I have followed securedomain , Auth is working with host required to host a meeting.However Anonymous domain is not up.I currently using it on AWS with Debian as os. Does it need a particular port to be unblocked other than required for jitsi setup?

Make sure you add anonymous virtualhost, just before the next virtualhost, after all component blocks of main virtualhost…

problem persists
here are the changed parts
[mydomain.com]config.js

`var config = {
    hosts: {
        // XMPP domain.
        domain:'mydomain.com',
        
        // When using authentication, domain for guest users.
        anonymousdomain: 'guest.mydomain.com',

        // Domain for authenticated users. Defaults to <domain>.
        //authdomain: 'auth.mydomain.com',

        // Focus component domain. Defaults to focus.<domain>.
        // focus: 'focus.mydomain.com',

        // XMPP MUC domain. FIXME: use XEP-0030 to discover it.
        muc: 'conference.<!--# echo var="subdomain" default="" -->mydomain.com'
    },
`

/etc/prosody/conf.avail/[mydomain.com].cfg.lua

VirtualHost "guest.mydomain.com"
    authentication = "anonymous"
    c2s_require_encryption = false
VirtualHost "mydomain.com"
    -- enabled = false -- Remove this line to enable this host
    authentication = "internal_hashed"
    -- Properties below are modified by meet-tokens package config
    -- and authentication above is switched to "token"
    --app_id="example_app_id"
    --app_secret="example_app_secret"
    -- Assign this host a certificate for TLS, otherwise it would use the one
    -- set in the global section (if any).
    -- Note that old-style SSL on port 5223 only supports one certificate, and will always
    -- use the global one.
    ssl = {
        key = "/etc/prosody/certs/mydomain.com.key";
        certificate = "/etc/prosody/certs/mydomain.com.crt";
    }
    av_moderation_component = "avmoderation.mydomain.com"
    speakerstats_component = "speakerstats.mydomain.com"
    conference_duration_component = "conferenceduration.mydomain.com"
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "ping"; -- Enable mod_ping
        "speakerstats";
        "external_services";
        "conference_duration";
        "muc_lobby_rooms";
        "av_moderation";
        "log_auth";
    }
    c2s_require_encryption = false
    lobby_muc = "lobby.mydomain.com"
    main_muc = "conference.mydomain.com"
    --muc_lobby_whitelist = { "recorder.mydomain.com" } -- Here we can whitelist jibri to enter lobby enabled rooms
Component "conference.mydomain.com" "muc"
    restrict_room_creation = true
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        --"token_verification";
    }
    admins = { "focus@auth.mydomain.com" }
    muc_room_locking = false
    muc_room_default_public_jids = true

-- internal muc component
Component "internal.auth.mydomain.com" "muc"
    storage = "memory"
    modules_enabled = {
        "ping";
    }
    admins = { "focus@auth.mydomain.com", "jvb@auth.mydomain.com" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.mydomain.com"
    ssl = {
        key = "/etc/prosody/certs/auth.mydomain.com.key";
        certificate = "/etc/prosody/certs/auth.mydomain.com.crt";
    }
    modules_enabled = {
        "limits_exception";
    }
    authentication = "internal_hashed"

-- Proxy to jicofo's user JID, so that it doesn't have to register as a component.
Component "focus.mydomain.com" "client_proxy"
    target_address = "focus@auth.mydomain.com"

Component "speakerstats.mydomain.com" "speakerstats_component"
    muc_component = "conference.mydomain.com"

Component "conferenceduration.mydomain.com" "conference_duration_component"
    muc_component = "conference.mydomain.com"

Component "avmoderation.mydomain.com" "av_moderation_component"
    muc_component = "conference.mydomain.com"

Component "lobby.mydomain.com" "muc"
    storage = "memory"
    restrict_room_creation = true
    muc_room_locking = false
    muc_room_default_public_jids = true
-- Section for example.com

VirtualHost "example.com"
        enabled = false -- Remove this line to enable this host

        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/example.com.key";
                certificate = "/etc/prosody/certs/example.com.crt";
                }

------ Components ------
-- You can specify components to add hosts that provide special services,
-- like multi-user conferences, and transports.
-- For more information on components, see http://prosody.im/doc/components

-- Set up a MUC (multi-user chat) room server on conference.example.com:
Component "conference.example.com" "muc"

-- Set up a SOCKS5 bytestream proxy for server-proxied file transfers:
--Component "proxy.example.com" "proxy65"

---Set up an external component (default component port is 5347)
--Component "gateway.example.com"
--      component_secret = "password"

-- Section for localhost

-- This allows clients to connect to localhost. No harm in it.
VirtualHost "localhost"

Try moving guest.mydomain block to just before ‘VirtualHost “auth.mydomain.com”’

does not work

Strange. Verify all configs once again. Nothing else is needed, except those that are listed on secure domain page.

what do you mean exactly by ‘not up’ ? when you create a meeting called ‘test’ and on another browser tab, using the same url, you enter again the same meeting name ‘test’, do you see an authentication prompt ?

If i try to go to guest.mydomain.com via its url it shows dns not founded

You are supposed to use the same url…even for guests…and that is when the guest can join the meeting without entering the password…

I understand why you would think to use a different domain though…

“After the room is created, others will be able to join from anonymous domain…”…secure domain page says…

Yes, it is a little confusing…and may be needs to be edited…to something like “…others will be able to join without entering the password…”

i was hoping that it was possible but i guess it is ok for now.