Jitsi and Rocketchat on Docker behind NGINX -> Problem with corporate FW's

Hello,

I have followed the GIT instruction for setting up Jitsi within Docker. My setup:

  1. Router -> Forwarding Port 443 (and 80) to my local IP (192.168.1.x)

  2. NGINX (192.168.1.x) for Jitsi and Rocketchat:

     location /rocketchat {
    
         proxy_pass http://rocketchat:3000/rocketchat;
         proxy_http_version 1.1;
         proxy_set_header Upgrade $http_upgrade;
         proxy_set_header Connection "upgrade";
         proxy_set_header Host $http_host;
         proxy_set_header Origin "";
    
         proxy_set_header X-Real-IP $remote_addr;
         proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
         proxy_set_header X-Forward-Proto https;
         proxy_set_header X-Nginx-Proxy true;
    
         proxy_redirect off;
     }
    
     location / {
    
         proxy_pass http://docker-jitsi-meet-master_web_1:80;
         proxy_http_version 1.1;
         proxy_set_header Upgrade $http_upgrade;
         proxy_set_header Connection "upgrade";
         proxy_set_header Host $http_host;
         proxy_set_header Origin "";
    
         proxy_set_header X-Real-IP $remote_addr;
         proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
         proxy_set_header X-Forward-Proto https;
         proxy_set_header X-Nginx-Proxy true;
    
         proxy_redirect off;
     }
    
  3. Jitsi running on Docker:
    docker-jitsi-meet-master_jicofo_1
    0.0.0.0:4443->4443/tcp, 0.0.0.0:10000->10000/udp docker-jitsi-meet-master_jvb_1
    5222/tcp, 5269/tcp, 5280/tcp, 5347/tcp docker-jitsi-meet-master_prosody_1
    0.0.0.0:8000->80/tcp, 0.0.0.0:8443->443/tcp docker-jitsi-meet-master_web_1

So far so good. It works perfectly and Jitsi is a really good solution. I have configured JWT authtication and it woorks fine with Rocketchat. As soon as somebody from a corporate network tries to connect it does not work. I can see that he he has a connection (Quality Good) and he can chat but there is no voice / video. I have read a lot articles and i guess that the TCP Fallback is not working for JVB or that i need a TURN server. I have found no thread that has my specific configuration and i am looking for help because i can’t find a working solution.

Thanks :slight_smile: