Jitsi and Asterisk in the same server

Hi!

I´m trying to use Jitsi and Astersk 16 in the same server to cut costs.

Asterisk and jitsi works very well in the same server ubuntu 18.04

I have an inbound DID and some extensions connected to asterisk.

The jigasi peer register in the local asterisk .

654348/654348 127.0.0.1 D Yes Yes A 56992 OK (5 ms)

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP:654348@sitroom.com.br
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=(password)
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=sitroom.com.br
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=654348@sitroom.com.br

The problem is that when i dial the jigasi peer to connect an local sip peer or external call to some conference room i receive this message from asterisk:

Not accepting call completion offers from call-forward recipient

And the channels are not bridged.

I think the problem is that jigasi is sending the rtp to the external adress and not to the local adress.

2020-02-03 10:38:22.871 SEVERE: [369] org.jitsi.impl.neomedia.RTPConnectorOutputStream.log() Failed to send a packet to target /207.246.83.12:10000:java.io.IOException: No active socket.
2020-02-03 10:38:22.877 SEVERE: [207] org.jitsi.impl.neomedia.RTPConnectorOutputStream.log() Failed to send a packet to target /207.246.83.12:10000:java.io.IOException: No active socket.

Where in jigasi i can configure to send rtp to the local adress 127.0.0.1 ?

Hi Claudio,

I had the same problem, have you try disabling re-invites in asterisk?

I’m using pjsip, setting directmedia=no fixed the problem.

Regards,

Lucas

Hi!

Thank you for your reply.

The same problem using this … what i think strange is that it is trying to do a forward…

– SIP/654348-00000011 is ringing
– Now forwarding SIP/vonex41-00000010 to ‘Local/11996012677@jitsi’ (thanks to SIP/654348-00000011)
[Feb 3 17:51:29] NOTICE[6332][C-00000012]: app_dial.c:1006 do_forward: Not accepting call completion offers from call-forward recipient Local/11996012677@jitsi-00000002;1
[Feb 3 17:51:29] NOTICE[6332][C-00000012]: core_local.c:734 local_call: No such extension/context 11996012677@jitsi while calling Local channel
[Feb 3 17:51:29] NOTICE[6332][C-00000012]: app_dial.c:1112 do_forward: Forwarding failed to dial ‘Local/11996012677@jitsi’

This happens in yours too?

PS. i have a system using a server for asterisk and other for jitsi that works very well…and it bridges the call without triyng to make a forward.

1 Like

Hello, I have the same problem. Asterisk+jigasi+jitsi-meet.

sip.conf

[24995]
directmedia=no
dtmfmode=rfc2833
type=friend
host=dynamic
port=5060
username=24995
secret=012345
context=jitsi
nat=no
disallow=all
allow=g722
allow=ulaw
allow=g729

extensions.conf

[jitsi]
exten => 24995,1,SIPAddHeader(Jitsi-Conference-Room: n2400)
exten => 24995,n,SIPAddHeader(Jitsi-Conference-Room-Pass: 456)
exten => 24995,n,Dial(SIP/24995,30,tr)
exten => 24995,n,Hangup

logs

== Using SIP RTP CoS mark 5
– Executing [24995@fku:1] Gosub(“SIP/24074-000002c5”, “conferences,24995,2”) in new stack
– Executing [24995@conferences:2] Gosub(“SIP/24074-000002c5”, “jitsi,24995,1”) in new stack
– Executing [24995@jitsi:1] SIPAddHeader(“SIP/24074-000002c5”, “Jitsi-Conference-Room: n2400”) in new stack
– Executing [24995@jitsi:2] SIPAddHeader(“SIP/24074-000002c5”, “Jitsi-Conference-Room-Pass: 456”) in new stack
– Executing [24995@jitsi:3] Dial(“SIP/24074-000002c5”, “SIP/24995,30,tr”) in new stack
== Using SIP RTP CoS mark 5
– Called SIP/24995
– SIP/24995-000002c6 is ringing
– SIP/24995-000002c6 is ringing
– SIP/24995-000002c6 is ringing
– Now forwarding SIP/24074-000002c5 to ‘Local/24074@jitsi’ (thanks to SIP/24995-000002c6)
[Feb 14 09:42:50] NOTICE[19829][C-00000190]: app_dial.c:1006 do_forward: Not accepting call completion offers from call-forward recipient Local/24074@jitsi-00000053;1
[Feb 14 09:42:50] NOTICE[19829][C-00000190]: core_local.c:734 local_call: No such extension/context 24074@jitsi while calling Local channel
[Feb 14 09:42:50] NOTICE[19829][C-00000190]: app_dial.c:1112 do_forward: Forwarding failed to dial ‘Local/24074@jitsi’
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [24995@jitsi:4] Hangup(“SIP/24074-000002c5”, “”) in new stack
== Spawn extension (jitsi, 24995, 4) exited non-zero on ‘SIP/24074-000002c5’

You can enable verbose sip logging in asterisk and do such a call and upload the result, it may hint the problem.

Hi Damencho

I will do it. Thank you

But I think the problem is that jigasi is sending the rtp to the external adress (real adress that resolv by the domain configured) and not to the local adress and so asterisk don´t know how to deal with it.

2020-02-03 10:38:22.871 SEVERE: [369] org.jitsi.impl.neomedia.RTPConnectorOutputStream.log() Failed to send a packet to target /207.246.83.12:10000:java.io.IOException: No active socket.
2020-02-03 10:38:22.877 SEVERE: [207] org.jitsi.impl.neomedia.RTPConnectorOutputStream.log() Failed to send a packet to target /207.246.83.12:10000:java.io.IOException: No active socket.

Where in jigasi i can configure to send rtp to the local adress 127.0.0.1 ?

There is no such option. jigasi sends the rtp to the address that is in the sdp, so this is an asterisk configuration, I’m pretty sure there was some media rtp address/ip setting there, but it will affect all accounts I suppose. But if the sip provider is doing latching (normally they do), this will not matter as they will send rtp traffic to the address port they received it from.

Hi Thank you.

The problem is that this happens even with local registered peers. The call is sent from that peers and the response comes with the external adress of the dns. Ok if the response comes with the external adress of the registered peer but it comes every time with the external adress of the machine dns. Maybe i´m missing something but i think that jigasi even registered with 127.0.0.1 caný use the local adress…it will use the dns.

I’m confused, you were talking about media, now you switched to signalling.
So Jigasi’s sip provider always uses a outbound proxy, if such is not configured it will use the dns to search for it in this order NAPTR, SRV, AAAA and A records. If you specified it you can force it to send signalling to 127.0.0.1.

This is how you can do this: [jitsi-users] Jigasi default SIP port

Thank you! i will test and post the results.

I have installed Jitsi and Freeswitch in the same server.
Everytime I restart my server, Freeswitch will take more time then jigasi in starting. and jigasi will register failed as freeswitch is still in starting. I have to restart jigasi server manually.

Well, after some time testing i discovered that the current version of jigasi has a bug that afffect the incoming calls from asterisk (don know about other). if you want that working you have to use: apt-get install jigasi=1.0-235.

Many people reported this but i found no other solution in here.

The current version do not answer so no incomming calls.
You have to use asterisk version 13 or > one that compile with opus codec.

Hope this helps someone out there.

2 Likes

Day saver , thank you for posting this

4 hour saver…