Jitsi and apache2: no vid/audio prosody problem?

Hi,
I got the apache proxy working (finally, dont forget ‘a2enmod include’ people !), but there is no video nor audio.
I am on a vps facing the net directly. Ubuntu 18.04.

I think prosody is the issue here, as it is eyeing port 443 and prosody.err show this:

net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
{java vomits 10+ lines of errors}
Caused by: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received
from conference.meet.xxxxx.nl: XMPPError: remote-server-not-found - cancel
{more java vomit}

In prosody’s meet.xxxxx.nl.cfg.lua I disabled the Virtualhost “meet.xxxxx.nl”, because I already declared a VirtualHost in apache working on port 443.

This results in another error, but in jicofo :

SEVERE: [162] org.jitsi.jicofo.ComponentsDiscovery.log() Failed to discover services on meet.xxxx.nl

Does anybody have a way out of this maze, a pointer ?

thx.S

Hello!

I just git the same problem trying to use apache2 instead of nginx on Ubuntu 20.04.

Did you solve this problem?

Thank you!

OK, solution is quite simple.
In config.js change
muc: 'conference.<!–# echo var=“subdomain” default=""
to
muc: 'conference.MYSERVER"

Dunno why it works with nginx though.