Jitisi-meet react native buid error

#1

I got this error when I run react-native run-android in jitsi meet If you can give me a solution to fix this error it would be great

chashika@chashika-XPS-15-9530:~/Projects/jitsi-meet$ react-native run-android
info JS server already running.
info Building and installing the app on the device (cd android && ./gradlew app:installDebug)…

Configure project :@react-native-community_async-storage
Checking the license for package Android SDK Build-Tools 28.0.3 in /home/chashika/Projects/jitsi-meet/android/build/android-sdk/licenses
Warning: License for package Android SDK Build-Tools 28.0.3 not accepted.
Checking the license for package Android SDK Platform 28 in /home/chashika/Projects/jitsi-meet/android/build/android-sdk/licenses
Warning: License for package Android SDK Platform 28 not accepted.

FAILURE: Build failed with an exception.

  • What went wrong:
    A problem occurred configuring project ‘:@react-native-community_async-storage’.

Failed to install the following Android SDK packages as some licences have not been accepted.
build-tools;28.0.3 Android SDK Build-Tools 28.0.3
platforms;android-28 Android SDK Platform 28
To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
Alternatively, to transfer the license agreements from one workstation to another, see http://d.android.com/r/studio-ui/export-licenses.html

Using Android SDK: /home/chashika/Projects/jitsi-meet/android/build/android-sdk

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.
See https://docs.gradle.org/4.10.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 0s
error Could not install the app on the device, read the error above for details.
Make sure you have an Android emulator running or a device connected and have
set up your Android development environment:
https://facebook.github.io/react-native/docs/getting-started.html
error Command failed: ./gradlew app:installDebug. Run CLI with --verbose flag for more details.

#2

The answer is right there in the error message. You must accept the license for the Androlid SDK. If you are using Android Studio, just start it and accept the prompt. If you are using the command line ones, you should be able to fix it with this command: yes | sdkmanager --licenses

#3

I have accepted all the licenses. but it’s not working.

#4

Have you installed build tools 28.0.3?

#5

Now that problem ok. I had a problem with make and I could fix that. I didn’t configure any local server before doing that. do I need to configure a local server. I got this error now in emulator

#6

Ho are you running the app? From the command line or from Android Studio?

#7

from command line

#8

Can you show the CLI output?

#9

#10

What command are you running to build the app?

#11

react-native run-android

#12

Doesn’t a new terminal open with the metro bundler? You can trigger it by hand with react-native start and then tap on Reload.

#13

Hi @chashikajw …can we connect to resolve issues? my email id: vvkkr21@gmail.com