Jitisi-meet On Ubuntu 18.04 Headless

All, I know there are many, many posts on this.

I have tried Debian 10.3 “BUSTER” 3 times … with apache2 … same symptoms of:

  • Both my camera and audio are working just fine
  • When I go to the webpage (in Chrome), the Jitsi page shows up just fine. The little light of my camera is activated right away. When I go to the Jitsi device settings, I can see the webcam image is working. Audio is recognized as well.
  • But I have no video/audio when actually using it, so I cannot see myself / cannot activate the camera. After a while, I get a message saying that the network connection is lost and it will reconnect in 30 seconds or so.

I read on line that BUSTER has too new a version of JRE. So, I tried Ubuntu 18.04 headless LTS.

Exact same problem … and I tried 3 times from scratch with it.

Followed all the advice related to opening ports (80, 443, 4443, 10000-20000 UDP). No joy.

Added: org.jitsi.jicofo.ALWAYS _TRUST_MODE_ENABLED=true … to /etc/jitsi/jicofo/sip-communicator.properties …

Added the specific PUBLIC and PRIVATE address lines from the “advanced config guidance”.

Made sure the /etc/nginx/sites-available/my.domain.ext.conf and /etc/jitsi/meet/my.domain.ext-config.js reflected my domain … both with and w/o the hostname.

Still no joy.

I’m using nginix.

Kinda desperate at this point.

Thks,

Pat

Resolved.

My hostname is “jitsi”.

I had to fix the DNS name in /etc/hostname to my FQDN.

I changed it to “jitsi.mydomain.com


I also had to modify /etc/hosts.

The default entry was: “127.0.0.1 localhost jitsi”

I changed it to: “127.0.0.1 localhost jitsi.mydomain.com