Jisti Ios Build directory permission issue

I am using JITSI SDK in IOS for live streaming. The SDK was installed using cocoapods. Previously I was using JITSI SDK 7.0.0(which was working fine). We faced ARM64 issue intermittently on 7.0.0. We tried updating the SDK to latest version and now we are facing the below issue.

Details of Platform versions.

Swift version: 5.7
Xcode version: 14.2
Mac OS version: Ventura 13.1
JITSI SDK version: 7.0.1

Build Log:

CreateBuildDirectory /JitsiWebRTC

cd /Users/css/Desktop/Whaot/whaot-ios
builtin-create-build-directory /JitsiWebRTC

error: mkdir(/JitsiWebRTC, S_IRWXU | S_IRWXG | S_IRWXO): Read-only file system (30)

mkdir(/JitsiWebRTC, S_IRWXU | S_IRWXG | S_IRWXO): Read-only file system (30)

The folder in which JITSI tries to execute mkdir has enough permission. Screenshot attached

JitsiIssues.txt (1.7 KB)

Please help us on resolving this issue.


What exactly are you trying to do? Please describe it from the start.

Hi Sagul,

I am trying to use Jitsi Meets iOS SDK through Cocoapods. When I try to generate a build on XCode, it is failing with a permission denied error. But I have verified that the build folder on my laptop has the right permissions. So I am trying to understand what is causing the build to crash with a permission error.

I am having this issue ever since we received a new release of Jitsi SDK when it was updated for M2 platform. I have not done any changes on my end except updating the Jitsi SDK and XCode on my end. I have also tried to delete and recreate the project on XCode but still having the same issue. So I strongly believe it is not a proj ct folder permission issue at this point.

Hope this helps. Looking forward to any suggestions Thanks Sagul

I honestly don’t know.