Jigasi with 3CX ipbx

Hello,

I’ve tried to connect Jigasi with my 3CX IPBX but it doesn’t work.
I’m sure about the credential, because I can connect with the same SIP account, on Jitsi Desktop.

3CX requires both User-ID and Autorization-ID
In Jitsi Desktop, I configure the user, and the authorization name

In Jigasi, i tried to configure UserID and Account UID, but it doesn’t work !!

Here my jigasi.log :
2019-10-28 12:22:25.191 INFOS: [51] org.jitsi.jigasi.SipGateway.registrationStateChanged().105 REG STATE CHANGE ProtocolProviderServiceSipImpl(32@aleksopbx.my3cx.fr (SIP)) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Connection Failed; reasonCode=3; reason=Received an error while trying to register. Server returned error:User unknown.]

Here my 3CX log :
28/10/2019 12:22:25 - [CM102001]: Authentication failed for AuthFail Recv Req REGISTER from username=“32”,realm=“3CXPhoneSystem”,nonce=“414d53595db6cf7178:887b962c8ccfa69983d8799fe328c2d7”,uri=“sip:aleksopbx.my3cx.fr;transport=tcp”,response=“060851264d112f63c97cec7549f4de0b”,algorithm=MD5
User-Agent: Jitsi2.11.0.build.by.SVNLinux
Content-Length: 0

; Reason: Credentials don’t match, check that authorization-ID and password match the ones in extension settings

Thank you for your help

You don’t need to modify UserID and Account UID, revert them as they were.
You need to add AUTHORIZATION_NAME property with the correct value.
You can go to Jitsi Desktop -> Settings -> Advanced -> Property Editor, find your account id and search it something like acc1553 and you can see all your props used in the desktop app so you can use same for jigasi.

It works fine now
Thank you for your help

Hello,

I can call a phone when I’m in a meeting, it works Fine.
I also can join a meeting by phone, when i call the meeting number, i can join the default meeting room.

I see that is possible, with an IVR to ask a PIN code to the user, and he can join a specific room.
The problem is than I can’t send Custom SIP Headers with 3CX IPBX (known limitation).
Has somebody encountered this problem ?

Thank you for your help

Nobody ? :frowning:

There is no other way for the moment other than sending a SIP Header to specify the meeting name to be used to join.

Thank you
Maybebe I can use other SIP Headers that my IPBX can send ?

In jigasi you can configure the Header name by adding account property to the sip account like:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-Room-Name

I will try that
Thank you

Hello I want connect jitsi over jigasi to 3cx

I installed jitsi-desktop and i created a account with success to 3cx. I had a look in the property editor
to find the AUTHORIZATION_NAME

So i filled out the sip-commincator.properties.

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=Xinux2Xinux
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP:50@asterix.homer.org
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=ODg4LVN1eGVyLTc3Nw==
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=asterix.homer.org
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=50@asterix.homer.org

but i get

2020-03-30 22:29:10.404 INFO: [53] org.jitsi.jigasi.SipGateway.registrationStateChanged().105 REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:50@asterix.homer.org) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Authentication Failed; reasonCode=1; reason=null]
2020-03-30 22:29:10.404 SEVERE: [53] org.jitsi.jigasi.ServerSecurityAuthority.log() Wrong username or password for provider:ProtocolProviderServiceSipImpl(SIP:50@asterix.homer.org)

any ideas?

I filed up all setting frim jitsi desktop to connect jigasi to 3cx with no success … I captured the packets with wireshare - they look like the same jitsi-desktop and jigasi … but i get an “Wrong username or password” when i tried to connect with jigasi … i copied the base from jitsi desktop to jigasi no success …

finaly i looked in the logs of 3cx all the same but i get wrong username or password error …

There was an nounce … it is posible that the ist here?

I am an idiot …

(*) Disable External Calls was checked, after an uncheck it works perfect :slight_smile:

I am also attempting to connect to an extension on my 3cx server for Jigasi to utilize for incoming conference calls. I provide the extension#@fqdn and the password during install, but I don’t get any phone in option afterwards. I also cannot find jigasi-home referenced in other posts or any other config files for Jigasi. Any help would be greatly appreciated!

Hi Damencho,

This number in sip account : 1403273890647
is random or it is specific and related to something else?

Can I create as much accounts as I want?
for instance :

  • acc1403273890647
  • acc1403273890648
  • acc1403273890649
    etc.

Thanks by advance for your answers.

Hi,

I made a try, I added this in jigasi sip-conmmunicator.properties :

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-test1  -- also made a try without  'X-'
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:5501@mysite.my3cx.fr
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.AUTHORIZATION_NAME=T9YU4qFkap
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=TTJXQktNoaA==
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=mysite.my3cx.fr
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=5501@mysite.my3cx.fr
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=750
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=650
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=1000
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890648=acc1403273890648
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-test2  -- also made a try without  'X-'
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.ACCOUNT_UID=SIP\:5502@mysite.my3cx.fr
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.AUTHORIZATION_NAME=T9YU4qFkap
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.PASSWORD=TTJkt3NTNA==
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.SERVER_ADDRESS=mysite.my3cx.fr
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.USER_ID=5502@mysite.my3cx.fr
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.AMR-WB/16000=750
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.G722/8000=700
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.PCMU/8000=650
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.iLBC/8000=10
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.opus/48000=1000
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.DEFAULT_ENCRYPTION=false
...
...
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=mysite.org
net.java.sip.communicator.impl.protocol.sip.acc1403273890648.DOMAIN_BASE=mysite.org

This way I thought that calls to 5501 would lead directly to test1 and call to 5502 would lead automatically to Test2.

But this does not works as expected, calls are still routed to default jvb session : siptest.

Any idea of what I’m doing wrong?

No, jigasi currently can operate with one sip account. The headers needs to be set in the sip incoming headers, containing the jid of the room to join

Ok thanks for your answer. But then what’s the purpose of this line :

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-test2

Does this means that only this header can be joined even if someone provide a good header for another room?

This is the header name which jigasi will check to find to which room to connect to.

Ahhh Ok. I misundestrood it.
Now that make sense.

I’ll give a try.

Many thanks

Hello @Thomas_Ralf_Will

I also try to connect Jigasi and 3CX together without success. Jigasi log sent to me a timeout from the 3cx server.
I already add AUTHORIZATION_NAME in the jigasi config file.
To be sure I try my credential with a SIP client like Zoiper and Jitsi desktop. Zoiper works every time but Jitsi desktop sometimes yes and sometimes no…
So I guess my credential are ok, and 3cx conf also.
Do you have an idea what did you do for jigasi works with 3cx? Maybe a special conf or whatever?
any help would be great.
Thanks in advance
xavier