Jigasi Transcription

Hi there,

First I would like to tell you how Jitsi is awesome for me.
I’m hosting VC for 10-15 Friends during this strange COVID time.

As all looks good with my Debian Jitsi-meet server, I would like to add transcription feature.
So I follow the QIG found here for Jigasi.

But I’m stuck now:

  • Jigasi is launched, can see the java process running
  • launching room and hit “CC” button, and… nothing.

Got 3 SEVERE in jigasi logs, but I saw that it can be ignored:

jigasi.log:2020-04-18 17:18:39.368 SEVERE: [11] impl.configuration.ConfigurationActivator.log() Error creating c lib instance for fixing file permissions
 jigasi.log:2020-04-18 17:18:39.699 SEVERE: [11] impl.sysactivity.NetworkManagerListenerImpl.<init>().60 Cannot obtain dbus connection
jigasi.log:2020-04-18 17:18:40.196 SEVERE: [11] org.jitsi.impl.neomedia.device.DeviceConfiguration.log() Failed to register custom Renderer org.jitsi.impl.neomedia.jmfext.media.renderer.audio.PulseAudioRenderer with JMF.

On Jicofo side:

Jicofo 2020-04-18 16:57:26.367 INFO: [31] org.jitsi.jicofo.ComponentsDiscovery.log() New component discovered: focus.conf.cieloasis.com, null
Jicofo 2020-04-18 16:57:26.381 INFO: [31] org.jitsi.jicofo.ComponentsDiscovery.log() New component discovered: callcontrol.conf.cieloasis.com, null
Jicofo 2020-04-18 16:57:26.381 INFO: [31] org.jitsi.jicofo.JitsiMeetServices.log() Discovered SIP gateway: callcontrol.conf.cieloasis.com
Jicofo 2020-04-18 17:18:45.662 SEVERE: [57] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for null
Jicofo 2020-04-18 17:18:45.662 INFO: [57] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber
Jicofo 2020-04-18 17:18:45.663 WARNING: [57] org.jitsi.jicofo.jigasi.TranscriberManager.log() Unable to invite transcriber due to no Jigasi instances being available

I do no dot enable SIP feature, just transcription:

org.jitsi.jigasi.ENABLE_TRANSCRIPTION=true
org.jitsi.jigasi.ENABLE_SIP=false

I have reviewed lots of topics, but none worked.

Kr,
Cma

Hi,
Do I need SIP gateway enabled to make Transcription working ?

KR,
Cma

Hey there, same here. I am fully struggling with the doc and the various problems.

I changed this
/etc/jitsi/meet/my.domain-config.js

// Call control component (Jigasi).
call_control: 'callcontrol.my.domain',

// Transcription (in interface_config,
// subtitles and buttons can be configured)
transcribingEnabled: true,

and, as /etc/prosody/prosody.cfg.lua contains everything in conf.d subfolder, I added the config in my virtual host file:
/etc/prosody/conf.d/my.domain.cfg.lua

**Content:**

Component "callcontrol.my.domain"

component_secret = "secret"

You should also add (How to config transcrption?) your Google SDK credentials to

vi /etc/jitsi/jigasi/config

GOOGLE_APPLICATION_CREDENTIALS="/etc/jitsi/jigasi/TranlatorApiDemo.json"

Therefore I copied it as recommended:
`

cp /root/.config/gcloud/application_default_credentials.json /etc/jitsi/jigasi/TranslatorApiDemo.json

`

chown jigasi:jitsi TranslatorApiDemo.json

chmod o+r TranslatorApiDemo.json

chmod g+r TranslatorApiDemo.json

Nothing helps, meetings now even fail and break.

I am also getting this error in trying to use the Transcribe feature.

  • I added google application link , enabled the CC button, but when I click on the cc button, I get this message:

Jicofo 2020-05-06 11:21:32.330 SEVERE: [49] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for null
Jicofo 2020-05-06 11:21:32.330 INFO: [49] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber

Hi @HachimanSec

Did you get the transcription to work?
I’ve been facing the same issue and don’t know how to proceed.