JIgasi transcription with gcloud on remote server


i want use Jigasi transcription using google cloud service.
but i can’t install gcloud on machine that Jigasi is running.
can i install gcloud on another matchine and configure Jigasi to use romote server that gcloud in running on?


Nope, there is no such option.

I don’t think you need to install gcloud on the Jigasi machine. All you need are the service account credentials, which you need to configure in sip properties. So if you have those, you are good.

For transcriptions you need GitHub - jitsi/jigasi: Jigasi: a server-side application acting as a gateway to Jitsi Meet conferences. Currently allows regular SIP clients to join meetings and provides transcription capabilities.

Yes, this I tried asking before, whether or not we need gcloud installed? And I tried on my setup, without that.

I am able to use transcription services without installing gcloud, by simply using service account credentials.

Maybe someone else can give this a try…

Nice … now I remember that was mentioned … ok. Maybe the dependencies is enough. Thanks for further clarifying

Hello Prashanth

Could please share your sip properties

Thank you in advance

Just default sip properties…with one addition of Google credentials path…

Thank you for your reply.
can I add the following to (etc/jitsi/jigasi/sip-communicator.properties)

Thank you

Jigasi user cannot read that file from root home.

Thank you for your reply
is this will work?
I also added the file TranslatorApiDemo.json to the folder

Thank you agin

I am a little confused. You say, in below post that you got subtitles working…Then wonder why you are still looking to add google credentials path…

subtitles work for the first time and stop working that why i attached both log.

as if now is not working…

I appreciate if you can help

If your sip properties doesn’t contain the google credentials path, subtitles will not work. So if it worked once, it does mean that you do not need to worry about the credentials path. Something else should be the issue.

I see. I am trying everything to get it to work, I have been trying everything.I appreciate if you can help

Make sure you have google service credentials…

I do have application_default_credentials.json and its correct.
Only happen when i have
In etc/jitsi/jigasi/sip-communicator.properties

If i change
I can see it in chat but no subtitles

You need this to get subtitles…

And I see those errors too, that you have mentioned and they will or should go away if you stop/start subtitles, by clicking on CC button…

correct i need
as you suggested i tried stop/start subtitles, by clicking on CC button…many times. I also tired to sudo systemctl restart jigasi

I am new here i am not sure if i am allowed to share my screen. so you can see my configuration.
I truly i appreciate you helping me