Jigasi Transcription Problem - Reading from SSRC while it is not known as a participant

This is fixed now in the latest version in unstable 1.1-123-g3883344.

1 Like

Hi @Damencho, is this fix available docker builds too.
I tried latest build but showing same error,

If this is still to be updated, can you help what basic steps I’d need to make to build image myself.

Thanks

We will update soon stable … Which will mean and docker.

Thanks, that’s sounds good, any timeline you have in mind when we can expect that please.

I was wondering if I can try this building myself before the official come live.
If you can give any pointers, where and how to begin. I’ll try and update.

right now, I tried changing jigasi Dockerfile by adding
apt install jigasi=1.1-123-g3883344
but it did not find that.

edit : i think i need to add unstable repo for this in apt sources. but looks like its not working either.

I just pushed latest jigasi to stable.

amazing, I can see latest version in stable branch
jigasi/stable 1.1-126-g6df3db2-1 amd64

I will update here how it goes .

just completed my basic tests after running make and building new docker images.
ensured that docker container now sees this new jigasi version and

transcription seems to be working OK now. :relaxed:

Will test more today & tomorrow.

Thanks again

@damencho,

so far all looks good, but I have two queries
a) how can i make the transcriber join hidden, right now it joins as visible participant.
I have jibri setup as well and have below configuration
hiddenDomain :'recorder.meet.example.com',

given that , can I make transcriber join as hidden.

b) i tried running two conference in parallel and in both I enable ‘CC’ button and transcriber joined and transcription working OK.
I initially thought it might be one instance of jigasi per transcription same as jibri … but looks like it is very different from it.

How many conference can be transcribed by one jigasi instance. and when should i consider scaling this when running on docker.

Yeah jigasi can have multiple sessions simultaneously, the problem at some point can cone from Google if you hit some quatas, but you can apply for increase.
You can authenticate transcriber in the same domain recorder and that will hide it.

I found another reason jigasi got disconnected after 2 seconds.
if you have jigasi installed on the same machine,

jigasi ICE harvester enabled ==> stun.jitsi.net:3478/udp
cannot resolve host stun.jitsi.net and therefore
“no active port for jvb”
then disconnected.

which version of jigasi is this? In what cases is this happening?

jigasi version: 1.1-126-g6df3db2-1

enabled UI to invite “jitsi_meet_transcribe” into the room. From prosody log saw jigasi is connected as well as the host can see transcriber joined. After 2~3 seconds, got disconnected.
I changed jigasi log level to INFO and found exception thrown at cannot resolve host “stun.jitsi.net” nor result from nslookup. Couldn’t find the setting anywhere, my config for

org.ice4j.ice.harvest.StunCandidateHarvest.sendRequest() Failed to send BINDING-REQUEST(0x1)[attrib.count=2 len=24 tranID=0x66C0FE4177013B8868460CA5] through 192.168.81.54:10001/udp to stun.jitsi.net:3478/udp java.lang.IllegalArgumentException: unresolved address
Couldn’t find the setting anywhere, my config.js is
`stunServers: [

        // { urls: 'stun:jitsi-meet.example.com:4446' },
        { urls: 'stun:meet-jit-si-turnrelay.jitsi.net:443' }
    ],`

Can you test with latest jigasi that is in stable? Do you get the same?

Check js console logs? Check jicofo logs?

Thank you, found error in jicofo.log

Jicofo 2021-01-27 16:15:12.493 SEVERE: [114] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for null

hum, which jitsi-meet is that? is it latest?

dpkg -s jitsi-meet
Version: 2.0.5390-3
Depends: jicofo (= 1.0-692-hf-1), jitsi-meet-web (= 1.0.4628-1), jitsi-meet-web-config (= 1.0.4628-1), jitsi-meet-prosody (= 1.0.4628-1)

with jigasi version upgraded to
Version: 1.1-166-g929a439-1

looks like they have the same problem here:

and

looks like since then there’s a diff with master branch

private Collection getBridgeRegions()
{
FocusManager focusManager =
ServiceUtils.getService(
FocusBundleActivator.bundleContext,
FocusManager.class);

    try
    {
        JitsiMeetConferenceImpl conference =
            focusManager.getConference(
                JidCreate.entityBareFrom(chatRoom.getIdentifier()));

        if (conference == null)
        {
            logger.debug("Cannot find conference for "
                + chatRoom.getIdentifier());
        }
        else
        {
            return conference.getBridges().stream()
                .map(b -> b.getRegion())
                .filter(Objects::nonNull)
                .collect(Collectors.toSet());
        }
    }
    catch (XmppStringprepException e)
    {
        logger.error("Error finding room for " + chatRoom.getIdentifier());
    }

    return new ArrayList<>();
}

Trace git found bgrozev 2021/1/14 changed the code of catch exception in TranscriberManager.java so maybe nightly build after jicofo 699 package can solve this issue ?

jicofo_1.0-699-1_all.deb

I was.testing with the version from the stable and didn’t see any issues.
Was that the only print in jicofo … ?
I will check again today I think there is wrong message printed there even on successful calls …