Jigasi Transcriber

I tried to setup transcriber with the below mentioned commands.
Installed jigasi with latest packages.

Jigasi Installation

sudo apt install jigasi
Give any random user and password, when prompted for SIP details

cd /etc/jitsi/meet

sudo chmod 777 -R hostname.config.js (If there is no permissions)

sudo nano hostname.config.js (Edit file)

sudo nano /etc/jitsi/jigasi/sip-communicator.properties

Need to uncomment these below lines

org.jitsi.jigasi.ENABLE_TRANSCRIPTION=true
org.jitsi.jigasi.ENABLE_SIP=true
org.jitsi.jigasi.transcription.DIRECTORY=/var/lib/jigasi/transcripts
org.jitsi.jigasi.transcription.BASE_URL=http://localhost/
org.jitsi.jigasi.transcription.jetty.port=-1
org.jitsi.jigasi.transcription.ADVERTISE_URL=false
org.jitsi.jigasi.transcription.SAVE_JSON=true
org.jitsi.jigasi.tanscription.SAVE_TXT=true
org.jitsi.jigasi.transcription.SEND_JSON=true
org.jitsi.jigasi.transcription.SEND_TXT=true

 create a file with name YourJsonFile.json ,in /opt  directory()       

sudo nano polytok.json (add your google application credentials)

sudo nano /etc/jitsi/jigasi/config (add below line in this file)
GOOGLE_APPLICATION_CREDENTIALS=“/opt/YourJsonFile” (ex: name.json)

sudo apt-get install apt-transport-https ca-certificates gnupg && echo “deb [signed-by=/usr/share/keyrings/cloud.google.gpg] Index of /apt// cloud-sdk main” | sudo tee -a /etc/apt/sources.list.d/google-cloud-sdk.list && curl https://packages.cloud.google.com/apt/doc/apt-key.gpg | sudo apt-key --keyring /usr/share/keyrings/cloud.google.gpg add - && sudo apt-get update && sudo apt-get install google-cloud-sdk && sudo apt-get install google-cloud-sdk-app-engine-java && sudo apt-get install google-cloud-sdk-app-engine-python

gcloud auth activate-service-account --key-file=/opt/yourJsonFile

sudo reboot.

Is there anything I am missing.

+1

+1

Make sure your transcriber is authorized and using the domain from hidden domain config.

Is this a new requirement in recent version? This was working in previous versions with TRUST enabled in the sip config.

I think there were changes in the UI. But this is the way the transcriber was always used.

Got it. I’ve installed from packages and I see it created a jigasi user in prosody. How can I get that password or would I have to create a new user for the hiddenDomain?


Ok. Authed “transcriber” user working and still the same failed results.

Upload logs from jigasi and from the browser, please.

consolelog.txt (91.0 KB)
jigasi.txt (42.9 KB)
Attached

Hum and recorder.meet… is set as a hidden domain?
This is the latest stable version?

Yep. Just installed it two nights ago :slight_smile:

Yesterday, I tried with latest version(2.0.8218) still I am getting the same issues.

That is strange. Can you update jigasi from unstable repo and see whether that fixes it?


@damencho This is the working configuration.

This has nothing to do with jvb nor jicofo

Yep this issue is still present in the unstable repo as well.

+1

Yep, I confirm that and we are looking into it.

1 Like

Commit 202441d

Man… what a tease :smiley: