Jigasi SIP Calling

Update to latest and try again, do you experience the same? And maybe share your config …

Hello Damian,
I have no change.
I appreciate if you can look into the dial plan and SIP properties
Please see attachedasterisk config.txt (4.9 KB)

sip-communicator.propertiest.txt (16.6 KB)

Thank you for your help

In your config you had set

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-Room-Name

to use header X-Room-Name, but you are sending header Jitsi-Conference-Room

Hello Damian,
I have tried so many configuration by comment out this line.please see attached Sip SIP properties, still the same

#net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=X-Room-Name

Thank you sip-communicator.propertiest_1.txt (16.7 KB)

Now you have:

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=Jitsi-Conference-Room@muc.meet.domain.com
Which is not correct, remove that, restart jigasi and try again.

Hello Damian, I removed “net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=Jitsi-Conference-Room@muc.meet.domain.com
and started jigasi now the call hangup and said please contact your support.

Upload jigasi logs. and there is no such message played from jigasi it is coming from asterisk.

Hello Damian,

You are correct the message is coming from asterisk
but when i added
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=Jitsi-Conference-Room@conference.meet.domain.com
Now, I’m unable to join any room provided with “Jitsi-Conference-Room” header in SIP INVITE. It always tries to join default room that is “siptest”

jigasi-2.log (70.6 KB)

Thank you

This is not correct as I already told you, drop that, restart jigasi, try and show the logs you see.

Hello Damian,

please see jigasi log
jigasi-3.log (49.2 KB)

Thank you

So you still have few problems you need to resolve:

  1. In your jigasi config you have:
org.jitsi.jigasi.MUC_SERVICE_ADDRESS=conference.meet.Domain.com
org.jitsi.jigasi.MUC_SERVICE_ADDRESS=muc.meet.Domain.com

Leave only the correct one.

  1. Your asterisk is sending empty values for:
        Jitsi-Conference-Room-Pass: 
        Jitsi-Conference-Room: 

From the last log everything looks ok, jigasi complains that you have sent an empty room.

  1. Do not send Jitsi-Conference-Room-Pass if the room has no password set, that may lead to other errors.

Hello Damian,

I followed your instructions (1-3)
Now, the call does not connect even to the siptest room it hangs up immediately… please see jigasi log
jigasi-4.log (93.8 KB)

On step (2) on asterisk , now i am send the follwoing
exten => s,n(enterconf),SIPAddHeader(Jitsi-Conference-Room:${CURL_RESULT})—is this correct?

I am not sure if its allowed if I can provide goto meeting link to share my screen and log you into the server.
Please advise. Thank you

No idea. But for sure what jigasi sees is that ${CURL_RESULT} is empty.
You need to fix your asterisk logic.

We do not offer customer support, sorry.

1 Like

Hello Damian,

Thank you for your reply.
I will continue working on asterisk logic. In mean time any idea why siptest stopped working after i removed
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=Jitsi-Conference-Room@conference.meet.domain.com

I am thankful for all your help

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.JITSI_MEET_ROOM_HEADER_NAME=Jitsi-Conference-Room@conference.meet.domain.com

This means you need to have a sip header named “Jitsi-Conference-Room@conference.meet.domain.com”, which I don’t even know that is possible to have character @ in the header name. The default room named siptest is used when no header is found in the sip INVITE.

When you removed it, jigasi correctly found the header from the sip INVITE message which is named Jitsi-Conference-Room, and tried to use its value.
But the value you pass is empty (wrong) and it tried to connect to a room name ‘@conference.somedomain.com’ which is not a valid jid for a room and it fails connecting.

Try hardcoding a room name in your asterisk and you will see it works.
Jitsi-Conference-Room: sometestroom2.

Hello Damian,
I hardcoding a room name in asterisk It did not work
exten => s,n(enterconf),SIPAddHeader(Jitsi-Conference-Room:JITSI)

please see jigasi log jigasi-5.log (58.6 KB)

Thank you so much

Actually it worked, the header was read as expected: Joining JVB conference room: JITSI@conference.meet.Domain.com.

Now you are on to the next problem, why the focus replies with XMPP error reply received from focus.meet.Domain.com: XMPPError: not-acceptable - modify

  1. Is this your main muc component defined in prosody: conference.meet.Domain.com?
  2. Do you have any kind of authentication configured and that’s why jicofo is denying you access to the room?

Hello Damian,

  1. the muc component defined in prosody as follows

Component “conference.meet.domain.com” “muc”
storage = “memory”
modules_enabled = {
“muc_meeting_id”;
“muc_domain_mapper”;
– “token_verification”;
}
admins = { “focus@auth.meet.domain.com” }
muc_room_locking = false
muc_room_default_public_jids = true

  1. No authentication configured

Thank you so much for helping me i have been struggling for two month.

Can you share your prosody config … something looks strange why would jicofo return that error.

Hello Damian,
Please see prosody config

Thank you prosody.cfg.txt (4.2 KB)