Jigasi - RegistrationState=Connection Failed


#1

Hi,

I tested Jigasi with sip2sip sip client and it works fine. But now I try with FusionPBX/FreeSWITCH sip client but registration fail with Invalid or inaccessible server address, so I want to know Jigasi support FusionPBX/FreeSWITCH client or is there any other issue?

Jigasi Log:

2019-02-26 14:35:27.285 WARNING: [40] org.jitsi.jigasi.xmpp.CallControl.<init>().138 Always trust in remote TLS certificates mode is enabled
2019-02-26 14:35:27.640 SEVERE: [46] impl.protocol.sip.ProtocolProviderServiceSipImpl.register().443 No address found for ProtocolProviderServiceSipImpl(1001@xxx.xx.xxx.xx:5080 (SIP))
2019-02-26 14:35:27.643 INFO: [46] org.jitsi.jigasi.SipGateway.registrationStateChanged().105 REG STATE CHANGE ProtocolProviderServiceSipImpl(1001@xxx.xx.xxx.xx:5080 (SIP)) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Connection Failed; reasonCode=8; reason=Invalid or inaccessible server address.]

FusionPBX user works fine with Zoiper.
I can ping and telnet FreeSWITCH server from Jitsi server.

Thanks
Abhijit


#2

If this is a standard SIP it should work, just a matter of settings. The easiest would be to download jitsi desktop, configure it so it works (there is audio), then got to its Advance Settings and check the property editor to see the sip settings you need to use for jigasi.


#3

Hi @damencho,

I installed Jitsi desktop application on mac, It successfully register with sip2sip client but faced same issue with FusionPBX client.

59%20PM

So How can I know that Jigasi support this client or not?

Thanks,
Abhijit


#4

I don’t understand? Did you manage to register to the problem server using the Jitsi Desktop? Is it using standard SIP?


#5

Hi @damencho,

No, the Jitsi Desktop application fails to register the SIP account. However, the same SIP account could be registered with the Zoiper client.

Abhijit


#6

Hi @damencho,

I compare wireshark packet and I found that destination PORT of Jitsi is 5060 default, I try to check advance setting but I didn’t found from where I have to set destination port.

Wireshark packet of Jitsi desktop application, and I note that destion port is 5060, I need to set it 5080 as per last attached image of X-Lite registration packet.

Wireshark packet - X-Lite registration

I also mark that in Jitsi packet, there is no allow field, where in X-Lite packet there is allow field in which it allow OPTIONS, SUBSCRIBE, NOTIFY, INVITE, ACK, CANCEL, BYE, REFER, INFO, MESSAGE.

I need to know config of Jitsi is OK? not then what should I have to change? and from where?

Thanks,
Abhijit


#7

You need to change the outbound proxy, you had changed the Registrar URI port.
Uncheck configure proxy automatically, enter the proxy to use, the port and the preferred protocol.


#8

Hi @damencho,

Thanks for Help, I am able to register FreeSWITCH user in Jitsi desktop application using proxy server.
Now I also want to know, how to register successfully on Jitsi Web-Application using Jigasi configuration.

During Jigasi installation I used username 1001@xxx.xx.xxx.xx:5080 but not able to register successfully.

Please Guide me to register successfully on Jitsi using Jigasi configuration.

Thanks,
Abhijit


#9

You can check your configs in Settings - Advanced - properties …
But basically you can check: [jitsi-users] Jigasi default SIP port for the properties you need and fill them in /etc/jitsi/jigasi/sip-communicator.properties