Jigasi registered but not outgoing call

Hi,
I need to do external pstn call only. I installed Jigasi and it hasbeen registered with the external sip server. But when I try to call a number it gives error. I see that I have a problem xmpp connection. According to some information on the internet, I set true the parameter “org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE” but it didn’t work. You can see the logs below.

Before tha call:

2022-06-29 17:31:22.651 INFO: [33] SipGateway.registrationStateChanged#120: REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:1c23ef6d16570740@teb.gm) -> RegistrationStateChangeEvent[ oldState=Unregistered; newState=RegistrationState=Registering; userRequest=false; reasonCode=-1; reason=null]
2022-06-29 17:31:22.798 INFO: [46] SipGateway.registrationStateChanged#120: REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:1c23ef6d16570740@teb.gm) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Registered; userRequest=false; reasonCode=-1; reason=null]
2022-06-29 17:31:22.801 WARNING: [46] SipHealthPeriodicChecker.create#169: No health check started, no HEALTH_CHECK_SIP_URI prop.
2022-06-29 17:31:22.874 INFO: [40] net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl$JabberConnectionListener.authenticated: Authenticated: false
2022-06-29 17:31:22.878 INFO: [40] CallControlMucActivator.joinCommonRoom#283: Joining call control room: JigasiBrewery@internal.auth.meet2.domain pps:ProtocolProviderServiceJabberImpl(Jabber:jigasi@auth.meet2.domain), id:acc-xmpp-1
2022-06-29 17:31:22.917 INFO: [57] net.java.sip.communicator.impl.protocol.jabber.ChatRoomJabberImpl$MemberListener.joined: jigasibrewery@internal.auth.meet2.domain/focus has joined the jigasibrewery@internal.auth.meet2.domain chat room.
2022-06-29 17:31:22.922 INFO: [57] net.java.sip.communicator.impl.protocol.jabber.ChatRoomJabberImpl$MemberListener.joined: jigasibrewery@internal.auth.meet2.domain/jitsi-1m1u48c has joined the jigasibrewery@internal.auth.meet2.domain chat room.
2022-06-29 17:31:22.923 INFO: [40] CallControlMucActivator.joinCommonRoom#321: Joined call control room: JigasiBrewery@internal.auth.meet2.domain pps:ProtocolProviderServiceJabberImpl(Jabber:jigasi@auth.meet2.domain), id:acc-xmpp-1 nickname:jitsi-1m1u48c sessionId:null

after trying the call:


2022-06-29 17:34:07.084 INFO: [76] CallControl.handleDialIq#201: [ctx=1656524047077357168835] Got dial request fromnumber -> 0530940xxxx room: test3@conference.meet2.domain
2022-06-29 17:34:07.096 INFO: [76] JvbConference.start#474: [ctx=1656524047077357168835] Starting JVB conference room: test3@conference.meet2.domain
2022-06-29 17:34:07.097 INFO: [76] JvbConference.createAccountPropertiesForCallId#1580: [ctx=1656524047077357168835] Using bosh url:https://meet2.domain/http-bind?room=test3
2022-06-29 17:34:07.108 INFO: [76] JvbConference.setXmppProvider#610: [ctx=1656524047077357168835] Using ProtocolProviderServiceJabberImpl(Jabber:6769b9b9@meet2.domain/6769b9b9)
2022-06-29 17:34:07.162 INFO: [80] org.igniterealtime.jbosh.BOSHClient.init: Starting with 1 request processors
2022-06-29 17:34:07.401 INFO: [80] net.java.sip.communicator.impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged: Jingle : ON
2022-06-29 17:34:07.401 INFO: [80] JvbConference.registrationStateChanged#669: [ctx=1656524047077357168835] Registering XMPP.
2022-06-29 17:34:07.402 SEVERE: [80] net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin: Failed to connect to XMPP service for:ProtocolProviderServiceJabberImpl(Jabber:6769b9b9@meet2.domain/6769b9b9)
org.jivesoftware.smack.SmackException$SmackSaslException: No supported and enabled SASL Mechanism provided by server. Server announced mechanisms: [PLAIN, SCRAM-SHA-1]. Registered SASL mechanisms with Smack: [SASL Mech: GSSAPI, Prio: 100, SASL Mech: SCRAM-SHA-1-PLUS, Prio: 100, SASL Mech: SCRAM-SHA-1, Prio: 110, SASL Mech: DIGEST-MD5, Prio: 200, SASL Mech: CRAM-MD5, Prio: 300, SASL Mech: PLAIN, Prio: 400, SASL Mech: X-OAUTH2, Prio: 410, SASL Mech: EXTERNAL, Prio: 500, SASL Mech: ANONYMOUS, Prio: 500]. Enabled SASL mechanisms for this connection: [ANONYMOUS]. Blacklisted SASL mechanisms: [SCRAM-SHA-1-PLUS]. Skip reasons: []
        at org.jivesoftware.smack.SASLAuthentication.selectMechanism(SASLAuthentication.java:366)
        at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:188)
        at org.jivesoftware.smack.AbstractXMPPConnection.authenticate(AbstractXMPPConnection.java:897)
        at org.jivesoftware.smack.bosh.XMPPBOSHConnection.loginInternal(XMPPBOSHConnection.java:230)
        at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:638)
        at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:595)
        at net.java.sip.communicator.impl.protocol.jabber.AnonymousLoginStrategy.login(AnonymousLoginStrategy.java:83)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1374)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:965)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin(ProtocolProviderServiceJabberImpl.java:790)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:495)
        at org.jitsi.jigasi.util.RegisterThread.run(RegisterThread.java:59)
2022-06-29 17:34:07.405 SEVERE: [80] net.java.sip.communicator.util.UtilActivator.uncaughtException: An uncaught exception occurred in thread=Thread[Thread-60,5,main], and message was: Cannot invoke "Object.hashCode()" because "key" is null
java.lang.NullPointerException: Cannot invoke "Object.hashCode()" because "key" is null
        at java.base/java.util.concurrent.ConcurrentHashMap.replaceNode(ConcurrentHashMap.java:1111)
        at java.base/java.util.concurrent.ConcurrentHashMap.remove(ConcurrentHashMap.java:1102)
        at org.jivesoftware.smackx.disco.ServiceDiscoveryManager.removeNodeInformationProvider(ServiceDiscoveryManager.java:387)
        at net.java.sip.communicator.impl.protocol.jabber.ScServiceDiscoveryManager.stop(ScServiceDiscoveryManager.java:680)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.disconnectAndCleanConnection(ProtocolProviderServiceJabberImpl.java:1524)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1002)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin(ProtocolProviderServiceJabberImpl.java:790)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:495)
        at org.jitsi.jigasi.util.RegisterThread.run(RegisterThread.java:59)
2022-06-29 17:34:17.110 SEVERE: [76] CallControlMucActivator$DialIqHandler.processIQInternal#634: [ctx=1656524047077357168835] Error processing RayoIq
java.lang.Exception: Fail to join muc!
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$WaitToJoinRoom.waitToJoinRoom(CallControlMucActivator.java:731)
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.setDialResponseAndRegisterHangUpHandler(CallControlMucActivator.java:666)
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.processIQInternal(CallControlMucActivator.java:623)
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.lambda$processIQ$0(CallControlMucActivator.java:582)
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
        at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
        at java.base/java.lang.Thread.run(Thread.java:833)

now:

        at org.jivesoftware.smack.AbstractXMPPConnection.lambda$new$2(AbstractXMPPConnection.java:407)
        at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.accept(NonzaCallback.java:177)
        at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.access$200(NonzaCallback.java:166)
        at org.jivesoftware.smack.NonzaCallback.onNonzaReceived(NonzaCallback.java:46)
        at org.jivesoftware.smack.AbstractXMPPConnection.parseAndProcessNonza(AbstractXMPPConnection.java:1440)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1700(XMPPTCPConnection.java:131)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1010)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(XMPPTCPConnection.java:916)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:939)
        at java.base/java.lang.Thread.run(Thread.java:833)

Could you please advise me how to solve the problem.
Regards,
Tufan

Do users need to enter password, when connecting to a meeting on your deployment?

only hosts need to enter password to create a meeting. After that users can join conferences without entering password.

You need to configure authentication for jigasi, it cannot use the guest domain for connecting.

Actually I added the lines which you can see below but it is not working.

You can see below.

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@auth.meet2.domain
org.jitsi.jigasi.xmpp.acc.PASS=123456
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false
org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true

by the way, the other xmpp lines still there.

net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1=acc-xmpp-1
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.ACCOUNT_UID=Jabber:jigasi@auth.meet2.domain
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.USER_ID=jigasi@auth.meet2.domain
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_SERVER_OVERRIDDEN=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.SERVER_ADDRESS=127.0.0.1
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.SERVER_PORT=5222
#net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.BOSH_URL=https://127.0.0.1/http-bind
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.ALLOW_NON_SECURE=true
#base64 AES keyLength:256 or 128
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.PASSWORD=base64password (I don't use it)

#net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.RESOURCE=jigasi
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.AUTO_GENERATE_RESOURCE=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.RESOURCE_PRIORITY=30

net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.KEEP_ALIVE_METHOD=XEP-0199
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.KEEP_ALIVE_INTERVAL=30
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.CALLING_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.JINGLE_NODES_ENABLED=false
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_CARBON_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.DEFAULT_ENCRYPTION=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_USE_ICE=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_ACCOUNT_DISABLED=false
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_PREFERRED_PROTOCOL=false
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.AUTO_DISCOVER_JINGLE_NODES=false
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.PROTOCOL=Jabber
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_USE_UPNP=false
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IM_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.SERVER_STORED_INFO_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_FILE_TRANSFER_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.USE_DEFAULT_STUN_SERVER=false
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.ENCRYPTION_PROTOCOL.DTLS-SRTP=0
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.ENCRYPTION_PROTOCOL_STATUS.DTLS-SRTP=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.Encodings.G722/8000=0
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.Encodings.PCMA/8000=0

Also I executed the command “prosodyctl register jigasi auth.meet2.domain 123456” exactly. As you can see the passwords are plain text.

Regards,
Tufan

No, you have to create a different user. “jigasi” is a specific user in the system.

You can see the logs.

2022-06-30 13:32:35.892 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator org.jitsi.jigasi.JigasiBundleActivator in file:/usr/share/jigasi/jigasi.jar
2022-06-30 13:32:35.894 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 1  dependencies
2022-06-30 13:32:35.896 INFO: [17] JigasiBundleActivator.startWithServices#212: initialized SipGateway
2022-06-30 13:32:36.054 INFO: [17] JigasiBundleActivator.startWithServices#250: skipped initialization of TranscriptionGateway
2022-06-30 13:32:36.160 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator org.jitsi.jigasi.rest.RESTBundleActivator in file:/usr/share/jigasi/jigasi.jar
2022-06-30 13:32:36.627 INFO: [18] JitsiConfig.<clinit>#47: Initialized newConfig: merge of system properties,reference.conf @ jar:file:/usr/share/jigasi/jigasi.jar!/reference.conf: 1,reference.conf @ jar:file:/usr/share/jigasi/lib/ice4j-3.0-59-g71e244d.jar!/reference.conf: 1
2022-06-30 13:32:36.629 INFO: [18] ReadOnlyConfigurationService.reloadConfiguration#51: loading config file at path /etc/jitsi/jigasi/sip-communicator.properties
2022-06-30 13:32:36.632 INFO: [18] JitsiConfig.<clinit>#68: Initialized legacyConfig: sip communicator props (no description provided)
2022-06-30 13:32:36.632 INFO: [18] JitsiConfig$Companion.useDebugNewConfig#74: Replacing newConfig with merge of system properties,reference.conf @ jar:file:/usr/share/jigasi/jigasi.jar!/reference.conf: 1,reference.conf @ jar:file:/usr/share/jigasi/lib/ice4j-3.0-59-g71e244d.jar!/reference.conf: 1
2022-06-30 13:32:36.955 INFO: [18] net.java.sip.communicator.impl.netaddr.NetaddrActivator.startWithServices: Network Address Manager Service ...[REGISTERED]
2022-06-30 13:32:38.661 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 1  dependencies
2022-06-30 13:32:39.822 INFO: [17] org.eclipse.jetty.server.Server.doStart: jetty-11.0.9; built: 2022-03-30T17:44:47.085Z; git: 243a48a658a183130a8c8de353178d154ca04f04; jvm 17.0.3+7-Ubuntu-0ubuntu0.20.04.1
2022-06-30 13:32:40.028 INFO: [17] org.eclipse.jetty.server.AbstractConnector.doStart: Started ServerConnector@45fa7eb4{HTTP/1.1, (http/1.1)}{0.0.0.0:8788}
2022-06-30 13:32:40.040 INFO: [17] org.eclipse.jetty.server.Server.doStart: Started Server@2416b3bb{STARTING}[11.0.9,sto=0] @5334ms
2022-06-30 13:32:40.040 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator org.jitsi.jigasi.rest.TranscriptServerBundleActivator in file:/usr/share/jigasi/jigasi.jar
2022-06-30 13:32:40.041 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 1  dependencies
2022-06-30 13:32:40.047 INFO: [17] AbstractJettyBundleActivator.startWithServices#447: Not starting the Jetty service for org.jitsi.jigasi.rest.TranscriptServerBundleActivator(port=0)
2022-06-30 13:32:40.048 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator org.jitsi.jigasi.xmpp.CallControlMucActivator in file:/usr/share/jigasi/jigasi.jar
2022-06-30 13:32:40.049 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 1  dependencies
2022-06-30 13:32:40.061 INFO: [17] CallControl.<init>#141: JID allowed to make outgoing calls: jigasibrewery@internal.auth.meet2.domain
2022-06-30 13:32:40.061 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator org.jitsi.jigasi.ddclient.DdClientActivator in file:/usr/share/jigasi/jigasi.jar
2022-06-30 13:32:40.062 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator net.java.sip.communicator.service.protocol.ProtocolProviderActivator in file:/usr/share/jigasi/lib/service-protocol-2.14.8fd5f3861.jar
2022-06-30 13:32:40.063 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 3  dependencies
2022-06-30 13:32:40.292 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator net.java.sip.communicator.impl.globaldisplaydetails.GlobalDisplayDetailsActivator in file:/usr/share/jigasi/lib/service-globaldisplaydetails-2.14.8fd5f3861.jar
2022-06-30 13:32:40.343 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 3  dependencies
2022-06-30 13:32:40.348 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator net.java.sip.communicator.plugin.reconnectplugin.ReconnectPluginActivator in file:/usr/share/jigasi/lib/jitsi-reconnect-2.14.8fd5f3861.jar
2022-06-30 13:32:40.349 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 5  dependencies
2022-06-30 13:32:40.350 FINE: [17] net.java.sip.communicator.util.osgi.DependentActivator.addingService: Got service NetworkAddressManagerServiceImpl, starting now
2022-06-30 13:32:40.353 FINE: [17] net.java.sip.communicator.plugin.reconnectplugin.ReconnectPluginActivator.startWithServices: Found 0 already installed providers.
2022-06-30 13:32:40.354 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator net.java.sip.communicator.impl.phonenumbers.PhoneNumberServiceActivator in file:/usr/share/jigasi/lib/jitsi-phonenumbers-2.14.8fd5f3861.jar
2022-06-30 13:32:40.354 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 1  dependencies
2022-06-30 13:32:40.356 INFO: [17] net.java.sip.communicator.impl.phonenumbers.PhoneNumberServiceActivator.startWithServices: Packet Logging Service ...[REGISTERED]
2022-06-30 13:32:40.356 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator net.java.sip.communicator.impl.protocol.sip.SipActivator in file:/usr/share/jigasi/lib/jitsi-protocol-sip-2.14.8fd5f3861.jar
2022-06-30 13:32:40.362 INFO: [17] org.jitsi.impl.osgi.framework.BundleImpl.start: Starting activator net.java.sip.communicator.impl.protocol.jabber.JabberActivator in file:/usr/share/jigasi/lib/jitsi-protocol-jabber-2.14.8fd5f3861.jar
2022-06-30 13:32:40.363 INFO: [17] net.java.sip.communicator.util.osgi.DependentActivator.start: Starting, setting up service tracker for 11  dependencies
2022-06-30 13:32:42.721 WARNING: [33] net.java.sip.communicator.impl.resources.ResourceManagementServiceImpl.getSettingsInt: Missing resource for key: net.java.sip.communicator.SIP_PREFERRED_CLEAR_PORT
2022-06-30 13:32:42.985 WARNING: [33] net.java.sip.communicator.impl.resources.ResourceManagementServiceImpl.getSettingsInt: Missing resource for key: net.java.sip.communicator.SIP_PREFERRED_SECURE_PORT
2022-06-30 13:32:44.747 INFO: [33] SipGateway.registrationStateChanged#120: REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:1c23ef6d16570740@server.gm) -> RegistrationStateChangeEvent[ oldState=Unregistered; newState=RegistrationState=Registering; userRequest=false; reasonCode=-1; reason=null]
2022-06-30 13:32:46.345 INFO: [46] SipGateway.registrationStateChanged#120: REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:1c23ef6d16570740@server.gm) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Registered; userRequest=false; reasonCode=-1; reason=null]
2022-06-30 13:32:46.347 WARNING: [46] SipHealthPeriodicChecker.create#169: No health check started, no HEALTH_CHECK_SIP_URI prop.
2022-06-30 13:32:47.158 SEVERE: [40] net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin: Failed to connect to XMPP service for:ProtocolProviderServiceJabberImpl(Jabber:jigasi@auth.meet2.domain)
org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
        at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:286)
        at org.jivesoftware.smack.AbstractXMPPConnection.lambda$new$2(AbstractXMPPConnection.java:407)
        at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.accept(NonzaCallback.java:177)
        at org.jivesoftware.smack.NonzaCallback$ClassAndConsumer.access$200(NonzaCallback.java:166)
        at org.jivesoftware.smack.NonzaCallback.onNonzaReceived(NonzaCallback.java:46)
        at org.jivesoftware.smack.AbstractXMPPConnection.parseAndProcessNonza(AbstractXMPPConnection.java:1440)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1700(XMPPTCPConnection.java:131)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1010)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$700(XMPPTCPConnection.java:916)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:939)
        at java.base/java.lang.Thread.run(Thread.java:833)

Do I also disable the other xmpp lines?

net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1=acc-xmpp-1
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.ACCOUNT_UID=Jabber:jigasi@auth.meet2.domain
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.USER_ID=jigasi@auth.meet2.domain
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.IS_SERVER_OVERRIDDEN=true
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.SERVER_ADDRESS=127.0.0.1
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.SERVER_PORT=5222

No, you don’t. You create a different, unique user.

Actually I created a unique user but it is same.

You’re saying you created a new, unique user (e.g.jigasi2@auth.meet2.domain) and entered the username and password in the respective lines above but still have problems?

yes unfortunately. I think I messed up somewhere else. Because I give the below error. Also it doesn’t ask host to enter the password while creating a room.

java.lang.NullPointerException: Cannot invoke “Object.hashCode()” because “key” is null

hi again,

I uninstalled Jigasi completely and installed again. But it didn’t work. I have still similar problems. The interesting point is that it doesn’t ask password while creating a meeting after I installed Jigasi. What do you think about the problem?

regards,

Sounds like you might have messed something up with your authentication. Why don’t you reverse the steps you took to implement Secure Domain, basically disable authentication, then test incoming and outgoing calls on Jigasi to see if they work. If everything works fine, then you can move on to implementing secure domain and finally configuring Jigasi to work in that secured domain.