Jigasi problem with unicode characters (master branch vs nightly version)

hi,

i did clone and build jigasi from master branch. in transcription, it writes unicode characters like this: (in both text and json files)
<10:02:51 AM> a: ??? ??? ??? ???

when i am installing jigasi nightly version with apt (i think it is version 1.1-177) it works fine

how can i clone nightly version code from git?

thanks

The latest from unstable is the latest from master.

1 Like

so, there is any config about encoding of transcription text? i checked it multiple times with vosk

on latest master: (it shows text correctly in subtitle but in text file i have something like this)
<10:02:51 AM> a: ??? ??? ??? ???

on jigasi/unstable,now 1.1-177-g1f1cb4e-1 amd64 [installed]
<1:13:12 PM> aaa: یک دو سه

If its only the saved text file, I guess this is a bug and is not using UTF-8 to save the transcriptions in the text file …
It can be the problem the FileWriter in the code that is picking something different from the OS, I see you can do -Dfile.encoding=UTF-8 so you may try adding that in /etc/jitsi/jigasi/config and see whether it fixes it for you

i add -Dfile.encoding=UTF8 in /etc/services.d/jigasi/run and now i am happy :slight_smile:

So this is a bug in jigasi code, it should be handled there and always write utf-8 files, any PRs are welcome :slight_smile:

hi, I have the same problem, but I installed it on my own server via docker. where exactly should i apply this setting

Here docker-jitsi-meet/run at c694a9e657627a2d31e0f10755caaa38d6d4f220 · jitsi/docker-jitsi-meet · GitHub

I added the code -Dfile.encoding=UTF-8 to the specified path and restarted the docker containers but still no change. What could be the reason? @damencho

JAVA_SYS_PROPS=“-Djava.util.logging.config.file=/config/logging.properties”

DAEMON=/usr/share/jigasi/jigasi.sh

DAEMON_OPTS=“–nocomponent=true --configdir=/ --configdirname=config --min-port=${JIGASI_PORT_MIN:-20000} --max-port=${JIGASI_PORT_MAX:-20050}”

-Dfile.encoding=UTF8


JAVA_SYS_PROPS="-Djava.util.logging.config.file=/config/logging.properties"

DAEMON=/usr/share/jigasi/jigasi.sh
DAEMON_OPTS="--nocomponent=true --configdir=/ --configdirname=config --min-port=${JIGASI_PORT_MIN:-20000} --max-port=${JIGASI_PORT_MAX:-20050}"
-Dfile.encoding=UTF8
exec s6-setuidgid jigasi /bin/bash -c "JAVA_SYS_PROPS=\"$JAVA_SYS_PROPS\" exec $DAEMON $DAEMON_OPTS"

Initial people present at 11:19:21 AM:
Fellow Jitser
?a?r?han G?NAY

Transcript, started at 11:19:21 AM:


<11:19:21 AM> ?a?r?han G?NAY joined the conference
<11:19:29 AM> ?a?r?han G?NAY: Bu bir T?rk?e test denemesidir
<11:19:34 AM> ?a?r?han G?NAY: T?rk?e
<11:19:36 AM> ?a?r?han G?NAY: T?rk?e karakterlerin testi
<11:19:42 AM> Fellow Jitser left the conference
<11:19:42 AM> ?a?r?han G?NAY left the conference


error log : “log”:"./run: line 7: -Dfile.encoding=UTF8: command not found\n

Maybe add that to JAVA_SYS_PROPS rather than on a line of its own.

So

JAVA_SYS_PROPS="-Djava.util.logging.config.file=/config/logging.properties -Dfile.encoding=UTF8"

thank you mate, it worked🤩 @shawn