Jigasi only transcript

Hello guys,

I’ve being struggling to get jigasi speech to text working along with jicofo secure rooms.

I’ve created a user with prosody, so jigasi use can login with credentials and set them on ~/jigasi/sip-communicator.properties.

Clearly something is not right, would you mind share some insight on this?
Best regads.

2019-07-25 10:52:23.505 ADVERTENCIA: [47] org.jitsi.jigasi.xmpp.CallControl.checkAuthorized().262 Requests are not secured by JID filter!
2019-07-25 10:52:23.507 INFORMACIÓN: [47] org.jitsi.jigasi.xmpp.CallControl.handleDialIq().188 Got dial request fromnumber -> jitsi_meet_transcribe room: foolishleopardsquestioneasily@internal.auth.j1.si-n.cc
2019-07-25 10:52:23.955 INFORMACIÓN: [47] org.jitsi.jigasi.JvbConference.setXmppProvider().567 0a428c0d@callcontrol.j1.si-n.cc will use ProtocolProviderServiceJabberImpl(transcript@auth.j1.si-n.cc (Jabber))
2019-07-25 10:52:24.048 ADVERTENCIA: [47] org.jitsi.xmpp.component.ComponentBase.verifyProcessingTime().540 PROCESSING TIME LIMIT EXCEEDED - it took 605ms to process: <iq type="set" to="callcontrol.j1.si-n.cc" from="focus@auth.j1.si-n.cc/focus38567843595510" id="NEwGm-130"><dial xmlns="urn:xmpp:rayo:1" to="jitsi_meet_transcribe" from="fromnumber"><header value="foolishleopardsquestioneasily@internal.auth.j1.si-n.cc" name="JvbRoomName"/></dial></iq>
2019-07-25 10:52:24.283 INFORMACIÓN: [48] impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().125 Jingle : ON 
2019-07-25 10:52:24.285 INFORMACIÓN: [48] org.jitsi.jigasi.JvbConference.registrationStateChanged().612 XMPP (0a428c0d@callcontrol.j1.si-n.cc): RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Registering; reasonCode=-1; reason=null]
2019-07-25 10:52:24.355 GRAVE: [48] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service
org.jivesoftware.smack.sasl.SASLErrorException: SASLError using SCRAM-SHA-1: not-authorized
	at org.jivesoftware.smack.SASLAuthentication.authenticationFailed(SASLAuthentication.java:292)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1100)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
	at java.lang.Thread.run(Thread.java:748)
2019-07-25 10:52:24.399 ADVERTENCIA: [55] org.jivesoftware.smack.roster.Roster.processStanza() Roster not loaded while processing Presence Stanza [id=qz9qB-19,type=error,]
2019-07-25 10:52:24.403 GRAVE: [48] org.jitsi.jigasi.JvbConference.registrationStateChanged().606 Connection failed XMPP on 0a428c0d@callcontrol.j1.si-n.cc
2019-07-25 10:52:24.405 ADVERTENCIA: [48] org.jitsi.jigasi.transcription.Transcriber.log() Trying to notify Transcriber for a while it is already stopped
2019-07-25 10:52:24.405 INFORMACIÓN: [48] org.jitsi.jigasi.JvbConference.stop().527 0a428c0d@callcontrol.j1.si-n.cc is removing account Jabber:0a428c0d@j1.si-n.cc/0a428c0d
2019-07-25 10:52:24.410 INFORMACIÓN: [48] impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().132 Jingle : OFF 
2019-07-25 10:52:24.411 ADVERTENCIA: [48] org.jitsi.jigasi.transcription.Transcriber.log() Trying to stop Transcriber while it is already stopped
2019-07-25 10:52:24.411 GRAVE: [48] org.jitsi.jigasi.AbstractGateway.notifyCallEnded().132 Call resource not exists for session 0a428c0d@callcontrol.j1.si-n.cc

Anything in prosody or jicofo logs for this?

Hello @damencho my issue was that the jigasi login account password in ~/jigasi/sip-communicator.properties needs to be plain, where I was using a base64 encoded.

I’m continuing testing still with no success, if you don’t mind I’ll keep updating this topic as reference for transcript instructions.

Ok, after several ours of hard testing it is alive!

Here my for those who have issues with jigasi.
Take care for the following configurations,

  1. make sure your google project has billing :moneybag: already enabled
  2. check that the google credentials are well configured, if you have a file like this, then it is not well configured. Make sure it has private key fields, see more here.
  3. setup proper certs otherwise enable ALWAYS_TRUST_MODE_ENABLED (not recommended for production)
  4. if using secure rooms make sure to register in prosody a jigasi xmpp user and set credentials for them like, xmpp.acc.USER_ID.
  5. Finally, I disabled SIP since my main goal was translation only.

The first 4 points were the ones that I had a hard time, hopefully you all guys will get the rest through.

Regards.

Yes, The json file must contain private key now. Or the GSR api will return error in jigasi logs.

Have you test other language speaking? I mean: one speaks English , another speaks French. I want see both English and French .