JIGASI not registering with PROSODY

Hey guys. I recently installed JITSI-MEET server and it’s running perfectly fine. Now I am trying to connect it to the VOIP provider and therefore using jigasi. I have installe jigasi from packages using apt-get install jigasi.

But I am getting trouble registering jigasi with prosody or jicofo. I don’t know the exact problem but jicofo is not detecting jigasi and on prosody I can see these logs -

Component not connected, bouncing error for: q id=‘2Xe3r-2178’ type=‘get’ to=‘callcontrol.meet.xxxxx.app’ from=‘focus@auth.meet.xxxxx.app/focus3180667991391’

This is my prosody config -
I have component added in my prosody config -
Component “callcontrol.meet.xxxxx.app” component_secret = “NXXXXX”

Please help me guys to troubleshoot this issue. I will really appreciate the help from this community.

Thank you

What do the jigasi logs tell you?
Did you enter the currect secret in the jigasi config as well?

Hi @Cookiefamily. Thanks for the reply. I am able to connect jigasi successfully to prosody and to jicofo. But the trouble I am getting is via service file. When I start jigasi via service file, it won’t connect. But when I start jigasi manually by executing bash script like this -
/usr/share/jigasi/jigasi.sh --domain=meet.xxxxx.app --subdomain=callcontrol --secret=refN8Y3frefAyb0 --host=127.0.0.1 --configdir=/etc/jitsi --configdirname=jigasi

it work’s fine manually. I am troubleshooting it’s service file now.

It’s very very strange bug. But i have same problem. Jigasi starting before prosody and SIP won’t work.
root@jitsi:~# systemctl status jigasi
● jigasi.service - Jitsi Gateway for SIP
Loaded: loaded (/lib/systemd/system/jigasi.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2020-04-19 23:46:35 MSK; 18s ago
Process: 855 ExecStartPost=/bin/bash -c echo $MAINPID > /var/run/jigasi/jigasi.pid (code=exited, status=0/SUCCESS)
Main PID: 854 (java)
Tasks: 35 (limit: 65000)
CGroup: /system.slice/jigasi.service
└─854 java -Xmx3072m -Djava.library.path=/usr/share/jigasi/lib -Djava.util.logging.config.file=/etc/jitsi/jigasi/logging.properties -cp /usr/share/jigasi/jigasi.jar:/usr/share/jigasi/lib/agafua-syslog-0.4.jar:/usr/sh

Apr 19 23:46:35 jitsi.lan systemd[1]: Starting Jitsi Gateway for SIP…
Apr 19 23:46:35 jitsi.lan systemd[1]: Started Jitsi Gateway for SIP.

root@jitsi:~# systemctl status prosody
● prosody.service - LSB: Prosody XMPP Server
Loaded: loaded (/etc/init.d/prosody; generated)
Active: active (running) since Sun 2020-04-19 23:46:36 MSK; 13s ago
Docs: man:systemd-sysv-generator(8)
Process: 863 ExecStart=/etc/init.d/prosody start (code=exited, status=0/SUCCESS)
Tasks: 1 (limit: 4659)
CGroup: /system.slice/prosody.service
└─985 lua5.1 /usr/bin/prosody

Apr 19 23:46:35 jitsi.lan systemd[1]: Starting LSB: Prosody XMPP Server…
Apr 19 23:46:35 jitsi.lan prosody[863]: * Starting Prosody XMPP Server prosody
Apr 19 23:46:36 jitsi.lan prosody[863]: …done.
Apr 19 23:46:36 jitsi.lan systemd[1]: Started LSB: Prosody XMPP Server.
Apr 19 23:46:36 jitsi.lan prosody[985]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281
Apr 19 23:46:36 jitsi.lan prosody[985]: portmanager: Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

As you see prosody started at 23:46:36 and jigasi started at 23:46:35 and we have an error in jigasi.log

2020-04-19 23:46:46.896 INFO: [10] org.jitsi.jigasi.JigasiBundleActivator.start().186 initialized SipGateway
2020-04-19 23:46:46.928 INFO: [10] org.jitsi.jigasi.JigasiBundleActivator.start().224 skipped initialization of TranscriptionGateway
2020-04-19 23:46:47.316 INFO: [10] org.eclipse.jetty.util.log.initialized() Logging initialized @11450ms to org.eclipse.jetty.util.log.Slf4jLog
2020-04-19 23:46:48.127 INFO: [10] org.eclipse.jetty.server.Server.doStart() jetty-9.4.17.v20190418; built: 2019-04-18T19:45:35.259Z; git: aa1c656c315c011c01e7b21aabb04066635b9f67; jvm 1.8.0_242-8u242-b08-0ubuntu3~18.04-b08
2020-04-19 23:46:48.403 INFO: [10] org.eclipse.jetty.server.AbstractConnector.doStart() Started MuxServerConnector@755f1d51{HTTP/1.1,[http/1.1]}{0.0.0.0:8788}
2020-04-19 23:46:48.404 INFO: [10] org.eclipse.jetty.server.Server.doStart() Started @12595ms
2020-04-19 23:46:48.408 INFO: [10] org.jitsi.rest.AbstractJettyBundleActivator.log() Not starting the Jetty service for org.jitsi.jigasi.rest.TranscriptServerBundleActivator(port=-1)
I restart this services this command:
sudo systemctl restart prosody jigasi
and SIP call work fine

I try change jigasi unit file in lib/systemd/system/jigasi.service and try add in section [Unit}
After=network.target prosody.service
But no effect. May be anybody can solve this problem.

Hi @Alsirion This is really a strange bug. I found very interesting thing, when I stated jigasi using service command it works but when I start using systemctl it does not. I’m 100% sure that, there service file have some issues.

Some result.
No restart prosody needed. Sometimes jigasi can start, sometimes can’t start. It’s magic)
If I restart service with help:
sudo systemctl restart jigasi

If i do restart, then i get differnt result.
But log stucks on string
2020-04-20 23:45:30.007 INFO: [10] org.jitsi.rest.AbstractJettyBundleActivator.log() Not starting the Jetty service for org.jitsi.jigasi.rest.TranscriptServerBundleActivator(port=-1)

If jigasi can start after this string i can see
2020-04-20 23:45:36.216 INFO: [10] org.jitsi.rest.AbstractJettyBundleActivator.log() Not starting the Jetty service for org.jitsi.jigasi.rest.TranscriptServerBundleActivator(port=-1)
2020-04-20 23:45:36.707 WARNING: [10] org.jitsi.jigasi.xmpp.CallControlMucActivator.start().107 MUC call control disabled.

And normal loading jigasi. How I can get more logs? How correct config the logger for maximal logging?

I had seen similar behaviour and couldn’t go to the bottom of it, but this fixed it for me: https://github.com/jitsi/jigasi/pull/258/commits/dfd269d33cb775b036649e6ef5cca9bf5ebd82d3

Should be fixed by jigasi_1.1-105-gb0d38d1

1 Like

Thank you for the fix

Waiting in stable…

I was updated to jigasi 1.1-107-g6928850. After restart server - not working, but manual restart services jigasi AND prosody 100% resolve the problem and now it’s more problem prosody than jigasi…imho…because if i call jigasi log are clean. And I have an error in browser console log:

. But jigasi well connected to freepbx.

Well it means jigasi did not connect to prosody … or jicofo is not discovering it. If you restart jicofo, is there any change?

1 Like

Ohh…restart only jicofo help me…And how to repair it after server restart?

I believe this issue is related to start order of these services. We may need to find the correct boot orders of these services. Example-> When server restarts, we need to test that what should be the order of prosody jicofo jitsi and jigasi.

Normally should not matter. But component discovery is the problem, if jigasi and jicofo is configured to use mucs that will not be a problem.
There was some config for component discovery …

org.jitsi.jicofo.SERVICE_REDISCOVERY_INTERVAL you can set it to 30000 so jicofo will be checking for jigasi is it there, every 30 seconds.

1 Like

Call start working after restart server!!! Thank you very much!!! Do you have any manul to configure with muc?