Jigasi.log: not-authorized, host:localhost, port:5347 org.xmpp.component.ComponentException: not-authorized

Hi,
sorry, if this has already been asked elsewhere, the documentation for jitst is a bit diffuse … I am in the middle of a jitsi installation on a dedicated VM with apache 2.4 as webserver/rev proxy and haproxy for ssl termination. While the services already work (jicofo.service, jigasi.service, jitsi-videobridge2.service), I still get an exception in jigasi.log:

2020-06-11 16:58:34.718 SCHWERWIEGEND: [39] org.jitsi.meet.ComponentMain.log() not-authorized, host:localhost, port:5347
org.xmpp.component.ComponentException: not-authorized
        at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:243)
        at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
        at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
        at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:285)
        at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
        at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
        at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
        at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
        at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
        at java.base/java.lang.Thread.run(Thread.java:834)

Went through some threads from the forum and checked jvb and prosody logs for JVB_SECRET, JICOFO_SECRET, JICOFO_AUTH_PASSWORD, but I think I am a bit lost now …

Can anyone give me an idea about what to double-check again step by step?

Thanks!
Thommie

I’m same problem

The main problem is the fragmented documentation for jitsi, but I see that something new is created at https://jitsi.github.io/handbook/

I want to understand the three different passwords:

You will need to change references to that to match your host, and generate some passwords for YOURSECRET1 , YOURSECRET2 and YOURSECRET3 .

And which of them is used for what?

I installed jitsi 3 month ago and all worked fine, but now I cannot connect to jitsi meet anymore from one day to the other. In jigasi.log I get the same exeption above. I assume it has to do with ubuntu update. The error occurs first time few minutes after udpate:

2020-06-15 09:41:59.306 SCHWERWIEGEND: [40] org.jitsi.meet.ComponentMain.log() java.net.ConnectException: Verbindungsaufbau abgelehnt (Connection refused), host:localhost, port:5347
org.xmpp.component.ComponentException: java.net.ConnectException: Verbindungsaufbau abgelehnt (Connection refused)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:296)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)

grep “2020-06-15” /var/log/dpkg.log | grep “status installed” gives me:

2020-06-15 09:32:12 status installed jitsi-videobridge2:all 2.1-202-g5f9377b9-1
2020-06-15 09:32:20 status installed jitsi-meet-web-config:all 1.0.4127-1
2020-06-15 09:39:28 status installed jigasi:amd64 1.1-107-g6928850-1
2020-06-15 09:39:30 status installed jitsi-meet-web:all 1.0.4127-1
2020-06-15 09:39:31 status installed jitsi-meet-prosody:all 1.0.4127-1
2020-06-15 09:39:37 status installed jicofo:all 1.0-589-1
2020-06-15 09:39:42 status installed jitsi-meet:all 2.0.4627-1
2020-06-15 09:39:43 status installed jitsi-meet-turnserver:all 1.0.4127-1

Have anybody an idea or hint?
Thanks

still not found the solution. the prosody.log shows a corresponding error:

Jun 17 22:58:50 jcp560056141df0 info Incoming Jabber component connection
Jun 17 22:58:50 callcontrol.saturn2:component info Component authentication failed for callcontrol.saturn2
Jun 17 22:58:50 mod_component info Disconnecting component, stream:error is: stream:errorGiven token does not match calculated token</stream:error>
Jun 17 22:58:50 jcp560056141df0 info component disconnected: callcontrol.saturn2 (false)

After following pwds was set correctly, the auth error was solved:

/etc/prosody/conf.d/saturn2.cfg.lua:
Component “callcontrol.YOURHOSTNAME” component_secret = “topsecret”

/etc/jitsi/jigasi/config:
JIGASI_SECRET=topsecret

but I still cannot connect -(