Jigasi in kubernetes

Hello,

Is there anyone successfully configured Jigasi with kubernetes. i am facing issues as error log indicates as below. Please let me know if anyone has any working k8s yaml for Jigasi.

strong text

Regards
Swathi Ambujakshan

Erro logsjigasi_error.txt (891 Bytes)

@adieye @damencho your help is highly appreciated

You can turn packet logging off from the config file. https://github.com/jitsi/jigasi/blob/6df3db2c63ccae1ac89d0591e6fe9005603c8a62/jigasi-home/sip-communicator.properties#L18

1 Like

@damencho Thank you very much for answering this.

I can disable the error the logging , but Can I know if there any specific reason I couldnt find any Kubernetes Yaml for Jigasi. Is there any compatibility issues with Jigasi on K8s. That would be really helpful if you can let me know if any repository you are aware of.

Attaching some more logs here.

jigasi.txt (25.0 KB)

Thanks again

regards
Swathi Ambujakshan

Sorry I’m not familiar with K8s, so I cannot help. Check the docker repo in the issues was something like that discussed.

Thank you for the responce. anyways I post my issue here so that somone can address it.

I do have a running scalable kubernetes environment except Jigasi. Jigasi is the place where I am facing issues.

I have different issues now with Jigasi.

  1. As soon as I make configmap changes to ENABLE_TRANSCRIPTION to “1” the pod keep restarting .

Here is my configmap for Jigasi:

JIGASI_SIP_URI: xxxxxx@sip.linphone.org
JIGASI_SIP_PASSWORD: xxxxxxxx
JIGASI_SIP_SERVER: xxxxxx
JIGASI_SIP_PORT: “5607”
#JIGASI_SIP_TRANSPORT
#JIGASI_XMPP_PASSWORD
#JIGASI_BREWERY_MUC
JIGASI_PORT_MIN: “20000”
JIGASI_PORT_MAX: “20002”
#JIGASI_HEALTH_CHECK_SIP_URI
#JIGASI_HEALTH_CHECK_INTERVAL
#JIGASI_SIP_KEEP_ALIVE_METHOD
#JIGASI_ENABLE_SDES_SRTP
#GC_PROJECT_ID
#GC_PRIVATE_KEY_ID
#GC_PRIVATE_KEY
#GC_CLIENT_EMAIL
#GC_CLIENT_ID
ENABLE_TRANSCRIPTIONS: “1”
JIGASI_TRANSCRIBER_RECORD_AUDIO: “true”
JIGASI_TRANSCRIBER_SEND_TXT: “true”
JIGASI_TRANSCRIBER_ADVERTISE_URL: “true”
#GC_CLIENT_CERT_URL

Error: - Warning BackOff (x5 over ) kubelet, test-pool-1-3jwni Back-off restarting failed container

My yaml as below

apiVersion: apps/v1
kind: Deployment
metadata:
labels:
service: jigasi
name: jigasi
namespace: clan
spec:
selector:
matchLabels:
service: jigasi
replicas: 1
strategy:
type: RollingUpdate
rollingUpdate:
maxSurge: 25%
maxUnavailable: 25%
template:
metadata:
labels:
service: jigasi
spec:
containers:

  • envFrom:
  • configMapRef:
    name: jitsi-env
    image: jitsi/jigasi:latest
    name: jigasi
    ports:
  • containerPort: 5607
    resources:
    requests:
    memory: “700Mi”
    cpu: “500m”
    limits:
    memory: “800Mi”
    cpu: “700m”

Do you have a working yaml for Jigasi.

What could be the reason it fails when I enable transcriptions. There is no much log since the container is even did not start when Transcription is enabled.

  1. If I enable Jigasi to call SIP , it did not work , I dont see any logs coming into the Jicofo. I can see the + button enabled in my web and when I click on add call it says failed to connect

Any help will be highly appreciated. @damencho

Regards
Swathi Ambujakshan