Jigasi: Failed to connect to XMPP because of TLS problems

Hi all.

I’m trying to get jigasi up and running. I have followed the secure domain manual and we use LDAP authentification. That all works fine. Now I try to get jigasi running. In the jigasi.log file I see incoming calls and also outgoing calls. Both with the same error:

2020-11-19 10:17:44.581 SEVERE: [63] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service

org.jivesoftware.smack.SmackException$SecurityRequiredByClientException: SSL/TLS required by client but not supported by server
at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:390)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1309)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:970)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin(ProtocolProviderServiceJabberImpl.java:795)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:500)
at org.jitsi.jigasi.util.RegisterThread.run(RegisterThread.java:59)

Full log at https://welcome.meet.dsb.net/tmp/jigasi.log

I’ve been looking for a few days now and unfortunately haven’t found anything suitable to solve this problem. Does anyone have any advice for me? Thank you so much!

Try adding this org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true

It can be that easy. Thank you very much!

I’m getting this same error when I try to do a transcription and with SIP calls. I have org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true in my sip-communicator.properties file.

Is there anything else it could be? What is the “server” and what is the “client” in this scenario?

thanks for any help you can provide!
88

Server is prosody and client is jigasi

I currently have my internal muc component set to “internal.auth.meet.domain.com” in prosody.

do I need to enable SSL for that specific component?

Could it be a certificate thing? Maybe the self-signed certs don’t allow for a subdomain?

the jigasi log is as follows:

2021-01-22 14:42:47.432 INFO: [137] org.jitsi.jigasi.xmpp.CallControl.handleDialIq().195 [ctx=16113553674311149930485] Got dial request null -> jitsi_meet_transcribe room: meetingname@conference.meet.domain.com
2021-01-22 14:42:47.433 INFO: [137] org.jitsi.jigasi.JvbConference.start().490 [ctx=16113553674311149930485] Starting JVB conference room: meetingname@conference.meet.domain.com
2021-01-22 14:42:47.436 INFO: [137] org.jitsi.jigasi.JvbConference.setXmppProvider().633 [ctx=16113553674311149930485] Using ProtocolProviderServiceJabberImpl(Jabber:3b9808f1@meet.domain.com/3b9808f1)
2021-01-22 14:42:47.439 INFO: [140] org.igniterealtime.jbosh.BOSHClient.init() Starting with 1 request processors
2021-01-22 14:42:47.513 SEVERE: [140] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service
org.jivesoftware.smack.SmackException$SecurityRequiredByClientException: SSL/TLS required by client but not supported by server
        at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:390)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1309)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:970)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin(ProtocolProviderServiceJabberImpl.java:795)
        at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:500)
        at org.jitsi.jigasi.util.RegisterThread.run(RegisterThread.java:59)
2021-01-22 14:42:47.515 SEVERE: [140] org.jitsi.jigasi.JvbConference.registrationStateChanged().688 [ctx=16113553674311149930485] XMPP Connection failed.
2021-01-22 14:42:47.515 WARNING: [140] org.jitsi.jigasi.JvbConference.leaveConferenceRoom().1115 [ctx=16113553674311149930485] MUC room is null
2021-01-22 14:42:52.436 SEVERE: [137] org.jitsi.jigasi.xmpp.CallControlMucActivator.processIQ().589 Error processing RayoIq
java.lang.Exception: Fail to join muc!
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$WaitToJoinRoom.waitToJoinRoom(CallControlMucActivator.java:688)
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.setDialResponseAndRegisterHangUpHandler(CallControlMucActivator.java:621)
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.processIQ(CallControlMucActivator.java:578)
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$DialIqHandler.processIQ(CallControlMucActivator.java:556)
        at org.jitsi.jigasi.xmpp.CallControlMucActivator$RayoIqHandler.handleIQRequest(CallControlMucActivator.java:741)
        at org.jivesoftware.smack.AbstractXMPPConnection$4.run(AbstractXMPPConnection.java:1188)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)

If it is a problem with the certs setting this will fix it: jigasi/sip-communicator.properties at b7423fad61beccab18728e05358b4e7a69702eff · jitsi/jigasi · GitHub

Looking at the error I still think that setting this will fix it: org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true, check whether you see it in the logs after restarting jigasi.

1 Like

Oh my god, that did it. Thank you!!!

I had enabled
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.ALLOW_NON_SECURE=true

and thought that was the right thing. Obviously it was the other one.

1 Like

I have same question and didn’t get satisfied solution.