Jigasi Dial Out not working

Hello Community,

After trying to find my way alone I have come to a dead end.

I have installed Jitsi Meet on a server and have it all working fine. Jigasi is also installed and I can dial into the default room “Siptest” so the connection between SIP-Trunk and Jigasi is working and the Trunk is set up to directly route into the public phone network. But whenever I try to add a participant via the Dial-Out Feature I get the error “Failed to add participant”. In my config I use
dialOutCodesUrl: ‘https://api.jitsi.net/countrycodes’,
dialOutAuthUrl: ‘https://api.jitsi.net/authorizephone’,

Does anyone know/have an idea why it’s not working?

Form where is the error, maybe share the logs will help us to see the error …

Unfortunately the jigasi.log at /var/log/jitsi/ doesn’t seem to register any error at all. Could the rror be logged anywhere else?

Yes, the web client. The js console.
Maybe you should not use dialOutCodesUrl: ‘https://api.jitsi.net/countrycodes’, and dialOutAuthUrl: ‘https://api.jitsi.net/authorizephone’,
As this is meet.jit.si specific, we had disabled some expensive destinations … This was the time when there was a dial-out demo on meet.jit.si, but we had removed it due to the risk of abuse …

Ah. I saw those 2 lines in another thread at some point and assumed it was required to dial out at all. So I don’t need those at all?

Jitsi Screenshot
Heres the Screenshot of the Error

You need to expand the message …

I’m sorry. I am still rather new to all of this.


The error has around 50 more frames. Do you need to see those as well?

Jitsi Screenshot 2

Jicofo reports service unavailable. This means jicofo does not see any jigasi instance.
Make sure you had configured jigasi to use muc control rooms and you see in jicofo logs that it had discovered your jigasi when you start it.

Do I need to add those lines in the sip-communicator properties? And if I have the prosody server on the same server I don’t need the first block except for the USER_ID do I?

Yes that goes in sip-communicator.properties, mind that you need and jicofo config, but that is also explained.
You need the configs as given in the example.

That worked out perfectly thank you! There is now some weird background noise in the call on phone though I doubt that is an error from Jigasi.