Jigasi Dial In no longer working after activating prosody ldap2 authentication

Dear everyone,

I need some help with my Jitsi installation. After enabling LDAP2 authentication in Prosody my Jigasi SIP dial in is no longer working. I read some threads in these forum but nothing worked for me. After typing the conference PIN on my mobile phone I got the information “The conference will be started, when the leader arrived”. But I have this conference open on my computer too. I can found this in the Jigasi log file during the test:

2021-04-19 11:34:49.664 INFO: [58] org.jitsi.jigasi.SipGateway.incomingCallReceived().216 [ctx=16188248896571021306408] Incoming call received...
2021-04-19 11:34:49.671 INFO: [60] org.jitsi.jigasi.SipGatewaySession.run().1718 [ctx=16188248896571021306408] Wait thread cancelled
2021-04-19 11:34:49.676 INFO: [58] org.jitsi.jigasi.JvbConference.start().479 [ctx=16188248896571021306408] Starting JVB conference room: test123
2021-04-19 11:34:49.720 INFO: [58] org.jitsi.jigasi.JvbConference.setXmppProvider().622 [ctx=16188248896571021306408] Using ProtocolProviderServiceJabberImpl(Jabber:27c9fcd4@jitsi.domain.tld/27c9fcd4)
2021-04-19 11:34:49.881 INFO: [64] impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().127 Jingle : ON
2021-04-19 11:34:49.882 INFO: [64] org.jitsi.jigasi.JvbConference.registrationStateChanged().673 [ctx=16188248896571021306408] Registering XMPP.
2021-04-19 11:34:49.883 SEVERE: [64] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service
org.jivesoftware.smack.SmackException: No supported and enabled SASL Mechanism provided by server. Server announced mechanisms: [PLAIN]. Registered SASL mechanisms with Smack: [SASL Mech: GSSAPI, Prio: 100, SASL Mech: SCRAM-SHA-1-PLUS, Prio: 100, SASL Mech: SCRAM-SHA-1, Prio: 110, SASL Mech: DIGEST-MD5, Prio: 200, SASL Mech: CRAM-MD5, Prio: 300, SASL Mech: PLAIN, Prio: 400, SASL Mech: X-OAUTH2, Prio: 410, SASL Mech: EXTERNAL, Prio: 500, SASL Mech: ANONYMOUS, Prio: 500]. Enabled SASL mechanisms for this connection: [ANONYMOUS]. Blacklisted SASL mechanisms: [SCRAM-SHA-1-PLUS].
	at org.jivesoftware.smack.SASLAuthentication.selectMechanism(SASLAuthentication.java:361)
	at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:192)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.loginInternal(XMPPTCPConnection.java:387)
	at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:491)
	at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:448)
	at net.java.sip.communicator.impl.protocol.jabber.AnonymousLoginStrategy.login(AnonymousLoginStrategy.java:84)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1371)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:970)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin(ProtocolProviderServiceJabberImpl.java:795)
	at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:500)
	at org.jitsi.jigasi.util.RegisterThread.run(RegisterThread.java:59)
2021-04-19 11:34:49.899 SEVERE: [64] org.jitsi.jigasi.JvbConference.registrationStateChanged().677 [ctx=16188248896571021306408] XMPP Connection failed.
2021-04-19 11:34:49.902 WARNING: [64] org.jitsi.jigasi.JvbConference.leaveConferenceRoom().1109 [ctx=16188248896571021306408] MUC room is null
2021-04-19 11:34:52.611 INFO: [74] org.jitsi.jigasi.SipGatewaySession.handleCallState().1614 [ctx=16188248896571021306408] SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Incoming Call newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=+491711234567890 <+491711234567890@asterisk>;status=Disconnected
2021-04-19 11:34:52.612 INFO: [74] org.jitsi.jigasi.SipGatewaySession.sipCallEnded().647 [ctx=16188248896571021306408] Sip call ended: Call: id=1618824889618368656939 peers=0
2021-04-19 11:34:52.612 WARNING: [74] org.jitsi.jigasi.JvbConference.leaveConferenceRoom().1109 [ctx=16188248896571021306408] MUC room is null
2021-04-19 11:34:52.612 INFO: [74] org.jitsi.jigasi.JvbConference.stop().582 [ctx=16188248896571021306408] Removing account Jabber:27c9fcd4@jitsi.domain.tld/27c9fcd4
2021-04-19 11:34:52.613 INFO: [74] impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().134 Jingle : OFF
2021-04-19 11:34:52.614 SEVERE: [74] org.jitsi.jigasi.AbstractGateway.notifyCallEnded().121 [ctx=16188248896571021306408] Call resource not exists for session.
2021-04-19 11:34:52.614 INFO: [74] org.jitsi.jigasi.SipGatewaySession.peerStateChanged().1680 null SIP peer state: Disconnected
2021-04-19 11:34:55.440 INFO: [76] org.jitsi.jigasi.SipGateway.incomingCallReceived().216 [ctx=16188248954391658297342] Incoming call received...
2021-04-19 11:34:55.441 INFO: [78] org.jitsi.jigasi.SipGatewaySession.run().1718 [ctx=16188248954391658297342] Wait thread cancelled
2021-04-19 11:34:55.441 INFO: [76] org.jitsi.jigasi.JvbConference.start().479 [ctx=16188248954391658297342] Starting JVB conference room: test123

I tried to set these variables with an existing LDAP Useraccount

#org.jitsi.jigasi.xmpp.acc.USER_ID=
#org.jitsi.jigasi.xmpp.acc.PASS=
#org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

but then I got in the log file:

2021-04-19 11:37:07.955 SEVERE: [65] impl.protocol.jabber.ProtocolProviderFactoryJabberImpl.createService().172 testuser is not a valid JID

Any other suggestions?

This is my /etc/jitsi/jigasi/sip-communicator.properties configuration file:

org.jitsi.jigasi.MUC_SERVICE_ADDRESS=conference.jitsi.domain.tld


net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false


net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10

net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true

net.java.sip.communicator.impl.protocol.sip.acc1403273890647=acc1403273890647
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.ACCOUNT_UID=SIP\:6338@asterisk.domain.tld
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PASSWORD=passwd
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_ADDRESS=asterisk.domain.tld
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.USER_ID=6338@asterisk.domain.tld
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.SERVER_PORT=5160
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS=asterisk.domain.tld
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_PORT=5160
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_ADDRESS_VALIDATED=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PROXY_AUTO_CONFIG=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREFERRED_TRANSPORT=udp
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.AMR-WB/16000=750
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.G722/8000=700
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.PCMU/8000=650
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.iLBC/8000=10
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.opus/48000=1000
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DEFAULT_ENCRYPTION=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.PREVENT_AUTH_LOGIN=false

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=jitsi.domain.tld


org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=127.0.0.1
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
org.jitsi.jigasi.xmpp.acc.JINGLE_NODES_ENABLED=false
org.jitsi.jigasi.xmpp.acc.AUTO_DISCOVER_STUN=false
org.jitsi.jigasi.xmpp.acc.IM_DISABLED=true
org.jitsi.jigasi.xmpp.acc.SERVER_STORED_INFO_DISABLED=true
org.jitsi.jigasi.xmpp.acc.IS_FILE_TRANSFER_DISABLED=true


net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

Did you add org.jitsi.jigasi.xmpp.acc.USER_ID=testuser?
That should be org.jitsi.jigasi.xmpp.acc.USER_ID=testuser@jitsi.domain.tld

1 Like

Di @damencho,

yes, you are completely right. That’s working perfect with testuser@jitsi.domain.tld

But I found another solution, which looks for me okay too. Could you just verify it with your deeper knowledge about the jitsi software stack, if this is okay too? It’s working, so for me it looks fine…

net.java.sip.communicator.impl.protocol.sip.acc1403273890647.DOMAIN_BASE=guest.jitsi.domain.tld

(That is the same domain which I configured in /etc/jitsi/meet/jitsi.domain.tld-config.js too for “anonymousdomain”).

And then I commented out the org.jitsi.jigasi.xmpp.acc.USER_ID, PASS, ANONYMOUS_AUTH variables again, so that they are not configured.

Yeah that is fine.

1 Like