Jigasi configure with jitsi but no subtitle is visible

It may be related to your Google creds, if you have made sure all Jigasi config is correct.

Did you verify if those credentials are working?

i check twice the credential are right . should i start some service on my account?

If you google or go through the steps given for activating google speech-to-text, you may find a step on how to verify if the feature is properly configured…

is there any other way except jigasi doc to achieve the caption functionality

I did provide you the link to a script, but it seemed you wanted to do it on your own…you may try with that script…

while try to run the given shell script giving following error:

cat jitsi_setup.sh_28-Sep-2021-11-51-37.log


            jitsi - 1.0

Installer for jitsi-meet, jigasi and jibri on same server

Supported Platforms: Ubuntu-16/18/20, Debian-9/10


Start Time: Tue Sep 28 11:51:37 IST 2021

jitsi: Lock Acquired…

*** Welcome to jitsi setup ***

*** Config file found: /home/mohan/jitsi/jitsi_config_file
*** Reading config file now…

*** Reading configuration from /home/mohan/jitsi/jitsi_config_file: COMPLETE… ***

What do you want to do?

1) check_prerequisites          5) Uninstall
2) show_installed_versions      6) help
3) show_status_of_services      7) export_config_file_template
4) Install                      8) Quit

You chose: “4”

jitsi_setup.sh Install called…

Tue Sep 28 11:51:44 IST 2021: Currently Installed Versions:


rc prosody 0.11.10-1~focal1 amd64 Lightweight Jabber/XMPP server


Checking Prerequisites…

Checking Operating System…

Distributor ID: Ubuntu
Description: Ubuntu 20.04.3 LTS
Release: 20.04
Codename: focal

Kernel: Linux 4.4.0-19041-Microsoft x86_64 GNU/Linux

Ubuntu-20.04: Operating System Check *** All Good ***

Checking Configuration…

Mandatory configuration options:

0. BEHIND_NAT (Set it to "no" if the server has a public IP on one of it's interfaces, else to "yes")
1. SERVER_FQDN (This will be used to access the web conferences)
2. PUBLIC_IP (mandatory only if BEHIND_NAT is "yes")
3. PRIVATE_IP (mandatory only if BEHIND_NAT is "yes")

For other options, dump the config file template using "export_config_file_template" option and check...

*** jitsi: Configuration for this run would be: ***

***** BEHIND_NAT not set(mandatory)…
Set it to “no”, if the server has a public IP assigned on one of it’s interfaces…
“yes”, otherwise…
***** Set it using export SERVER_FQDN=yes/no

***** SERVER_FQDN not set(mandatory). Set it using export SERVER_FQDN=FQDN_OF_SERVER

HOST_NAME not set. Defaulting to the current hostname “LAPTOP-5U4A3V75”

GOOGLE_APPLICATION_CREDENTIALS not set. Will copy from default /home/mohan/google_credentials.json (if exists)

JIGASI_TRANSCRIPTS_DIR not set. Defaulting to /etc/jitsi/transcripts
*** NOTE ***: Remember to take a backup of /etc/jitsi/transcripts before uninstalling…

JIBRI_RECORDINGS_DIR not set. Defaulting to /etc/jitsi/recordings
*** NOTE ***: Remember to take a backup of /etc/jitsi/recordings before uninstalling…

SIP_USER_ID is not set. You will be asked to enter while installing jigasi…

SIP_PASSWORD is not set. You will be asked to enter while installing jigasi…

***** Prerequisites: ***** FAIL *****. Set all the mandatory configuration options…
***** Either export them from Terminal… OR…
***** Use Configuration file /home/mohan/jitsi/jitsi_config_file
***** You may dump the config file template using “export_config_file_template” option…

End Time: Tue Sep 28 11:51:45 IST 2021

Logs for this run are saved in “/home/mohan/jitsi/jitsi_setup.sh_28-Sep-2021-11-51-37.log”

jitsi: Lock Released…You are good for next run…

If you go through the errors that are displayed in logs(in what you pasted), you can find what needs to be done.

Also make sure your google credentials, start with this(it should be service_account):
{
“type”: “service_account”,
“project_id”: “some_project”,
“private_key_id”: “some_key_id”,
“private_key”:

thank you for the response let me check