Jigasi can't connect to XMPP server

When I try to call a phone to the conference, it fails showing this message at jigasi logs:

SSL/TLS required by client but not supported by server

Here the logs: https://pastebin.com/raw/T2RZa0gq

I tried setting net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true but it still kept with the same error, at the prosody logs all it says it that it successfully authenticated, but no further information about the SSL/TLS error

What is your config using mucs or components for jigasi, have you configured it to use bosh it connects directly to port 5222? Maybe show your config.
Seems you have two problems, first the sip cannot register and second the xmpp account cannot connect.

I followed the instruction at “Adding sip-gateway to Jitsi Meet” at the jitsi-meet github page and added some additional configs trying to fix the error

JIgasi config: https://pastebin.com/raw/Ciwj3R54
Jigasi sip: https://pastebin.com/raw/kmFQvgQu

Prosody site cfg: https://pastebin.com/raw/z73LVjFe
Prosody root cfg: https://pastebin.com/raw/EGr8HSUN
Jicofo config: https://pastebin.com/raw/LG2BPZxd
Jicofo sip: https://pastebin.com/raw/fVRSXqjg

Some other errors at jigasi.log: https://pastebin.com/raw/zntJ7Va7

Thank you so much for the help!

Not sure why your sip account cannot connect:

2019-10-11 15:43:07.101 INFO: [52] org.jitsi.jigasi.SipGateway.registrationStateChanged().105 REG STATE CHANGE ProtocolProviderServiceSipImpl(user@domain.sip.twilio.com (SIP)) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Connection Failed; reasonCode=1; reason=No realms present, cannot authenticate]

Maybe installing on your desktop jitsi desktop client and try logging from there and then comparing configurations …

I suppose jigasi and your xmpp server is on the same host? Strange that SSL/TL says is not supported by server … does prosody logs reveal why that can be disabled for auth.domain host?

I tried at another server and with some changed configurations I managed to send a call, but it says that is “Forbidden” and then “Failed” at the front-end. Maybe something related to the SIP provider?

Jigasi logs: https://pastebin.com/raw/TSBU1ttS
Jvb logs: https://pastebin.com/raw/s9ugKxzd

Yeah, some kind of authentication error, strange is that it is registering, but not calling

Was some missing configuration at twilio by my part, now its calling perfectly!

Thanks for the help!