Jigasi call-out error in password protected conference

Hi,
we installed jitsi-meet with jigasi. Everthing works fine, when I create a meeting without password protection and I do a outbound call from the room.

If I protect the meeting with a password it’s impossible to invite a participant by phone.

Here my jigasi log:

[216] org.jitsi.jigasi.JvbConference.joinConferenceRoom().823 [ctx=1591336083063279483247]net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join chat room siptest@conference.meet.domain.com with nickname: 2e1499cf. The chat room requests a password.
at net.java.sip.communicator.impl.protocol.jabber.ChatRoomJabberImpl.joinAs(ChatRoomJabberImpl.java:714)
at net.java.sip.communicator.impl.protocol.jabber.ChatRoomJabberImpl.joinAs(ChatRoomJabberImpl.java:778)
at org.jitsi.jigasi.JvbConference.joinConferenceRoom(JvbConference.java:785)
at org.jitsi.jigasi.JvbConference.registrationStateChanged(JvbConference.java:591)
at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:187)
at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:141)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1389)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:970)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin(ProtocolProviderServiceJabberImpl.java:795)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:500)
at org.jitsi.jigasi.util.RegisterThread.run(RegisterThread.java:59)
Caused by: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from siptest@conference.meet.domain.com/2e1499cf: XMPPError: not-authorized - auth
at org.jivesoftware.smack.XMPPException$XMPPErrorException.ifHasErrorThenThrow(XMPPException.java:132)
at org.jivesoftware.smack.StanzaCollector.nextResultOrThrow(StanzaCollector.java:263)
at org.jivesoftware.smackx.muc.MultiUserChat.enter(MultiUserChat.java:355)
at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:711)
at org.jivesoftware.smackx.muc.MultiUserChat.join(MultiUserChat.java:603)
at net.java.sip.communicator.impl.protocol.jabber.ChatRoomJabberImpl.joinAs(ChatRoomJabberImpl.java:665)
… 10 more


Thanks for your answers.

For me same issue pls help me out

You want to pass Jitsi-Conference-Room-Pass sip header from your IVR with the room password.

How is this done when dialing out ? Also, this does not make sense. When you are calling out from within a password protected chat you already know the password and you probably trust the called person. So why is there any further protection needed?

-Heinrich

Dial out is working without a problem with password protected room when the dialing out participant is the one that sets the password (the one that knows it).

Hmm, in my case it does not work. /var/log/jitsi/jigasi.log shows:

net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join chat room wm@conference.j.wtmhb.de with nickname: 5c48d5b5. The chat room requests a password

EDIT: wm@conference… happens to be the default room name. Could that pose a problem?

-Heinrich

Are you doing the dial-out with the same participant that had set the password?

Yes. And I just tried it with another (non default) room. Same result. When I clear pwd, dial out works. with pwd it doesn’t.

“The chat room requests a password”

Workaround: clear pwd prior to making call, then set again (not a big deal)

I think I reproduce it. If you join a room with password and enter the password and you are moderator, that should work.
The other use-case should be fixed with: fix: Dial-out after setting password in the meeting. by damencho · Pull Request #1542 · jitsi/lib-jitsi-meet · GitHub

Thank you, Damian. I will try that tomorrow.
But the link you provided, yields 404!

-Heinrich

Fixed now

Yes, that’s right. if I join a room with password and the moderator grants me moderator rights, then I can dial out.
As for the patch, I do not know how to implement it. I am able to download the fixed .js file from GitHub, but where should I put it? Into some .jar file? Or should I wait for a new Ubuntu package to come out?
There is yet another problem: When I hover the mouse over the window of a dial-out participant, his or her phone number is shown. This is not acceptable as we have elevated privacy needs. For dial in, I was able to wipe the phone number in my PBX’s IVR, but how can I do that with dial-out?

Thanks for your fast and kind support!

-Heinrich

I don’t think you can disable it at the moment without a config.

The fix need to go to jitsi-meet and recompile and deploy the whole app. Probably that will be out in next stable release