Jigasi and sipgate -- Wrong username or password

Hello everyone,

I am trying to connect Jigasi to my sipgate account. But I have trouble with that. Maybe someone has a tip for me to solve this problem?

After restarting jigasi I can find this in the jigasi logfile:

2020-03-31 13:33:31.845 INFO: [45] org.jitsi.jigasi.SipGateway.registrationStateChanged().105 REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:4192221e0@sipgate . de) -> RegistrationStateChangeEvent[ oldState=Unregistered; newState=RegistrationState=Registering; userRequest=false; reasonCode=-1; reason=null]
2020-03-31 13:33:31.943 INFO: [54] org.jitsi.jigasi.SipGateway.registrationStateChanged().105 REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:4192221e0@sipgate . de) -> RegistrationStateChangeEvent[ oldState=Registering; newState=RegistrationState=Authentication Failed; userRequest=false; reasonCode=1; reason=null]
2020-03-31 13:33:31.944 SEVERE: [54] org.jitsi.jigasi.ServerSecurityAuthority.log() Wrong username or password for provider:ProtocolProviderServiceSipImpl(SIP:4192221e0@sipgate . de)
2020-03-31 13:33:31.944 INFO: [54] org.jitsi.jigasi.SipGateway.registrationStateChanged().105 REG STATE CHANGE ProtocolProviderServiceSipImpl(SIP:4192221e0@sipgate . de) -> RegistrationStateChangeEvent[ oldState=Authentication Failed; newState=RegistrationState=Unregistered; userRequest=false; reasonCode=0; reason=User has canceled the authentication process.]

Here is my configuration:

Attention: I had to write “sipgate . de” in this post instead of sipgate.de because the forum thinks this would be a link and I am not allowed to add more then two links in a post as newbie.

/etc/jitsi/jigasi/config

# Jigasi settings
JIGASI_SIPUSER="4192221e0@sipgate . de"
JIGASI_SIPPWD="xyz123"

/etc/jitsi/jigasi/sip-communicator.properties

net.java.sip.communicator.impl.protocol.sip.acc1=acc1
net.java.sip.communicator.impl.protocol.sip.acc1.PROXY_ADDRESS=sipgate . de
net.java.sip.communicator.impl.protocol.sip.acc1.PROXY_AUTO_CONFIG=true
net.java.sip.communicator.impl.protocol.sip.acc1.PROXY_PORT=5060
net.java.sip.communicator.impl.protocol.sip.acc1.PREFERRED_TRANSPORT=UDP
net.java.sip.communicator.impl.protocol.sip.acc1.ACCOUNT_UID=SIP\:4192221e0@sipgate . de
net.java.sip.communicator.impl.protocol.sip.acc1.PASSWORD=xyz123
net.java.sip.communicator.impl.protocol.sip.acc1.PROTOCOL_NAME=SIP
net.java.sip.communicator.impl.protocol.sip.acc1.SERVER_ADDRESS=sipgate . de
net.java.sip.communicator.impl.protocol.sip.acc1.USER_ID=4192221e0@sipgate . de
net.java.sip.communicator.impl.protocol.sip.acc1.KEEP_ALIVE_INTERVAL=25
net.java.sip.communicator.impl.protocol.sip.acc1.KEEP_ALIVE_METHOD=OPTIONS
net.java.sip.communicator.impl.protocol.sip.acc1.VOICEMAIL_ENABLED=false
net.java.sip.communicator.impl.protocol.sip.acc1.JITSI_MEET_ROOM_HEADER_NAME=X-Room-Name
net.java.sip.communicator.impl.protocol.sip.acc1.JITSI_MEET_DOMAIN_BASE_HEADER_NAME=X-Domain-Base
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.AMR-WB/16000=750
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.G722/8000=700
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.GSM/8000=800
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.PCMA/8000=600
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.PCMU/8000=650
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.iLBC/8000=10
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.opus/48000=1000
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.red/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.telephone-event/8000=1
net.java.sip.communicator.impl.protocol.sip.acc1.Encodings.ulpfec/90000=0
net.java.sip.communicator.impl.protocol.sip.acc1.OVERRIDE_ENCODINGS=false
net.java.sip.communicator.impl.protocol.sip.acc1.DOMAIN_BASE=test-jitsi.my.domain

Your sip password needs to be encode to base64 in the jigasi confg and .properties files.

Jeah, cool! Thanks for your answer. Now my jigasi is connected to sipgate. Thanks!
Now i just have to configure the rest. Wish me luck :slight_smile:

I got stuck on this. Turns out I forgot to use echo with -e and encoded a newline character into my password.

With echo -n PASSWORD | base64 it works perfectly fine.