Jigasi and Asterisk, different codecs (G.722 and G.711a) possible?

Hi Community,

I am running Jitsi with Jigasi and sipgate.de OR Telekom via Asterisk PBX and it is working (at least almost working).

I just want to setup a dial-in configuration.

Can you give me some hints how I can get Jigasi / Asterisk to work with different codecs (HD Voice if possible and ALAW as a fallback option).

What I got so far:

  • I can establish HD-Voice via Telekom Account, but don’t know if there’s a fallback to ALAW if the “other end” doesn’t “speak” HD-Voice, is it enough in Asterisk to allow both codecs?
  • I can establish ALAW-connection via sipgate (as they don’t support HD-Voice incoming yet)
  • When I try to “mix” it together, there’s no audio available (I can still make a connection to the conferences)

Idea(s):

  • using one single number and have a kind of “intelligence” using the right codec (HD-Voice aka G.722 or ALAW aka G.711a)
  • using two different numbers (HD-Voice first dial-in number and ALAW second dial-in number), but I think there will be then 2 jigasi instances, right? But I didn’t find anything how to set up 2 instances (on one server)

Thank you for your ideas!

Cheers Rainer

Jigasi supports single sip connection, you can control codecs with these properties: jigasi/sip-communicator.properties at b7423fad61beccab18728e05358b4e7a69702eff · jitsi/jigasi · GitHub

@damencho Thank you for your quick reply. Unfortunately, this doesn’t help me a lot. In the sip-communicator-properties, I have just enabled G.722 and ALAW with priority 700. OVERRIDE_ENCODINGS is set to true.

Asterisk has enabled both codecs for both ends (sip provider and jigasi)

I think, there is a “codec translation problem”, but I can’t figure out, what program is responsible or what to change in order to get the problem solved.

Will try to describe it:

The problem occurs, as soon as the incoming call sends a different codec, e. g. Caller uses ALAW, Jigasi connection is G.722 -> no audio on both ends.
If both ends speak the same codec, everything is fine.
Unfortunately, there are still callers who can only use ALAW.

Therefore, I had the idea (see above) to use 2 Jigasi instances, one for HD-Voice, one for ALAW, but I haven’t got a clue how I can initiate a second instance of Jigasi ?!?

Any ideas?

If the different codecs are on the asterisk side, maybe asterisk cannot transcode, have you checked that?