Jicofo update error - jicofo : Depends: ruby-hocon but it is not installable

Our server is running ubuntu 16.04 and we have been aligned with jitsi-meet_5142 for long time. I tried to update jicofo and jitsi-videobridge2 ( apt install jicofo && apt install jicofo ) but the version it was installed was align with jitsi-meet_5390 not with latest jitsi-meet_5765. Later I solved this by finding out that gpg key of jitsi repo has been changed (GPG key changed?)

Then I tried again (apt install jitsi-videobridge2 && apt install jicofo - also took backup before update),now video bridge got updated but jicofo runs into error " jicofo : Depends: ruby-hocon but it is not installable"

full error :

root@testcon:/etc/prosody# apt install jicofo
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 jicofo : Depends: ruby-hocon but it is not installable
E: Unable to correct problems, you have held broken packages.

any idea or solution?

Can ruby-hocon be installed on Ubuntu 16.04?

I wasn’t sure… so it can’t be installed on 16.04 and I can’t update jicofo to align with jitsi-meet_5765…? so either I have to upgrade to 18.04/20.04 or I have to downgrade everything to jitsi-meet_5390?

can anyone please confirm that ruby-hocon is not at all instalable in 16.04 and so jicofo can’t be updated to it’s lates (5765) in 16.04?

Why not just do a search for ruby-hocon and its requirements? You’re using a very old distro; new releases of Jitsi tend to work with the latest releases of most dependencies. The error message jicofo is spitting is quite clear, so clearly that’s where the focus should be.

ok thanks for the answer of my dumb question :slight_smile: … I was just confused and really couldn’t find something to install in on 16.04 as there are other services running of ours which will be costly to shift rightway and just wanted to be sure.

What’s the output of this command in your installation?

which ruby

this is the output of “which ruby”


we decided to upgrade though anyway…

Meaning, you’re moving to a more current distro? If so, that’s honestly your best bet, because otherwise, you’re likely to run into similar issues eventually.

1 Like

Yeah… I just understood that, this is just the start and if we don’t update now we will be flooded with issues… but I was just little afraid shifting to 20.04 as I ran into problem shifting 20.04 in my desktop pc and couldn’t solve UI rendering problem (which seems many ran into this problem, don’t know whether it can affect server as I ran into other issues before UI rendering issues which got solved after much effort) and got suggested to install fresh :slight_smile: didn’t face problem during fresh install in another pc though.

You’re probably more likely to experience issues with Jitsi versions than with upgrading your distro to the latest version. And even the ‘issues’ with Jitsi versions are really more often just individual preferences (like for instance, wanting to stay on sctp instead of websockets e.t.c…). So, at least as of right now, updating to 20.04 is a safe and smart bet. If a new version of Ubuntu is released, then there’s another conversation to be had.