Jicofo needs restart because of "Failed to create room: JvbBrewery@internal.auth.mydomain.com" after system boot

Hi, I deployed my own jitsi system on Debian Jessie (8).
After upgrading the working version (jitsi-meet 4376) to the latest version, jitsi-meet stopped working after reboot.
After every system boot I need to restart jicofo, for jitsi meet to work.
In effect, after every boot in jicofo log I found this error:

Jicofo 2020-06-12 16:00:56.739 INFO: [17] org.jitsi.jicofo.xmpp.BaseBrewery.log() Joined brewery room: JibriBrewery@internal.auth.glass.ctechs.eu
Jicofo 2020-06-12 16:00:56.896 SEVERE: [17] org.jitsi.jicofo.xmpp.BaseBrewery.log() Failed to create room: JvbBrewery@internal.auth.glass.ctechs.eu
net.java.sip.communicator.service.protocol.OperationFailedException: Failed to join the room
at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:298)
at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.join(ChatRoomImpl.java:209)
at org.jitsi.jicofo.xmpp.BaseBrewery.start(BaseBrewery.java:185)
at org.jitsi.jicofo.xmpp.BaseBrewery.maybeStart(BaseBrewery.java:136)
at org.jitsi.jicofo.xmpp.BaseBrewery.registrationStateChanged(BaseBrewery.java:161)
at org.jitsi.jicofo.ProtocolProviderHandler.registrationStateChanged(ProtocolProviderHandler.java:150)
at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:187)
at net.java.sip.communicator.service.protocol.AbstractProtocolProviderService.fireRegistrationStateChanged(AbstractProtocolProviderService.java:141)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.notifyConnected(XmppProtocolProvider.java:315)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:60)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$XmppConnectionListener.authenticated(XmppProtocolProvider.java:512)
at org.jivesoftware.smack.AbstractXMPPConnection.callConnectionAuthenticatedListener(AbstractXMPPConnection.java:1297)
at org.jivesoftware.smack.AbstractXMPPConnection.afterSuccessfulLogin(AbstractXMPPConnection.java:572)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.afterSuccessfulLogin(XMPPTCPConnection.java:379)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.loginInternal(XMPPTCPConnection.java:444)
at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:491)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:272)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: org.jivesoftware.smack.XMPPException$XMPPErrorException: XMPP error reply received from jvbbrewery@internal.auth.glass.ctechs.eu: XMPPError: forbidden - auth
at org.jivesoftware.smack.XMPPException$XMPPErrorException.ifHasErrorThenThrow(XMPPException.java:132)
at org.jivesoftware.smack.StanzaCollector.nextResultOrThrow(StanzaCollector.java:263)
at org.jivesoftware.smack.StanzaCollector.nextResultOrThrow(StanzaCollector.java:214)
at org.jivesoftware.smackx.muc.MultiUserChat.getConfigurationForm(MultiUserChat.java:781)
at org.jitsi.impl.protocol.xmpp.ChatRoomImpl.joinAs(ChatRoomImpl.java:244)
… 24 more

If I restar jicofo the error does’nt occur, even it remains a not relevant error

Jicofo 2020-06-12 16:44:33.384 INFO: [17] org.jitsi.jicofo.xmpp.BaseBrewery.log() Joined brewery room: JibriBrewery@internal.auth.glass.ctechs.eu
Jicofo 2020-06-12 16:44:33.409 INFO: [17] org.jitsi.jicofo.xmpp.BaseBrewery.log() Joined brewery room: JvbBrewery@internal.auth.glass.ctechs.eu
Jicofo 2020-06-12 16:44:33.432 INFO: [17] org.jitsi.jicofo.ComponentsDiscovery.log() New component discovered: recorder.glass.ctechs.eu, Prosody(0.10.2,Linux)
Jicofo 2020-06-12 16:44:33.435 INFO: [17] org.jitsi.jicofo.ComponentsDiscovery.log() New component discovered: guest.glass.ctechs.eu, Prosody(0.10.2,Linux)
Jicofo 2020-06-12 16:44:33.445 SEVERE: [17] org.jitsi.impl.protocol.xmpp.OpSetSimpleCapsImpl.log() Failed to discover features for focus.glass.ctechs.eu: XMPP error reply received from focus.glass.ctechs.eu: XMPPError: service-unavailable - wait

Do you have these settings:



That should help … although you are on prosody 0.10, I’m not sure what are these defaults there, I have the feeling that changed only on 0.11.

Now it’s working, many thanks.
So when I upgrade jitsi I need to update configuration files too.

What makes the difference is the row above the two rows you suggested, without
admins = { “focusUser@auth.jitmeet.example.com”, “jvb@auth.jitmeet.example.com” }
the error persists.