Jicofo logs showing error SSLException, Received fatal alert: protocol_version

The quick start tutorial worked for me without Domain secure setting. Then I did the Domain secure setting and after restarting jicofo,jitsi-videobridge2 and prosody, launched the url. But when I start the meeting and provide username and password, meeting does not start and is stuck at username password screen. I get the logs mentioned below. Any help would be highly appreciated.

Jicofo 2020-07-23 07:46:57.591 SEVERE: [79] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to connect/login: javax.net.ssl.SSLException: Received fatal alert: protocol_version
org.jivesoftware.smack.SmackException: javax.net.ssl.SSLException: Received fatal alert: protocol_version
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1076)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.lang.Thread.run(Thread.java:820)
Caused by: javax.net.ssl.SSLException: Received fatal alert: protocol_version
at com.ibm.jsse2.k.a(k.java:1)
at com.ibm.jsse2.k.a(k.java:14)
at com.ibm.jsse2.av.b(av.java:761)
at com.ibm.jsse2.av.a(av.java:582)
at com.ibm.jsse2.av.i(av.java:136)
at com.ibm.jsse2.av.a(av.java:1001)
at com.ibm.jsse2.av.startHandshake(av.java:991)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)
… 3 more
Jicofo 2020-07-23 07:46:57.594 WARNING: [185] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener() Connection XMPPTCPConnection[not-authenticated] (0) closed with error
javax.net.ssl.SSLException: Received fatal alert: protocol_version
at com.ibm.jsse2.k.a(k.java:1)
at com.ibm.jsse2.k.a(k.java:14)
at com.ibm.jsse2.av.b(av.java:761)
at com.ibm.jsse2.av.a(av.java:582)
at com.ibm.jsse2.av.i(av.java:136)
at com.ibm.jsse2.av.a(av.java:1001)
at com.ibm.jsse2.av.startHandshake(av.java:991)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
at java.lang.Thread.run(Thread.java:820)

I’m currently have the same issues and errors from a fresh quick-install guide and using the ssl .sh file.

I’m facing the same problem.

It’s a new fresh installation of Jitsi on ubuntu 18.04, made using the quick install guide. Works fine on P2P but video and audio stop (marked as disabled on the frontend) as soon as a third person join.
The installation is behind a NAT (Google Cloud) and ports tcp:80,443,4443,4444,5222 and udp:10000-20000 are open. It’s the same environement I used on a previous setup (early april - with videobridge1 not 2) but this one doesn’t work.

Here’s the errors I see (looped):

jicofo.log

Jicofo 2020-07-31 20:05:53.437 SEVERE: [39] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to connect/login: javax.net.ssl.SSLException: Received fatal alert: protocol_version
org.jivesoftware.smack.SmackException: javax.net.ssl.SSLException: Received fatal alert: protocol_version
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1076)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
	at java.lang.Thread.run(Thread.java:820)
Caused by: javax.net.ssl.SSLException: Received fatal alert: protocol_version
	at com.ibm.jsse2.k.a(k.java:1)
	at com.ibm.jsse2.k.a(k.java:14)
	at com.ibm.jsse2.av.b(av.java:761)
	at com.ibm.jsse2.av.a(av.java:582)
	at com.ibm.jsse2.av.i(av.java:136)
	at com.ibm.jsse2.av.a(av.java:1001)
	at com.ibm.jsse2.av.startHandshake(av.java:991)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)
	... 3 more
Jicofo 2020-07-31 20:05:53.439 WARNING: [68] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener() Connection XMPPTCPConnection[not-authenticated] (0) closed with error
javax.net.ssl.SSLException: Received fatal alert: protocol_version
	at com.ibm.jsse2.k.a(k.java:1)
	at com.ibm.jsse2.k.a(k.java:14)
	at com.ibm.jsse2.av.b(av.java:761)
	at com.ibm.jsse2.av.a(av.java:582)
	at com.ibm.jsse2.av.i(av.java:136)
	at com.ibm.jsse2.av.a(av.java:1001)
	at com.ibm.jsse2.av.startHandshake(av.java:991)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
	at java.lang.Thread.run(Thread.java:820)

prosody.log

|Jul 31 20:05:48 c2s55cfce77dca0|info|Client connected|
|---|---|---|
|Jul 31 20:05:48 c2s55cfce77dca0|info|Client disconnected: ssl handshake error: unsupported protocol|
|Jul 31 20:05:48 conference.bluestream.whynotblue.com:muc_domain_mapper|warn|Session filters applied|

jvb.log

2020-07-31 20:07:39.435 WARNING: [30] [hostname=localhost id=shard] MucClient.lambda$getConnectAndLoginCallable$8#669: [MucClient id=shard hostname=localhost] error connecting
org.jivesoftware.smack.SmackException: javax.net.ssl.SSLException: Received fatal alert: protocol_version
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1076)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
	at java.lang.Thread.run(Thread.java:820)
Caused by: javax.net.ssl.SSLException: Received fatal alert: protocol_version
	at com.ibm.jsse2.k.a(k.java:1)
	at com.ibm.jsse2.k.a(k.java:14)
	at com.ibm.jsse2.av.b(av.java:761)
	at com.ibm.jsse2.av.a(av.java:582)
	at com.ibm.jsse2.av.i(av.java:136)
	at com.ibm.jsse2.av.a(av.java:1001)
	at com.ibm.jsse2.av.startHandshake(av.java:991)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)
	... 3 more
2020-07-31 20:07:39.436 WARNING: [124] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connection XMPPTCPConnection[not-authenticated] (0) closed with error
javax.net.ssl.SSLException: Received fatal alert: protocol_version
	at com.ibm.jsse2.k.a(k.java:1)
	at com.ibm.jsse2.k.a(k.java:14)
	at com.ibm.jsse2.av.b(av.java:761)
	at com.ibm.jsse2.av.a(av.java:582)
	at com.ibm.jsse2.av.i(av.java:136)
	at com.ibm.jsse2.av.a(av.java:1001)
	at com.ibm.jsse2.av.startHandshake(av.java:991)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
	at java.lang.Thread.run(Thread.java:820)
2020-07-31 20:07:39.437 WARNING: [124] [hostname=localhost id=shard] MucClient$1.connectionClosedOnError#314: Closed on error:
javax.net.ssl.SSLException: Received fatal alert: protocol_version
	at com.ibm.jsse2.k.a(k.java:1)
	at com.ibm.jsse2.k.a(k.java:14)
	at com.ibm.jsse2.av.b(av.java:761)
	at com.ibm.jsse2.av.a(av.java:582)
	at com.ibm.jsse2.av.i(av.java:136)
	at com.ibm.jsse2.av.a(av.java:1001)
	at com.ibm.jsse2.av.startHandshake(av.java:991)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
	at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
	at java.lang.Thread.run(Thread.java:820)

And on the javascript console (as soon as the third person joins):

Logger.js:154 2020-07-31T20:30:07.087Z [modules/xmpp/strophe.jingle.js] :  invalid session id 

Any help would be really appreciated! I can join more info if needed.

Just adding that I have the same issue here. I haven’t enabled domain secure or anything; this is just following their Ubuntu/Debian setup scripts exactly as stated. This should be fairly reproducible too since I’m also doing this on a freshly-created Google Compute Engine VM.

Jicofo logs are as follows:

Jicofo 2020-08-03 04:09:00.396 SEVERE: [108] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.log() Failed to connect/login: javax.net.ssl.SSLException: Received fatal alert: protocol_version
org.jivesoftware.smack.SmackException: javax.net.ssl.SSLException: Received fatal alert: protocol_version
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1076)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:1000)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1016)
        at java.lang.Thread.run(Thread.java:820)
Caused by: javax.net.ssl.SSLException: Received fatal alert: protocol_version
        at com.ibm.jsse2.k.a(k.java:1)
        at com.ibm.jsse2.k.a(k.java:14)
        at com.ibm.jsse2.av.b(av.java:761)
        at com.ibm.jsse2.av.a(av.java:582)
        at com.ibm.jsse2.av.i(av.java:136)
        at com.ibm.jsse2.av.a(av.java:1001)
        at com.ibm.jsse2.av.startHandshake(av.java:991)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnection.java:810)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1200(XMPPTCPConnection.java:151)
        at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1071)

The same Java error is reported in the JVB logs, and the Prosody logs error out with “unsupported protocol.” I can post these if it’s helpful.

Since this is very clearly a Jitsi bug and not a documentation question I’m also going try to file this as a Github issue. I’m not sure whether it is a JVB or Jicofo issue, though.

Workarounds I have already tried: changing Prosody supported protocols to just TLSv1.2 instead of TLSv1.2+, and adding the -Dhttp.protocols=“TLSv1.2” flags to the JVB and Jicofo Java flags. The latter did change the error from “unsupported protocol” to “wrong ssl version” but still 3 people do not work.

I have solved the issue. To make this work you may have to start with the tutorial again.
The solution is to use OpenJDK. So before your start with the tutorial ensure that OpenJDK is installed. And also install nginx.

This is because for some reason the tutorial will install IBM JDK which causes the above mentioned issue.

Once this is done install jitsi-meet without

> --no-install-recommends

apt install --no-install-recommends jitsi-meet

Thank you, gauravnavgire! Replying to confirm that this workaround worked for me as well.

Thank you @gauravnavgire!!! It worked for me too!