Jicofo error log. more than 3 participants audio and camera muted


#1

Hi team,
I quick install jitsimeet and met proplem that is audio and camera muted when more than 3 participants join.
And i found error on jicofo:

Jicofo 2018-11-14 02:15:25.954 SEVERE: [131] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().319 Failed to connect/login: No response received within reply timeout. Timeout was 15000ms (~15s). While waiting for establishing TLS
org.jivesoftware.smack.SmackException$NoResponseException: No response received within reply timeout. Timeout was 15000ms (~15s). While waiting for establishing TLS
at org.jivesoftware.smack.SmackException$NoResponseException.newWith(SmackException.java:93)
at org.jivesoftware.smack.SynchronizationPoint.checkForResponse(SynchronizationPoint.java:270)
at org.jivesoftware.smack.SynchronizationPoint.checkIfSuccessOrWait(SynchronizationPoint.java:155)
at org.jivesoftware.smack.SynchronizationPoint.checkIfSuccessOrWaitOrThrow(SynchronizationPoint.java:126)
at org.jivesoftware.smack.AbstractXMPPConnection.connect(AbstractXMPPConnection.java:383)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect(XmppProtocolProvider.java:275)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.access$000(XmppProtocolProvider.java:62)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:256)
at org.jitsi.impl.protocol.xmpp.XmppProtocolProvider$1.call(XmppProtocolProvider.java:251)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Jicofo 2018-11-14 02:15:25.955 WARNING: [317] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener() Connection XMPPTCPConnection[not-authenticated] (0) closed with error
java.lang.IllegalStateException: Could not transform string ‘undefined_condition’ to XMPPErrorCondition
at org.jivesoftware.smack.packet.StreamError$Condition.fromString(StreamError.java:194)
at org.jivesoftware.smack.util.PacketParserUtils.parseStreamError(PacketParserUtils.java:827)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPConnection.java:1054)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPConnection.java:994)
at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnection.java:1010)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.IllegalArgumentException: No enum constant org.jivesoftware.smack.packet.StreamError.Condition.undefined_condition
at java.lang.Enum.valueOf(Enum.java:238)
at org.jivesoftware.smack.packet.StreamError$Condition.valueOf(StreamError.java:156)
at org.jivesoftware.smack.packet.StreamError$Condition.fromString(StreamError.java:192)
… 5 more

Pls, help me check it.
Thanks


#2

So it seems jocofo is having problems connecting to your xmpp server. How did you install, following quick install? Did you change the default config?


#3

Hi @damencho,
I followed quick install. I didnt change any default config.
But i reinstall jitsi on a same server.

Some prosody information:

Prosody 0.10.2

Prosody directories

Data directory: /var/lib/prosody
Config directory: /etc/prosody
Source directory: /usr/lib/prosody
Plugin directories:
/usr/lib/prosody/modules/

Lua environment

Lua version: Lua 5.1

Lua module search paths:
/usr/lib/prosody/?.lua
/usr/local/share/lua/5.1/?.lua
/usr/local/share/lua/5.1/?/init.lua
/usr/local/lib/lua/5.1/?.lua
/usr/local/lib/lua/5.1/?/init.lua
/usr/share/lua/5.1/?.lua
/usr/share/lua/5.1/?/init.lua

Lua C module search paths:
/usr/lib/prosody/?.so
/usr/local/lib/lua/5.1/?.so
/usr/lib/x86_64-linux-gnu/lua/5.1/?.so
/usr/lib/lua/5.1/?.so
/usr/local/lib/lua/5.1/loadall.so

LuaRocks: Not installed

Lua module versions

lfs: LuaFileSystem 1.6.3
lxp: LuaExpat 1.3.0
socket: LuaSocket 3.0-rc1

root@vultr:/etc/apt/sources.list.d#

Thanks,


#4

What is the output of netstat -anp | grep lua?
What is the content of /etc/jitsi/jicofo/config?
Do you have firewall running on the machine?


#5

Hi @damencho,

root@vultr:/etc/prosody/conf.avail# netstat -anp | grep lua
tcp 0 0 0.0.0.0:5269 0.0.0.0:* LISTEN 31933/lua5.1
tcp 0 0 0.0.0.0:5280 0.0.0.0:* LISTEN 31933/lua5.1
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN 31933/lua5.1
tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 31933/lua5.1
tcp 0 0 127.0.0.1:5347 127.0.0.1:42078 ESTABLISHED 31933/lua5.1
tcp 0 0 127.0.0.1:5347 127.0.0.1:42076 ESTABLISHED 31933/lua5.1
tcp6 0 0 :::5269 :::* LISTEN 31933/lua5.1
tcp6 0 0 :::5280 :::* LISTEN 31933/lua5.1
tcp6 0 0 ::1:5347 :::* LISTEN 31933/lua5.1
tcp6 0 0 :::5222 :::* LISTEN 31933/lua5.1

root@vultr:/etc/jitsi/jicofo# more config
JICOFO_HOST=localhost

JICOFO_HOSTNAME=vc1.xxx.vn

JICOFO_SECRET=D5zqxx6c

JICOFO_PORT=5347

JICOFO_AUTH_DOMAIN=auth.vc1.xxx.vn

JICOFO_AUTH_USER=focus

JICOFO_AUTH_PASSWORD=P4rRKxxA

JICOFO_OPTS=""

JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_L
OCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"

root@vultr:/etc/jitsi/jicofo# ufw status
Status: active

To Action From


Apache Full ALLOW Anywhere
OpenSSH ALLOW Anywhere
10000:20000/udp ALLOW Anywhere
3306 ALLOW Anywhere
4443 ALLOW Anywhere
Apache Full (v6) ALLOW Anywhere (v6)
OpenSSH (v6) ALLOW Anywhere (v6)
10000:20000/udp (v6) ALLOW Anywhere (v6)
3306 (v6) ALLOW Anywhere (v6)
4443 (v6) ALLOW Anywhere (v6)

Thanks,


#6

For some reason, your prosody is not listening to localhost 5222, but jicofo is configured to connect to localhost 5222 and this is the reason for your exception No response received ....
You need either to make prosody listen to localhost 5222 or if you change jicofo to connect to the ip address of your machine by changing JICOFO_HOST, then you need to make sure prosody also listens on that address for components connection (this is port 5347).

So basically now you have:

tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 31933/lua5.1
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN 31933/lua5.1

So this should be either:

tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 31933/lua5.1
tcp 0 0 0 0.0.0.0:5347 0.0.0.0:* LISTEN 31933/lua5.1

and you update JICOFO_HOST=you-machine-ip-address
or you need to have:

tcp 0 0 127.0.0.1:5222 0.0.0.0:* LISTEN 31933/lua5.1
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN 31933/lua5.1

and leave JICOFO_HOST=localhost.


#7

Hi @damencho,
How can i change listen port? I changed JICOFO_HOST=IP address but it’s not work.
Addition,
tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 31933/lua5.1
that is mean prosody listen from all IP on port 5222.
jicofo and prosody is install on same server.
Why jicofo can not connect to prosody?

Thanks,


#8

I use tcpdump to troubleshoot this king of things

tcpdump -w mydebug.cap -i eth0 -n port 5222

And analyse with wireshark

First don’t log it in a file

tcpdump -i eth0 -n port 5222

Just to see if packets arrive


#9

Hi @Mikygee,
That is file log.
Pls help me to check it.

Thanks,
Check port 5222.txt (11.1 KB)


#10

Is everything on the same machine ?
So far it’s looking fine to me, you have this bidirectionnal communication.

You need to record the packets as a cap/pcap capture now with option -w


#11

Hi @Mikygee
That is all log on lo and ens3(local IP) interface.
ens3_port.pcap (24 Bytes)
lo_port.pcap (4.3 KB)

Thanks,


#12

Look at packet 7, it doesn’t sound good

No stream features to proceed with

Then the server closes the connection.

I’ll might have more time tonight and make a capture that works on my side.
But I also want to tell you that it doesn’t work on my side with more than 2 participants.


#13

Hi @Mikygee,
Did you meet same issue with me?
Can you know how to downgrade prosody from 0.10 to 0.9.
I think there are some problem with prosody 0.10.

Thanks,


#14

Hi @Mikygee,
Did you meet same issue with me?
Can you know how to downgrade prosody from 0.10 to 0.9.
I think there are some problem with prosody 0.10.

Thanks,


#15

Hum, I was just experimenting with that and I’m completely wrong.
Having

tcp        0      0 0.0.0.0:5222            0.0.0.0:*               LISTEN      18926/lua5.1
tcp        0      0 127.0.0.1:5347          0.0.0.0:*               LISTEN      18926/lua5.1

is completely fine. I was testing on my dev instance.
So it must be something another wrong with your configuration. Can you send to me privately the content of your /etc/jitsi and /etc/prosody folder and /var/log/jitsi (but clean the content of /var/log/jitsi then restart jvb, restart jicofo, wait few seconds and try one conference with 3 participants and then send the content).


#16

Pls give your email. I cant upload file rar here.
Thanks so much


#17

Do a zip, damencho at jitsi dot org.


#18

I sent message to you. :slight_smile:
Pls check message on jitsi community.

Thanks