Jicofo don’t listen/connect to prosody client_proxy - act 2 (latest 2 stable builds)

sip com :











jicofo config

# Jitsi Conference Focus settings
# sets the host name of the XMPP server

# sets the XMPP domain (default: none)

# sets the XMPP domain name to use for XMPP user logins

# sets the focus domain name to use for XMPP focus user

# sets the username to use for XMPP user logins

# sets the password to use for XMPP user logins

# extra options to pass to the jicofo daemon

# adds java system props that are passed to jicofo (default are for home and logging config file)
JAVA_SYS_PROPS="-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Dconfig.file=/etc/jitsi/jicofo/jicofo.conf -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties -Dorg.jitsi.jicofo.PING_INTERVAL=-1 -Dorg.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1 -Dorg.jitsi.jicofo.SERVICE_REDISCOVERY_INTERVAL=-1 -Dorg.ice4j.ipv6.DISABLED=true"

jicofo jicofo.conf

jicofo {
  // Configuration for the internal health checks performed by jicofo.
  health {
    enabled = false
  xmpp {
    // The separate XMPP connection used for communication with clients (endpoints).
    client {
      enabled = true
      hostname = "gofast-preprod-comm.ceo-vision.com"
      port = 5222
      domain = "auth.gofast-preprod-comm.ceo-vision.com"
      xmpp-domain = "gofast-preprod-comm.ceo-vision.com"
      username = "focus"
      password = "XXX"

      // How long to wait for a response to a stanza before giving up.
      reply-timeout = 15 seconds

      // The JID/domain of the MUC service used for conferencing.
      conference-muc-jid = conference.gofast-preprod-comm.ceo-vision.com

      // A flag to suppress the TLS certificate verification.
      disable-certificate-verification = true
      // The JID of the mod_client_proxy component if used. It will be trusted to encode the JID of the original
      // sender in the resource part of the JID.
      client-proxy = "focus.gofast-preprod-comm.ceo-vision.com"
    // The separate XMPP connection used for internal services (currently only jitsi-videobridge).
    service {
      enabled = false

    // How often XMPP components re-discovery will be performed. If set to 0, re-discovery will not be performed.
     rediscovery-interval = 0 seconds

Oh and yes you are right this is definitly the issue as in production with an older version it authentifies with focus :

You have provided the jvb sip-communicator.properties do you have such a file for jicofo?

No I use the same with sym links, but there is no more configurations concerning jicofo in it if I remember because all was migrated in the new config files

There is something fishy in here. You do not have any configurations about brewery rooms, but your jicofo is trying to use one … you are probably looking at wrong files or something

Yes I have, look in the sip communicator :


(So yes it remains some jicofo config in there)

Oh you are using same file for both … this is so confusing.

Look, to make it easier. Create a new VM, do a clean install. Take the configs from there and use those and stick to those …

These are from my newly installed Jitsi


# adds java system props that are passed to jicofo (default are for home and logging config file)
JAVA_SYS_PROPS="-Dconfig.file=/etc/jitsi/jicofo/jicofo.conf -Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc/jitsi -Dnet.java.sip.communicator.SC_HOME_DIR_NAME=jicofo -Dnet.java.sip.communicator.SC_LOG_DIR_LOCATION=/var/log/jitsi -Djava.util.logging.config.file=/etc/jitsi/jicofo/logging.properties"


# Jicofo HOCON configuration. See reference.conf in /usr/share/jicofo/jicofo.jar for
#available options, syntax, and default values.
jicofo {
  xmpp: {
    client: {
      client-proxy: "focus.jitsi.mydomain.corp"
      xmpp-domain: "jitsi.mydomain.corp"
      domain: "auth.jitsi.mydomain.corp"
      username: "focus"
      password: "sf5m7rg9IAJsEESc"
    trusted-domains: [ "recorder.jitsi.mydomain.corp" ]
  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.jitsi.mydomain.corp"
  jibri: {
    brewery-jid: "JibriBrewery@internal.auth.jitsi.mydomain.corp"
    pending-timeout: 90 seconds

There is also logging.properties but no sip.communicator for the new setup

Mmh interesting, yeah it may be related to the old sip file.

Let me try to get rid of it and I’ll tell you

Well done, thank you !

So yeah the old sip configuration is completly unusable now, I think something has changed in the code with the old config vs the new config with the exact same parameters.

Now I have other issues with video communication but I think I can handle that by myself (things with turn).

Thank you both for your help, I hope jitsi (or some maintained fork, maybe us in the future) will release RHEL packages a day because for now, comparing configurations, updates and stuff from the deb packages are the only way we have to update our production and there is some breaking changes each release

Have a nice day !