Jibri visiting URL problem

Hi all!
My Jitsi and Jibri are on separate servers.
Jitsi works correctly on the following link:
https://mydnsname/meet/
Jicofo log shows me that the "jibri available’ is true when I starting Jibri.

When I try to start recording in the meeting room, Jicofo tells me that Jibri is not available. At the same time, Jibri sends me the following message from its log “Visiting url”:
https://mydns/dedicatedstampsenablecurrently#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true&config.p2p.enabled=false

The problem is when I try to copy, paste this above link there is nothing in the browser and 404 error happens.

When I supplementing this link that it comes from the Jibri log with the “/meet/” subdirectory, the jitsi room is created.

I tried to supplement “name”, “xmpp_server_hosts”, “xmpp_domain” of Jibri config.json with the “/meet/” value but I cannot make it to work. The link that I showed above keeps showing the wrong link without the /meet/ subdirectory.

Could someone help me?

My Jibri config.json file content:

"xmpp_environments": [
        {
            // A friendly name for this environment which can be used
            //  for logging, stats, etc.
            "name": "prod environment",
            // The hosts of the XMPP servers to connect to as part of
            //  this environment
            "xmpp_server_hosts": [
                "mydnsname.com"
            ],
            // The xmpp domain we'll connect to on the XMPP server
            "xmpp_domain": "mydnsname.com",

            // meet baseurl
            //"meet_url":"mydnsname.com",
            // Jibri will login to the xmpp server as a privileged user
            "control_login": {
                // The domain to use for logging in
                "domain": "auth.mydnsname.com",
                // The credentials for logging in
                "username": "jibri",
                "password": "passwd"
            },
            // Using the control_login information above, Jibri will join
            //  a control muc as a means of announcing its availability
            //  to provide services for a given environment
            "control_muc": {
                "domain": "internal.auth.mydnsname.com",
                "room_name": "JibriBrewery",
                "nickname": "jibri"
            },
            // All participants in a call join a muc so they can exchange
            //  information.  Jibri can be instructed to join a special muc
            //  with credentials to give it special abilities (e.g. not being
            //  displayed to other users like a normal participant)
            "call_login": {
                "domain": "recorder.mydnsname.com",
                "username": "recorder",
                "password": "passwd"
            },
            // When jibri gets a request to start a service for a room, the room
            //  jid will look like:
            //  roomName@optional.prefixes.subdomain.xmpp_domain
            // We'll build the url for the call by transforming that into:
            //  https://xmpp_domain/subdomain/roomName
            // So if there are any prefixes in the jid (like jitsi meet, which
            //  has its participants join a muc at conference.xmpp_domain) then
            //  list that prefix here so it can be stripped out to generate
            //  the call url correctly
            "room_jid_domain_string_to_strip_from_start": "conference.",
            // The amount of time, in minutes, a service is allowed to continue.
            //  Once a service has been running for this long, it will be
            //  stopped (cleanly).  A value of 0 means an indefinite amount
            //  of time is allowed
            "usage_timeout": "0"
        }

I think the problem is the visiting URL that I mentioned above previously. The part of the /meet/ (subdirectory) is missing from it.

How can I resolve this?
Any help is welcomed!

The subomain problem was solved by xranby.

1 Like