Jibri Tip: send the recording folder name or a download link to the initiator

Sorted out.
It was due to my custom Prosody module which records chat, since Jibri does not have a display name it is causing issue there.
I noticed message is sent as soon as recording is started. Will check if there is a way to send it when recording stops, or to user who stops recording.

Actually, the initiator can get the same session id by checking APP.store.getState()["features/recording"].sessionDatas array too. Maybe you can try another implementation on the user side.

Hi @emrah,

Should I restart the services at jitsi meet server after implementing the script? Please inform, since I will implement this on a production server.

Thanks

If you only need session id and you only edit /usr/share/jitsi-meet/body.html then there is no need to restart anything.

If you change the nginx config too then you need to restart or reload the nginx service

I deploy jibri in the separated server. Just to confirm, at jibri server these steps are necessary right?

  1. install nginx
  2. create /etc/nginx/sites-enabled/jibri.conf (with settings from this post: Jibri Tip: send the recording folder name or a download link to the initiator - #3 by emrah)

Please advice

Hi @emrah,

I have already installed nginx at jibri server and create additional nginx config for recording, but nginx failed to start and show the following error:

nginx: [emerg] unknown directive "access_by_lua_block" in /etc/nginx/sites-enabled/jibri.conf:14
nginx: configuration file /etc/nginx/nginx.conf test failed

Please advise

Thanks

Probably, your Nginx has no embedded Lua module. Which nginx package do you have?

dpkg -l "nginx*" | egrep "^ii"

Try nginx-extras package if this is not the installed one

or

remove access_by_lua_block block but in this case, the initiator can open the folder before the recording is complete.

This is my nginx version:

ii  nginx          1.14.0-0ubuntu1.9 all          small, powerful, scalable web/proxy server
ii  nginx-common   1.14.0-0ubuntu1.9 all          small, powerful, scalable web/proxy server - common files
ii  nginx-core     1.14.0-0ubuntu1.9 amd64        nginx web/proxy server (standard version)

I install nginx, with the following command: sudo apt-get install nginx

You can change the Nginx package running the following command

apt-get install nginx-extras

Add sudo if you are not root

Thanks @emrah
nginx is working now and I’ve got the private message.

But now it’s shown the site can’t be reached:

Is there any other package that I have to installed or any other settings that have not been configured?

Please advice
Thanks

Something doesn’t want to connect TCP/10080
ERR_UNSAFE_PORT in message

I didn’t see a message like this before.
Which browser is this?
Is there any extension preventing to access unfamilar ports?

It seems that this is a Chrome issue. Is there any active web site on this server?

Chrome blocks TCP/10080 by default. (Firefox too)

1 Like

I’m using Chrome Version 93.0.4577.82 (Official Build) (64-bit)

How to check if there any extension preventing to access unfamiliar ports?

Can you try port 10000 or 5000?

@emrah, I’ve change to port 10000 and it works perfectly.

Thanks

1 Like

Hi @emrah, for my case I create subfolder recording/jibri-id/file…

how I can return this instance jibri-id, as you did in javascript .

you will ask me you why this subfolder ! because I run multiple jibri instances using docker on the same host each jibri instance creates it own folder to record the file.

Thank a lot!
BR
Yassine

The link must be created using data that is known to both the backend and the frontend. I don’t know how you can get jibri-id on the client-side.

You may create sembolic links to session folders and use it in nginx conf.

when jibri join to meeting as hidden user, it uses his id as name?

nope