Jibri Timed out waiting for call page to load

Hey guys.

I am creating this topic because I am struggling to make JITSI MEET and JIBRI work. We have JITSI Meet Up and running at meeting .netlinkvoice.app and we are using secure domain option too. Everything is working fine on the JITSI Meet side. Now we want to record the conference, therefore, we installed Ubuntu 16 with Jibri on it. Jibri can connect itself with JITSI to meet no problem. But when JIBRI gets the request for call recording it just timeout on-page call loading.

JIBRI config.json file -

{
// NOTE: this is a *SAMPLE* config file, it will need to be configured with
// values from your environment

// Where recording files should be temporarily stored
"recording_directory":"/srv/recordings/",
// The path to the script which will be run on completed recordings
"finalize_recording_script_path": "/srv/finalize_recording.sh",
"xmpp_environments": [
    {
        // A friendly name for this environment which can be used
        //  for logging, stats, etc.
        "name": "prod environment",
        // The hosts of the XMPP servers to connect to as part of
        //  this environment
        "xmpp_server_hosts": [
            "meet.netlinkvoice.app"
        ],
        // The xmpp domain we'll connect to on the XMPP server
        "xmpp_domain": "meet.netlinkvoice.app",
        // Jibri will login to the xmpp server as a privileged user 
        "control_login": {
            // The domain to use for logging in
            "domain": "auth.meet.netlinkvoice.app",
            // The credentials for logging in
            "username": "jibri",
            "password": "jibriauthpass"
        },
        // Using the control_login information above, Jibri will join 
        //  a control muc as a means of announcing its availability 
        //  to provide services for a given environment
        "control_muc": {
            "domain": "internal.auth.meet.netlinkvoice.app",
            "room_name": "JibriBrewery",
            "nickname": "jibri-nickname"
        },
        // All participants in a call join a muc so they can exchange
        //  information.  Jibri can be instructed to join a special muc
        //  with credentials to give it special abilities (e.g. not being
        //  displayed to other users like a normal participant)
        "call_login": {
            "domain": "recorder.meet.netlinkvoice.app",
            "username": "recorder",
            "password": "jibrirecorderpass"
        },

Jibri Logs -
2020-03-19 20:26:06.095 INFO: [93] org.jitsi.jibri.JibriManager.startFileRecording() Starting a file recording with params: FileRecordingRequestParams(callParams=CallParams(callUrlInfo=CallUrlInfo(baseUrl=https://meet.netlinkvoice.app, callName=jollyhuntersanticipatebrightly, urlParams=)), sessionId=jrgvghlvahmbpmww, callLoginParams=XmppCredentials(domain=recorder.meet.netlinkvoice.app, username=recorder, password=jibrirecorderpass)) finalize script path: /srv/finalize_recording.sh and recordings directory: /srv/recordings/
2020-03-19 20:26:07.468 INFO: [93] org.openqa.selenium.remote.ProtocolHandshake.createSession() Detected dialect: OSS
2020-03-19 20:26:07.480 INFO: [93] org.jitsi.jibri.selenium.JibriSelenium.() Starting empty call check with a timeout of PT30S
2020-03-19 20:26:07.482 FINE: [93] org.jitsi.jibri.capture.ffmpeg.FfmpegCapturer.() Detected os as OS: LINUX
2020-03-19 20:26:07.484 INFO: [93] org.jitsi.jibri.service.impl.FileRecordingJibriService.() Writing recording to /srv/recordings/jrgvghlvahmbpmww
2020-03-19 20:26:07.484 FINE: [93] org.jitsi.jibri.statsd.JibriStatsDClient.incrementCounter() Incrementing statsd counter: start:recording
2020-03-19 20:26:07.485 INFO: [93] org.jitsi.jibri.status.JibriStatusManager.log() Busy status has changed: IDLE -> BUSY
2020-03-19 20:26:07.485 INFO: [93] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=BUSY, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections
2020-03-19 20:26:07.485 INFO: [93] org.jitsi.xmpp.mucclient.MucClientManager.log() Setting a presence extension: org.jitsi.xmpp.extensions.jibri.JibriStatusPacketExt@53a91ebc
2020-03-19 20:26:09.115 FINE: [102] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Visiting url https://meet.netlinkvoice.app/jollyhuntersanticipatebrightly#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true&config.p2p.enabled=false
2020-03-19 20:26:40.287 SEVERE: [102] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load
2020-03-19 20:26:40.287 INFO: [102] org.jitsi.jibri.selenium.JibriSelenium.onSeleniumStateChange() Transitioning from state Starting up to Error: SESSION Failed to join call
2020-03-19 20:26:40.288 INFO: [102] org.jitsi.jibri.service.impl.FileRecordingJibriService.onServiceStateChange() File recording service transitioning from state Starting up to Error: SESSION Failed to join call
2020-03-19 20:26:40.288 INFO: [102] org.jitsi.jibri.api.xmpp.XmppApi.invoke() Current service had an error, sending error iq
2020-03-19 20:26:40.289 FINE: [102] org.jitsi.jibri.statsd.JibriStatsDClient.incrementCounter() Incrementing statsd counter: stop:recording
2020-03-19 20:26:40.289 INFO: [102] org.jitsi.jibri.JibriManager.stopService() Stopping the current service
2020-03-19 20:26:40.289 INFO: [102] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Stopping capturer
2020-03-19 20:26:40.289 INFO: [102] org.jitsi.jibri.util.JibriSubprocess.ffmpeg.stop() Stopping ffmpeg process
2020-03-19 20:26:40.290 INFO: [102] org.jitsi.jibri.util.JibriSubprocess.ffmpeg.stop() ffmpeg exited with value null
2020-03-19 20:26:40.290 INFO: [102] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Quitting selenium
2020-03-19 20:26:40.297 INFO: [102] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Participants in this recording:
2020-03-19 20:26:40.318 INFO: [102] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 10 log entries for type browser
2020-03-19 20:26:40.371 INFO: [102] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 1008 log entries for type driver
2020-03-19 20:26:40.538 INFO: [102] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Got 0 log entries for type client
2020-03-19 20:26:40.538 INFO: [102] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Leaving web call
2020-03-19 20:26:40.576 INFO: [102] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Quitting chrome driver
2020-03-19 20:26:40.654 INFO: [102] org.jitsi.jibri.selenium.JibriSelenium.leaveCallAndQuitBrowser() Chrome driver quit
2020-03-19 20:26:40.655 INFO: [102] org.jitsi.jibri.service.impl.FileRecordingJibriService.stop() Finalizing the recording
2020-03-19 20:26:50.664 SEVERE: [102] org.jitsi.jibri.service.impl.FileRecordingJibriService.finalize() Timed out waiting for process logger task to complete
2020-03-19 20:26:50.664 INFO: [102] org.jitsi.jibri.service.impl.FileRecordingJibriService.finalize() Recording finalize script finished with exit value 0
2020-03-19 20:26:50.665 INFO: [102] org.jitsi.jibri.status.JibriStatusManager.log() Busy status has changed: BUSY -> IDLE
2020-03-19 20:26:50.665 INFO: [102] org.jitsi.jibri.api.xmpp.XmppApi.updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connections


I also tried to open that link on my browser which JIBRI tries to connect with, and I can open the link and can join the conference with no problem.

Prosody config file -

– Plugins path gets uncommented during jitsi-meet-tokens package install - that’s where token plugin is located
–plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

VirtualHost “meet.netlinkvoice.app”
– enabled = false – Remove this line to enable this host
authentication = “internal_plain”
– Properties below are modified by jitsi-meet-tokens package config
– and authentication above is switched to “token”
–app_id=“example_app_id”
–app_secret=“example_app_secret”
– Assign this host a certificate for TLS, otherwise it would use the one
– set in the global section (if any).
– Note that old-style SSL on port 5223 only supports one certificate, and will always
– use the global one.
ssl = {
key = “/etc/prosody/certs/meet.netlinkvoice.app.key”;
certificate = “/etc/prosody/certs/meet.netlinkvoice.app.crt”;
}
– we need bosh
modules_enabled = {
“bosh”;
“pubsub”;
“ping”; – Enable mod_ping
}

    c2s_require_encryption = false

Component “conference.meet.netlinkvoice.app” “muc”
storage = “null”
–modules_enabled = { “token_verification” }
c2s_require_encryption = false
admins = { “focus@auth.meet.netlinkvoice.app” }

Component “jitsi-videobridge.meet.netlinkvoice.app”
component_secret = “akNNADXz”
c2s_require_encryption = false
VirtualHost “auth.meet.netlinkvoice.app”
ssl = {
key = “/etc/prosody/certs/auth.meet.netlinkvoice.app.key”;
certificate = “/etc/prosody/certs/auth.meet.netlinkvoice.app.crt”;
}
authentication = “internal_plain”

Component “focus.meet.netlinkvoice.app”
component_secret = “da1zCstm”
Component “callcontrol.meet.netlinkvoice.app” component_secret = “HQlcHgE2”

VirtualHost “anonymous.meet.netlinkvoice.app”
authentication = “anonymous”
c2s_require_encryption = false

– internal muc component, meant to enable pools of jibri and jigasi clients
Component “internal.auth.meet.netlinkvoice.app” “muc”
modules_enabled = {
“ping”;
}
storage = “null”
muc_room_cache_size = 1000
c2s_require_encryption = false
– adding another virtual host
VirtualHost “recorder.meet.netlinkvoice.app”
modules_enabled = {
“ping”;
}
authentication = “internal_plain”
c2s_require_encryption = false

I have spent more than 10 hours trying to fix this issue but no luck. I also tried various combinations of
c2s_require_encryption = false or consider_bosh_secure=true. None of them worked. Please help us guys and I will really appreciate the help from this wonderful community.

Thanks and Regards

hi there

you are not alone. i have banged my head, reinstalled a zillion times and all cominations. I’m still stuck with the same dreaded “Timed Out waiting…” error

In case you were able to get it solved, please do let me know

That being said, you should not post your config files with real information. please mask if up you can

1 Like

Hi @masteryoda

Thanks for the reply. I was feeling lonely here lol. I have terminated my VPS because I got sucked and nobody helped me out here.

But yes I will let you know if I will fix this issue some day.

Hi bro. have you solved it ???
Cause i am right now in the same shoes of yours.
It will be a great help if anyone can help.

yes, it was an error on my end.

it had to do with the prosodyctl user creation

1 Like

Can you please elaborate.??
prosodyctl register jibri auth.domain.com passauth
prosodyctl register recorder recorder.domain.com passrecord

I have used this command to create prosodyctl user. Is there anything wrong here ?

these look correct

can you try pinging from the jibri server & see if you can resolve the domain.com from there?

else add the meet.domain.com to the /etc/hosts file and point it to the IP of the jitsi server

1 Like

Hey master, looks like im in the same situation here.

Could you help me and im sure a lot of other peopple how you solve this?
I Didnt understood what you mean using prosodyctl, im already did it and the /etc/hosts file are ok

I´m stuck here
2020-05-07 19:25:01.928 SEVERE: [51] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load
2020-05-07 19:25:01.930 INFO: [51] org.jitsi.jibri.selenium.JibriSelenium.onSeleniumStateChange() Transitioning from state Starting up to Error: SESSION Failed to join call
2020-05-07 19:25:01.931 INFO: [51] org.jitsi.jibri.service.impl.FileRecordingJibriService.onServiceStateChange() File recording service transitioning from state Starting up to Error: SESSION Failed to join call

Well, im sorry :sweat_smile:

i had a recorder recorderpassword111 and typed recorderpassword11 … missing one number, that was the problem.

I saw a lot of topics of peopple complaining about this same selenium SEVERE error, please check your username and password typing hahaha

Im recording, but now my recorder is joining the room. Still trying to figure out how to solve this :smiley:

in my case i used the wrong domain for recorder. once i corrected it , things started to work

thats what i meant

Could you elaborate? Let me post an example:

considering jitsi .my-domain .net is the subdomain of the server and looking at the config.json, there are some subdomains at play.

jitsi .my-domain .net
auth .jitsi .my-domain .net
recorder .jitsi .my-domain .net

So let’s create users and enter their credentials into the config.json:

prosodyctl register recorder jitsi .my-domain .net P4ssw0rd
prosodyctl register jibri jitsi .my-domain .net P4ssw0rd

prosodyctl register recorder auth. jitsi.my-domain .net P4ssw0rd
prosodyctl register jibri auth. jitsi .my-domain .net P4ssw0rd

Sounds good, doesn’t work. For me at least.

this was my mistake

Thanks… didn’t work for me though. I spammed user accounts with all subdomains and it still throws an error. I’ll open my own thread then.

try this

in the hosts file of the jibri server add the ip address of the jitsi meet server and resolve it as meet.mydomain.com, like this (just change your ip & domain)

192.168.10.50 meet.mydomain.com

I added meet.myTLD.com and meet.jitsi.myTLD.com into DNS and resolved from the server. No dice on the recording tho…

please try to add in the hosts file in jibri server too

Hi, sorry, only had the chance to access and restart the server now . Still the same error . Here’s the log file from /var/log/jitsi/jibri/

2020-05-13 15:01:24 .298 INFO: [1] org .jitsi .jibri .Main .main() Jibri run with args [–config, /etc/jitsi/jibri/config .json]
2020-05-13 15:01:24 .315 INFO: [1] org .jitsi .jibri .Main .main() Using config file /etc/jitsi/jibri/config .json
2020-05-13 15:01:24 .315 INFO: [1] org .jitsi .jibri .Main .main() Using port 3333 for internal HTTP API
2020-05-13 15:01:24 .316 INFO: [1] org .jitsi .jibri .Main .main() Using port 2222 for the HTTP API
2020-05-13 15:01:25 .475 INFO: [1] org .jitsi .jibri .Main .loadConfig() Parsed config:
JibriConfig(recordingDirectory=/recordings, singleUseMode=false, enabledStatsD=true, finalizeRecordingScriptPath=, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[jitsi .my-domain .net], xmppDom$
2020-05-13 15:01:26 .242 WARNING: [1] org .glassfish .jersey .internal .inject .Providers .checkProviderRuntime() A provider org .jitsi .jibri .api .http .internal .InternalHttpApi registered in SERVER runtime does not implement any provider inter$
2020-05-13 15:01:26 .548 INFO: [1] org .jitsi .jibri .api .xmpp .XmppApi .updatePresence() Jibri reports its status is now JibriStatus(busyStatus=IDLE, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connectio$
2020-05-13 15:01:26 .551 INFO: [1] org .jitsi .xmpp .mucclient .MucClientManager .log() Setting a presence extension: org .jitsi .xmpp .extensions .jibri .JibriStatusPacketExt@31be6b49
2020-05-13 15:01:26 .559 INFO: [1] org .jitsi .jibri .api .xmpp .XmppApi .start() Connecting to xmpp environment on jitsi .my-domain .net with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=[jitsi .rohnstock-biogr$
2020-05-13 15:01:26 .560 INFO: [1] org .jitsi .jibri .api .xmpp .XmppApi .start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2020-05-13 15:01:26 .581 WARNING: [21] org .jitsi .xmpp .mucclient .MucClient .log() Disabling certificate verification!
2020-05-13 15:01:26 .619 WARNING: [1] org .glassfish .jersey .internal .inject .Providers .checkProviderRuntime() A provider org .jitsi .jibri .api .http .HttpApi registered in SERVER runtime does not implement any provider interfaces applicable 2020-05-13 15:01:26 .852 INFO: [21] org .jitsi .xmpp .mucclient .MucClient .log() [MucClient id=jitsi .my-domain .net hostname=jitsi .my-domain .net] connected 2020-05-13 15:01:26 .930 INFO: [21] org .jitsi .xmpp .mucclient .MucClient .log() Joined MUC: jibribrewery@internal .auth .jitsi .my-domain .net 2020-05-13 15:04:43 .550 INFO: [43] org .jitsi .jibri .api .xmpp .XmppApi .handleJibriIq() Received JibriIq <iq to='jibri@auth .jitsi .my-domain .net/7ee0cae6-0dde-4c84-89ca-0652e3da0832' from='jibribrewery@internal .auth .jitsi .rohnsto
2020-05-13 15:04:43 .551 INFO: [43] org .jitsi .jibri .api .xmpp .XmppApi .handleStartJibriIq() Received start request
2020-05-13 15:04:43 .556 INFO: [43] org .jitsi .jibri .api .xmpp .XmppApi .handleStartJibriIq() Sending ‘pending’ response to start IQ
2020-05-13 15:04:43 .556 INFO: [44] org .jitsi .jibri .api .xmpp .XmppApi .run() Starting service
2020-05-13 15:04:43 .619 INFO: [44] org .jitsi .jibri .api .xmpp .XmppApi .handleStartService() Parsed call url info: CallUrlInfo(baseUrl=https://jitsi .my-domain .net, callName=f, urlParams=)
2020-05-13 15:04:43 .621 INFO: [44] org .jitsi .jibri .JibriManager .startFileRecording() Starting a file recording with params: FileRecordingRequestParams(callParams=CallParams(callUrlInfo=CallUrlInfo(baseUrl=https://jitsi .rohnstock-biogr$
2020-05-13 15:04:45 .040 INFO: [44] org .openqa .selenium .remote .ProtocolHandshake .createSession() Detected dialect: OSS
2020-05-13 15:04:45 .068 INFO: [44] org .jitsi .jibri .selenium .JibriSelenium .() Starting empty call check with a timeout of PT30S
2020-05-13 15:04:45 .086 FINE: [44] org .jitsi .jibri .capture .ffmpeg .FfmpegCapturer .() Detected os as OS: LINUX
2020-05-13 15:04:45 .093 INFO: [44] org .jitsi .jibri .service .impl .FileRecordingJibriService .() Writing recording to /recordings/wrjqntohsujuclsl
2020-05-13 15:04:45 .097 FINE: [44] org .jitsi .jibri .statsd .JibriStatsDClient .incrementCounter() Incrementing statsd counter: start:recording
2020-05-13 15:04:45 .097 INFO: [44] org .jitsi .jibri .status .JibriStatusManager .log() Busy status has changed: IDLE -> BUSY
2020-05-13 15:04:45 .098 INFO: [44] org .jitsi .jibri .api .xmpp .XmppApi .updatePresence() Jibri reports its status is now JibriStatus(busyStatus=BUSY, health=OverallHealth(healthStatus=HEALTHY, details={})), publishing presence to connecti$
2020-05-13 15:04:45 .098 INFO: [44] org .jitsi .xmpp .mucclient .MucClientManager .log() Setting a presence extension: org .jitsi .xmpp .extensions .jibri .JibriStatusPacketExt@1723a532
2020-05-13 15:04:46 .153 FINE: [54] org .jitsi .jibri .selenium .pageobjects .CallPage .visit() Visiting url https://jitsi .my-domain .net/f#config .iAmRecorder=true&config .externalConnectUrl=null&config .startWithAudioMuted=true&confi$
2020-05-13 15:05:16 .894 SEVERE: [54] org .jitsi .jibri .selenium .pageobjects .CallPage .visit() Timed out waiting for call page to load
2020-05-13 15:05:16 .897 INFO: [54] org .jitsi .jibri .selenium .JibriSelenium .onSeleniumStateChange() Transitioning from state Starting up to Error: SESSION Failed to join call
2020-05-13 15:05:16 .898 INFO: [54] org .jitsi .jibri .service .impl .FileRecordingJibriService .onServiceStateChange() File recording service transitioning from state Starting up to Error: SESSION Failed to join call
2020-05-13 15:05:16 .899 INFO: [54] org .jitsi .jibri .api .xmpp .XmppApi .invoke() Current service had an error, sending error iq <jibri xmlns=$
2020-05-13 15:05:16 .899 FINE: [54] org .jitsi .jibri .statsd .JibriStatsDClient .incrementCounter() Incrementing statsd counter: stop:recording
2020-05-13 15:05:16 .900 INFO: [54] org .jitsi .jibri .JibriManager .stopService() Stopping the current service
2020-05-13 15:05:16 .900 INFO: [54] org .jitsi .jibri .service .impl .FileRecordingJibriService .stop() Stopping capturer
2020-05-13 15:05:16 .901 INFO: [54] org .jitsi .jibri .util .JibriSubprocess .ffmpeg .stop() Stopping ffmpeg process
2020-05-13 15:05:16 .901 INFO: [54] org .jitsi .jibri .util .JibriSubprocess .ffmpeg .stop() ffmpeg exited with value null
2020-05-13 15:05:16 .901 INFO: [54] org .jitsi .jibri .service .impl .FileRecordingJibriService .stop() Quitting selenium

And here’s my config .json

// NOTE: this is a SAMPLE config file, it will need to be configured with
// values from your environment

// Where recording files should be temporarily stored
"recording_directory":"/recordings",
// The path to the script which will be run on completed recordings
"finalize_recording_script_path": "",
"xmpp_environments": [
    {
        // A friendly name for this environment which can be used
        //  for logging, stats, etc  .
        "name": "prod environment",
        // The hosts of the XMPP servers to connect to as part of
        //  this environment
        "xmpp_server_hosts": [
            "jitsi  .my-domain  .net"
        ],
        // The xmpp domain we'll connect to on the XMPP server
        "xmpp_domain": "jitsi  .my-domain  .net",
        // Jibri will login to the xmpp server as a privileged user 
        "control_login": {
            // The domain to use for logging in
            "domain": "auth  .jitsi  .my-domain  .net",
            // The credentials for logging in
            "username": "jibri",
            "password": "P4ssw0rd"
        },
        // Using the control_login information above, Jibri will join 
        //  a control muc as a means of announcing its availability 
        //  to provide services for a given environment
        "control_muc": {
            "domain": "internal  .auth  .jitsi  .my-domain  .net",
            "room_name": "JibriBrewery",
            "nickname": "jibri"
        },
        // All participants in a call join a muc so they can exchange
        //  information  .  Jibri can be instructed to join a special muc
        //  with credentials to give it special abilities (e  .g  . not being
        //  displayed to other users like a normal participant)

“call_login”: {
“domain”: “recorder .jitsi .my-domain .net”,
“username”: “recorder”,
“password”: “P4ssw0rd”
},
// When jibri gets a request to start a service for a room, the room
// jid will look like:
// roomName@optional .prefixes .subdomain .xmpp_domain
// We’ll build the url for the call by transforming that into:
// https://xmpp_domain/subdomain/roomName
// So if there are any prefixes in the jid (like jitsi meet, which
// has its participants join a muc at conference .xmpp_domain) then
// list that prefix here so it can be stripped out to generate
// the call url correctly
“room_jid_domain_string_to_strip_from_start”: “conference .”,
// The amount of time, in minutes, a service is allowed to continue .
// Once a service has been running for this long, it will be
// stopped (cleanly) . A value of 0 means an indefinite amount
// of time is allowed
“usage_timeout”: “0”
}
]
}

I had to add a space in front of every period because “new users can only post two links”.
Any ideas?

leme know if you guys solved those problem.
im also stuck at that severe problem.

[100] org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Timed out waiting for call page to load

even with my laptop browser i can open link that used in CallPage.visit()

org.jitsi.jibri.selenium.pageobjects.CallPage.visit() Visiting url https://domainname/1#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME=“Jibri”&config.analytics.disabled=true&config.p2p.enabled=false

Include the browser logs from Jibri as well

Here’s the browser log. https://pastebin.com/kGcEP9JB

Here’s the config.json again in case it’s better readable: https://pastebin.com/ZDgivWNt