Jibri start fails on Redhat Linux

At first sight, looks like a known problem. There are a lot of question about it and their solution in the community channel. However, this solution looks useless for my case. Basically, the problem is chrome driver cannot run chrome stable binary on RHEL 7 machines. The messaging between the prosody, the jicofo and the jibri nodes look OK.

2020-06-16 00:03:53.575 SEVERE: [36] org.jitsi.jibri.api.xmpp.XmppApi.run() Error starting Jibri service : org.openqa.selenium.WebDriverException: unknown error: Chrome failed to start: exited abnormally.
(unknown error: DevToolsActivePort file doesn’t exist)

And the basic recommended solution is to fix JibriSelenium.kt by adding those ones “–no-sandbox”, “–disable-dev-shm-usage”, “–headless”.

However, when I did it, I noticed that there is no change in the chromedriver logs. I added those three options in the Chromeoptions, however these options was disappeared somehow:

[1592255033.421][INFO]: Launching chrome: /usr/bin/google-chrome --autoplay-policy=no-user-gesture-required --disable-background-networking --disable-client-side-phishing-detection --disable-default-apps --disable-hang-monitor --disable-infobars --disable-popup-blocking --disable-prompt-on-repost --disable-sync --enable-automation --enable-blink-features=ShadowDOMV0 --enable-logging --enabled --kiosk --load-extension=/tmp/.com.google.Chrome.R4mHBK/internal --log-level=0 --no-first-run --password-store=basic --remote-debugging-port=0 --start-maximized --test-type=webdriver --use-fake-ui-for-media-stream --use-mock-keychain --user-data-dir=/tmp/.com.google.Chrome.X5eFYb data:,
[1592255033.573][INFO]: [5b4e66775e7a3646ea58ac6f55cfbe62] RESPONSE InitSession ERROR unknown error: Chrome failed to start: exited abnormally.
(unknown error: DevToolsActivePort file doesn’t exist)
(The process started from chrome location /usr/bin/google-chrome is no longer running, so ChromeDriver is assuming that Chrome has crashed.)

I built jibri on several different machines such as windows by command line, by Intellij, linux by command line etc. Not surprisingly, the same result I had.

I’m pretty sure that my extra options has been put in the class:

[jibri@aselpractice01 target] find . -type f | xargs grep "no-sandbox" Binary file ./classes/org/jitsi/jibri/selenium/JibriSelenium.class matches [jibri@aselpractice01 target] find . -type f | xargs grep “headless”
Binary file ./classes/org/jitsi/jibri/selenium/JibriSelenium.class matches
[jibri@aselpractice01 target] find . -type f | xargs grep "disable-dev-shm" Binary file ./classes/org/jitsi/jibri/selenium/JibriSelenium.class matches [jibri@aselpractice01 target] find . -type f | xargs grep “kiosk”
Binary file ./classes/org/jitsi/jibri/selenium/JibriSelenium.class matches

I don’t think it’s related to RHEL7. However, just in case, I highlighted it.

So, I feel I missed something essential. Especially in the maven build mechanism. But I can not get rid of this problem.

Do you have any idea about it?

Solved! Basically I had tried to run wrong jar file for a while. This mistake is related to Debian-Redhat file system differences. Thanks…