Jibri.service: Failed

Hi,
when executing service jibri status , getting the below error

● jibri.service - Jibri Process
Loaded: loaded (/etc/systemd/system/jibri.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2021-11-26 13:31:09 UTC; 19s ago
Process: 14726 ExecStart=/opt/jitsi/jibri/launch.sh (code=exited, status=127)
Main PID: 14726 (code=exited, status=127)

Nov 26 13:31:09 jibri.jaam.co systemd[1]: jibri.service: Main process exited, code=exited, status=127/n/a
Nov 26 13:31:09 jibri.jaam.co systemd[1]: jibri.service: Failed with result ‘exit-code’.
Nov 26 13:31:09 jibri.jaam.co systemd[1]: jibri.service: Service hold-off time over, scheduling restart.
Nov 26 13:31:09 jibri.jaam.co systemd[1]: jibri.service: Scheduled restart job, restart counter is at 5.
Nov 26 13:31:09 jibri.jaam.co systemd[1]: Stopped Jibri Process.
Nov 26 13:31:09 jibri.jaam.co systemd[1]: jibri.service: Start request repeated too quickly.
Nov 26 13:31:09 jibri.jaam.co systemd[1]: jibri.service: Failed with result ‘exit-code’.
Nov 26 13:31:09 jibri.jaam.co systemd[1]: Failed to start Jibri Process.

Please help on this.

Thanks

Did you install as root user? Share your jibri.conf and Jibri log (if you were able to generate one).

I have not installed as root user.
jibri.conf
jibri {
id = “”
single-use-mode = false

recording {
recordings-directory = “/srv/recordings”
#finalize-script = “/usr/local/bin/finalize_recording.sh”
}

streaming {
rtmp-allow-list = [
“.*”
]
}

chrome {
flags = [
// “–ignore-certificate-errors”,
“–use-fake-ui-for-media-stream”,
“–start-maximized”,
“–kiosk”,
“–enabled”,
“–disable-infobars”,
“–autoplay-policy=no-user-gesture-required”
]
}

ffmpeg {
resolution = “1920x1080”
audio-source = “alsa”
audio-device = “plug:bsnoop”
}

api {
http {
internal-api-port = 2222
external-api-port = 3333
}

xmpp {
  environments = [{
    name = "eb-environment"
    xmpp-server-hosts = ["---jitsi server domain--"]
    xmpp-domain = "---jitsi server domain--"

    control-muc {
      domain = "internal.auth.---jitsi server domain--"
      room-name = "JibriBrewery"
      nickname = "jibri-nickname2"
    }

    control-login {
      domain = "auth.---jitsi server domain--"
      username = "jibri2"
      password = "jibripass"
    }

    call-login {
      domain = "recorder.---jitsi server domain--"
      username = "recorder2"
      password = "recorderpass"
    }

    strip-from-room-domain = "conference."
    usage-timeout = 0
    trust-all-xmpp-certs = true
  }]
}

}

stats {
enable-stats-d = true
}

call-status-checks {
no-media-timeout = 30 seconds
all-muted-timeout = 10 minutes
default-call-empty-timeout = 30 seconds
}
}
jibri log
I went into cd /var/log/jitsi/jibri …There were no jibri logs.

I have given jitsi domain in jibri.conf. Is that correct?

You need to uninstall and reinstall as root user. Follow the guides:

Thank you . I read the documents.

  1. In jibri server , how do I set the hostname?

sudo hostnamectl set-hostname —jitsi meet domain –
OR
sudo hostnamectl set-hostname —jibri domain –

  1. In jibri server , what to add in /etc/hosts
    127.0.0.1 localhost
    IP address of jitsi meet ----jitsi meet domain
    ping "$(jitsi domain name)"

    OR
    

127.0.0.1 localhost
IP address of jibri meet ----jibri domain
ping "$(jibri domain name)"

Please tell me the correct way to do.

There is no need a domain name for jibri

Ok… in jibri server,I will then set Jitsi domain in /etc/hosts and in hostctl set hostname = Jitsi domain
Or
Should I not set anything in jibri server?

If jibri is on a seperate server and if jibri can resolv jitsi's FQDN, you don’t need to set anything.

If jibri cannot resolv jitsi's FQDN, add it to /etc/hosts

Thank you emrah. We have successfully done the setup of second jibri.